Episerver Commerce
User Guide
# Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table of contents</strong></td>
<td>3</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>15</td>
</tr>
<tr>
<td>Features, licenses and releases</td>
<td>15</td>
</tr>
<tr>
<td>Copyright notice</td>
<td>16</td>
</tr>
<tr>
<td><strong>What's new?</strong></td>
<td>17</td>
</tr>
<tr>
<td><strong>About Episerver</strong></td>
<td>18</td>
</tr>
<tr>
<td>Features</td>
<td>18</td>
</tr>
<tr>
<td>CMS</td>
<td>18</td>
</tr>
<tr>
<td>Commerce</td>
<td>18</td>
</tr>
<tr>
<td>Add-ons</td>
<td>19</td>
</tr>
<tr>
<td><strong>Getting started</strong></td>
<td>20</td>
</tr>
<tr>
<td>Logging in</td>
<td>20</td>
</tr>
<tr>
<td>Accessing features</td>
<td>20</td>
</tr>
<tr>
<td>Navigation</td>
<td>20</td>
</tr>
<tr>
<td>Next steps</td>
<td>21</td>
</tr>
<tr>
<td>User interface</td>
<td>21</td>
</tr>
<tr>
<td>General features</td>
<td>22</td>
</tr>
<tr>
<td>Panes</td>
<td>24</td>
</tr>
<tr>
<td>Left-hand navigation pane</td>
<td>24</td>
</tr>
<tr>
<td>Right-hand assets pane</td>
<td>24</td>
</tr>
<tr>
<td>Editing</td>
<td>25</td>
</tr>
<tr>
<td>Real-time Updates</td>
<td>26</td>
</tr>
<tr>
<td>Network problems</td>
<td>27</td>
</tr>
<tr>
<td>WebSocket support</td>
<td>27</td>
</tr>
<tr>
<td>My settings</td>
<td>28</td>
</tr>
<tr>
<td>Roles and tasks</td>
<td>28</td>
</tr>
</tbody>
</table>

© Episerver 2016
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Commerce Categories</td>
<td>52</td>
</tr>
<tr>
<td>Creating a category</td>
<td>53</td>
</tr>
<tr>
<td>Viewing an item’s categories</td>
<td>54</td>
</tr>
<tr>
<td>View items assigned to a category</td>
<td>54</td>
</tr>
<tr>
<td>Editing a category</td>
<td>54</td>
</tr>
<tr>
<td>Deleting a category</td>
<td>54</td>
</tr>
<tr>
<td>Linking a catalog entry to a category</td>
<td>55</td>
</tr>
<tr>
<td>Detaching a catalog entry from a category</td>
<td>56</td>
</tr>
<tr>
<td>Creating a catalog entry</td>
<td>57</td>
</tr>
<tr>
<td>Types of catalog entries</td>
<td>58</td>
</tr>
<tr>
<td>Creating a variant</td>
<td>59</td>
</tr>
<tr>
<td>Translating catalog content</td>
<td>60</td>
</tr>
<tr>
<td>Saving and publishing</td>
<td>60</td>
</tr>
<tr>
<td>Moving a catalog entry</td>
<td>60</td>
</tr>
<tr>
<td>Duplicating a catalog entry</td>
<td>61</td>
</tr>
<tr>
<td>Editing a product or variant</td>
<td>62</td>
</tr>
<tr>
<td>Editing multiple catalog entries</td>
<td>63</td>
</tr>
<tr>
<td>Updating multiple catalog entries at once</td>
<td>64</td>
</tr>
<tr>
<td>Deleting a product or variant</td>
<td>65</td>
</tr>
<tr>
<td>Catalog entry properties</td>
<td>66</td>
</tr>
<tr>
<td>Header</td>
<td>66</td>
</tr>
<tr>
<td>Tabs</td>
<td>67</td>
</tr>
<tr>
<td>Menu options</td>
<td>73</td>
</tr>
<tr>
<td>Editing a package or bundle</td>
<td>74</td>
</tr>
<tr>
<td>Working with packages</td>
<td>75</td>
</tr>
<tr>
<td>Working with bundles</td>
<td>75</td>
</tr>
<tr>
<td>Deleting a package or bundle</td>
<td>77</td>
</tr>
<tr>
<td>Managing pricing</td>
<td>77</td>
</tr>
</tbody>
</table>
Viewing prices ........................................................................................................... 78
Adding and editing prices ......................................................................................... 79
Setting customer group pricing ............................................................................... 80

Orders .......................................................................................................................... 81
Meta-classes and meta-fields ....................................................................................... 81
Browsing orders ........................................................................................................... 81
Searching and viewing orders .................................................................................... 81
Order summary preview .............................................................................................. 82
Viewing orders by time range or status ..................................................................... 82
Viewing orders per market .......................................................................................... 83

Creating an order ......................................................................................................... 83
Creating an order from order list ................................................................................ 84
Creating an order within a contact ............................................................................. 84

Processing an order ..................................................................................................... 88
Splitting a shipment .................................................................................................... 91

Setting up a payment plan .......................................................................................... 93
Payment plan order detail page explained .................................................................. 95
Editing and canceling a payment plan ....................................................................... 96
Creating a recurring payment plan using Authorize.Net ........................................ 96

Editing, canceling, and deleting orders ..................................................................... 97
Editing an order ........................................................................................................... 97
Canceling an order ...................................................................................................... 97
Deleting an order ......................................................................................................... 98

Shipping and receiving ............................................................................................... 98
Creating a picklist ........................................................................................................ 99
Completing a shipment ............................................................................................... 101
Printing a picklist and packing slip ........................................................................... 103
Removing items and deleting picklists ....................................................................... 104
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Removing items from a picklist</td>
<td>104</td>
</tr>
<tr>
<td>Deleting picklists</td>
<td>104</td>
</tr>
<tr>
<td>Shopping carts</td>
<td>104</td>
</tr>
<tr>
<td>Creating a shopping cart</td>
<td>105</td>
</tr>
<tr>
<td>Converting a shopping cart</td>
<td>105</td>
</tr>
<tr>
<td>Returns and exchanges</td>
<td>107</td>
</tr>
<tr>
<td>Initiating a return</td>
<td>108</td>
</tr>
<tr>
<td>Initiating an exchange order</td>
<td>111</td>
</tr>
<tr>
<td>Customers</td>
<td>114</td>
</tr>
<tr>
<td>Organizations</td>
<td>115</td>
</tr>
<tr>
<td>Browsing organizations</td>
<td>115</td>
</tr>
<tr>
<td>Viewing organization details</td>
<td>116</td>
</tr>
<tr>
<td>Searching for an organization</td>
<td>116</td>
</tr>
<tr>
<td>Customizing views for browsing organizations</td>
<td>116</td>
</tr>
<tr>
<td>Editing and deleting views</td>
<td>119</td>
</tr>
<tr>
<td>Customized view example</td>
<td>119</td>
</tr>
<tr>
<td>Printing a list of organizations</td>
<td>120</td>
</tr>
<tr>
<td>Creating or editing an organization</td>
<td>120</td>
</tr>
<tr>
<td>Creating an organizational hierarchy</td>
<td>122</td>
</tr>
<tr>
<td>Deleting an organization</td>
<td>123</td>
</tr>
<tr>
<td>Adding dictionary values for an organization</td>
<td>124</td>
</tr>
<tr>
<td>Creating, editing and deleting business categories</td>
<td>126</td>
</tr>
<tr>
<td>Contacts</td>
<td>126</td>
</tr>
<tr>
<td>Browsing contacts</td>
<td>126</td>
</tr>
<tr>
<td>Searching for a contact</td>
<td>128</td>
</tr>
<tr>
<td>Customizing views for browsing contacts</td>
<td>128</td>
</tr>
<tr>
<td>Editing and deleting views</td>
<td>131</td>
</tr>
<tr>
<td>Printing a list of contacts</td>
<td>132</td>
</tr>
</tbody>
</table>
Creating a contact with an account ................................................................. 133
Editing or deleting a contact and account ...................................................... 137
Adding dictionary values for a contact .......................................................... 137
Roles and tasks ....................................................................................... 139
Visitor ........................................................................................................ 139
Community member .................................................................................. 139
Content editor ........................................................................................... 140
Marketer ..................................................................................................... 140
Merchandiser .............................................................................................. 140
Website owner ............................................................................................ 140
Administrator .............................................................................................. 140
Developer .................................................................................................. 141
Markets ....................................................................................................... 142
Defining markets ....................................................................................... 142
Browsing markets ...................................................................................... 142
Creating or editing a market ......................................................................... 143
Deleting a market ....................................................................................... 145
Marketing .................................................................................................. 146
Campaigns and discounts ........................................................................ 146
Campaign overview .................................................................................... 147
Creating a campaign .................................................................................. 148
Editing a campaign ................................................................................... 151
Deleting a campaign .................................................................................. 151
Discounts ................................................................................................... 151
Discount colors ......................................................................................... 151
Creating a discount ................................................................................... 152
Example: Buy three items, get cheapest free ............................................... 154
Selecting discount-eligible items ................................................................. 155
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How Episerver Commerce determines which items to discount</td>
<td>156</td>
</tr>
<tr>
<td>Using promotion codes</td>
<td>157</td>
</tr>
<tr>
<td>Applying redemption limits</td>
<td>158</td>
</tr>
<tr>
<td>Built-in discounts</td>
<td>159</td>
</tr>
<tr>
<td>Prioritizing discounts</td>
<td>183</td>
</tr>
<tr>
<td>Discount exclusions</td>
<td>184</td>
</tr>
<tr>
<td>Campaigns (Legacy)</td>
<td>186</td>
</tr>
<tr>
<td>Browsing campaigns (Legacy)</td>
<td>186</td>
</tr>
<tr>
<td>Managing campaigns (Legacy)</td>
<td>187</td>
</tr>
<tr>
<td>Deleting a campaign</td>
<td>190</td>
</tr>
<tr>
<td>Promotions (Legacy)</td>
<td>190</td>
</tr>
<tr>
<td>Browsing promotions (Legacy)</td>
<td>191</td>
</tr>
<tr>
<td>Creating an entry-level promotion (Legacy)</td>
<td>192</td>
</tr>
<tr>
<td>Example: Build your own discount - &quot;40% off wine decanter&quot;</td>
<td>192</td>
</tr>
<tr>
<td>Example: Buy catalog entry X, get catalog entry Y at a discount</td>
<td>195</td>
</tr>
<tr>
<td>Example: Buy X get $ off discount</td>
<td>196</td>
</tr>
<tr>
<td>Creating an order-level promotion (Legacy)</td>
<td>196</td>
</tr>
<tr>
<td>Example: Buy X, get N quantity of Y at a discount</td>
<td>196</td>
</tr>
<tr>
<td>Example: Order Sub Total Volume Discount</td>
<td>197</td>
</tr>
<tr>
<td>Example: Build Your Own Discount</td>
<td>197</td>
</tr>
<tr>
<td>Creating a shipping-level promotion (Legacy)</td>
<td>198</td>
</tr>
<tr>
<td>Example: buy N quantity get % off shipment discount</td>
<td>198</td>
</tr>
<tr>
<td>Creating a custom promotion (Legacy)</td>
<td>199</td>
</tr>
<tr>
<td>Setting customer group promotions (Legacy)</td>
<td>200</td>
</tr>
<tr>
<td>Editing and activating promotions (Legacy)</td>
<td>203</td>
</tr>
<tr>
<td>Editing a promotion</td>
<td>203</td>
</tr>
<tr>
<td>Activating and inactivating promotions</td>
<td>204</td>
</tr>
<tr>
<td>Deleting a promotion</td>
<td>205</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Customizing the left menu</td>
<td>246</td>
</tr>
<tr>
<td>Adding a left menu item</td>
<td>246</td>
</tr>
<tr>
<td>Catalog system administration</td>
<td>251</td>
</tr>
<tr>
<td>Warehouses</td>
<td>251</td>
</tr>
<tr>
<td>Deleting a warehouse</td>
<td>253</td>
</tr>
<tr>
<td>Tax categories</td>
<td>254</td>
</tr>
<tr>
<td>Deleting a tax category</td>
<td>254</td>
</tr>
<tr>
<td>Catalog meta-classes and meta-fields</td>
<td>255</td>
</tr>
<tr>
<td>Creating a catalog meta class</td>
<td>255</td>
</tr>
<tr>
<td>Creating a catalog meta field</td>
<td>256</td>
</tr>
<tr>
<td>Applying meta fields to a meta class</td>
<td>258</td>
</tr>
<tr>
<td>Order system administration</td>
<td>259</td>
</tr>
<tr>
<td>Payments</td>
<td>260</td>
</tr>
<tr>
<td>Setting up a payment</td>
<td>261</td>
</tr>
<tr>
<td>Editing payment methods</td>
<td>264</td>
</tr>
<tr>
<td>Deleting payment methods</td>
<td>265</td>
</tr>
<tr>
<td>Using nSoftware-provided payment gateways</td>
<td>265</td>
</tr>
<tr>
<td>Shipping</td>
<td>267</td>
</tr>
<tr>
<td>Shipping methods</td>
<td>268</td>
</tr>
<tr>
<td>Shipping providers</td>
<td>272</td>
</tr>
<tr>
<td>Configuring taxes</td>
<td>273</td>
</tr>
<tr>
<td>Configuring taxes manually</td>
<td>273</td>
</tr>
<tr>
<td>Configuring taxes using CSV import</td>
<td>274</td>
</tr>
<tr>
<td>Sample CSV files and scenarios</td>
<td>275</td>
</tr>
<tr>
<td>Order meta-classes and meta-fields</td>
<td>276</td>
</tr>
<tr>
<td>Creating an order meta-class</td>
<td>276</td>
</tr>
<tr>
<td>Creating an order meta-field</td>
<td>277</td>
</tr>
<tr>
<td>Applying meta fields to a meta-class</td>
<td>279</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Scheduled jobs</td>
<td>280</td>
</tr>
<tr>
<td>Subscription payment plans</td>
<td>281</td>
</tr>
<tr>
<td>Remove expired carts</td>
<td>281</td>
</tr>
<tr>
<td>Full search index</td>
<td>281</td>
</tr>
<tr>
<td>Draft store migration</td>
<td>281</td>
</tr>
<tr>
<td>Shipment releasing</td>
<td>281</td>
</tr>
<tr>
<td>Rotate encryption keys</td>
<td>281</td>
</tr>
<tr>
<td>Incremental search index</td>
<td>281</td>
</tr>
<tr>
<td><strong>Managing content</strong></td>
<td>283</td>
</tr>
<tr>
<td>Catalog content</td>
<td>283</td>
</tr>
<tr>
<td>Catalogs gadget</td>
<td>285</td>
</tr>
<tr>
<td>Commerce-specific gadgets</td>
<td>286</td>
</tr>
<tr>
<td>Multiple language content</td>
<td>287</td>
</tr>
<tr>
<td>Personalized content</td>
<td>287</td>
</tr>
<tr>
<td>Find and best bets for catalog content</td>
<td>287</td>
</tr>
<tr>
<td>Managing languages in Commerce</td>
<td>287</td>
</tr>
<tr>
<td>Enabling a language for catalog content</td>
<td>287</td>
</tr>
<tr>
<td>Translating content for catalog entries</td>
<td>288</td>
</tr>
<tr>
<td>Switching language and viewing language versions</td>
<td>289</td>
</tr>
<tr>
<td>Editing global properties</td>
<td>289</td>
</tr>
<tr>
<td>Setting the user interface language</td>
<td>289</td>
</tr>
<tr>
<td><strong>Personalization</strong></td>
<td>290</td>
</tr>
<tr>
<td>Commerce-specific criteria</td>
<td>290</td>
</tr>
<tr>
<td>How visitor groups are used</td>
<td>291</td>
</tr>
<tr>
<td><strong>Gadgets</strong></td>
<td>291</td>
</tr>
<tr>
<td>Commerce orders gadget</td>
<td>291</td>
</tr>
<tr>
<td>Commerce overview gadget</td>
<td>292</td>
</tr>
<tr>
<td>Commerce settings for CMO gadget</td>
<td>292</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Adding or editing Commerce settings for the CMO gadget</td>
<td>293</td>
</tr>
<tr>
<td>Deleting Commerce settings for the CMO gadget</td>
<td>294</td>
</tr>
<tr>
<td>Access rights</td>
<td>294</td>
</tr>
<tr>
<td>Managing users and groups</td>
<td>294</td>
</tr>
<tr>
<td>Groups and access rights</td>
<td>294</td>
</tr>
<tr>
<td>Groups for controlling access to basic parts of the system</td>
<td>295</td>
</tr>
<tr>
<td>Groups for providing specific access in Commerce Manager</td>
<td>295</td>
</tr>
<tr>
<td>Controlling user access for Commerce functions</td>
<td>296</td>
</tr>
<tr>
<td>Controlling access to the content structure</td>
<td>296</td>
</tr>
<tr>
<td>Index</td>
<td>299</td>
</tr>
</tbody>
</table>
Introduction

The features and functionality of the entire Episerver platform are described in an online help that opens in a web browser. The online help covers CMS for content management, Commerce for e-commerce functionality, Find for extended search, and Episerver add-ons. It is either accessed from within the Episerver platform or from Episerver World. The online help is also divided into a number of PDFs for users who prefer those or want to print the documentation.

This PDF describes the features and functionality of Episerver Commerce. PDFs for Episerver CMS and Find can be found on Episerver World. The user documentation is intended for editors, administrators, marketers and merchandisers, working with tasks as described in Roles and tasks.

Features, licenses and releases

The user documentation is continuously updated and covers the latest releases for the Episerver platform.

- **CMS**
  Episerver CMS is the core part of the Episerver platform providing advanced content creation and publishing features for all types of website content. CMS features are available in all Episerver installations.

- **Commerce**
  Episerver Commerce adds complete e-commerce capabilities to the core functionality in CMS. Commerce requires additional license activation.

- **Add-ons**
  Add-ons extend the Episerver capabilities with features like advanced search, multivariate testing, and social media integration. Some add-ons are free, others require
license activation. Add-ons by Episerver are described in the online help.

Due to frequent feature releases, this user guide may describe functionality that is not yet available on your website. Refer to What’s new to find out in which area and release a specific feature became available.

Copyright notice

© Episerver 1996 – 2016. All rights reserved.

All information and content within this document is the sole copyright of Episerver. Changes to the contents, or partial copying of the contents, may not be done without permission. The document may be freely distributed in its entirety, either digitally or in printed format, to all users of Episerver Software. We assume no liability or responsibility for any errors or omissions in the content of this document. We reserve the right to alter functionality and technical system requirements. Episerver is a registered trademark of Episerver AB. Ektron is a registered trademark of Episerver Inc.
What's new?

The Episerver user guide describes features in the Episerver platform, including CMS for content management and Commerce for e-commerce management, and add-ons from Episerver. New features are continuously made available through Episerver updates.

This user guide (16-8) describes features added up until and including update 137 for Episerver; see Episerver World for previous user guide versions.

<table>
<thead>
<tr>
<th>Area</th>
<th>Features and updates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commerce</td>
<td>This version of the user guide contains no updates to the Episerver Commerce sections.</td>
</tr>
</tbody>
</table>
About Episerver

The base of the Episerver platform is the CMS (Content Management System) with its core features for online content creation, publishing, and website management. The platform can be extended with Episerver Commerce for managing e-commerce tasks, and Episerver Find for building advanced search features, as well as a broad selection of other add-ons from both Episerver and third-parties.

Features

Episerver CMS is a powerful yet easy to use web content management platform, based on cutting edge technology. The intuitive user interface and superior usability of Episerver CMS allow both experienced and occasional users to efficiently manage website content. Refer to the Managing content section in the CMS Editor user guide for more information on how to work with CMS features.

Adding Episerver Commerce to your CMS solution brings e-commerce functionality such as catalog, customer and order management, combining the powerful content publishing and display features of...
CMS with advanced back-end online store management. Refer to the Commerce user guide for more information about Episerver Commerce features.

**Add-ons**

There are many add-ons available for extending your Episerver solution. The add-ons from Episerver described in this documentation add features such as advanced search, Google Analytics and social media integrations. Refer to the Add-ons section in the online help for more information about Episerver add-ons.

Refer to [Introduction](#) and [What's new](#) for information about licenses and recent features.
Getting started

This section describes how to log in to an Episerver website, access features and navigate the different views. Note that the login procedure may be different from what is described here, depending on how your website and infrastructure are set up. The examples described here are based on a “standard” installation of Episerver with sample templates.

Logging in

As an editor or administrator, you usually log in to your website using a specified URL, a login button or link. Enter your user name and password in the Episerver login dialog, and click Log In.

Accessing features

What you are allowed to do after logging in depends on your implementation and your access rights, since these control the options you see. When logged in, the Episerver quick access menu is displayed in the upper right corner.

Selecting CMS Edit takes you to the edit view as well as other parts of the system. You can go directly to your personal dashboard by selecting the Dashboard option.

Navigation

Pull down the global menu, available at the very top, to navigate around. The menu displays the different products and systems integrated with your website. Select, for instance, CMS to display available options in the submenu.

Your menu options vary depending on your access rights. These user guide examples assume that the user has full permissions to all functions in Episerver.
Next steps

Refer to the sections below for more information.

- User interface and Roles and tasks in the CMS Editor User Guide for information about the Episerver user interface and roles.
- Managing content in the CMS Editor User Guide for information on how to create and publish content.
- Administration interface in the CMS Administrator User Guide for information on how to administer and configure settings in Episerver.
- Commerce User Guide for information on how to work with e-commerce tasks, if you have Episerver Commerce installed.
- Find User Guide for information on how to work with search optimization, if you have Episerver Find installed.
- Add-ons section in the online help for information on how to use add-ons from Episerver, if you have any of these installed.

User interface

The Episerver user interface is flexible allowing developers to plug-in customized features when implementing websites. This description refers to a “standard installation” of Episerver without customizations.

The toolbar and the panes in the Episerver edit view provide easy access to functions when working with content. When entering the edit view, you have the global menu and the toolbar at the top, and adjustable panes to the left and right.
The **global menu** provides access to other areas of the Episerver platform. You can also access this user guide, your user settings and a global search from the global menu. Note that you in some areas need to pull down the global menu with the arrow.

The toolbar contains features like preview and view options, and lets you add items such as pages or blocks.

The page information area below the toolbar displays the page name, the path to the page and when it was last autosaved. If it is possible to undo the latest changes you did to the content, there is also an **Undo** link.

A notification toolbar may be displayed below the toolbar showing confirmation and error messages and such.

**General features**

- **Context-sensitive actions.** Some features are only available in certain context. The toolbar, for instance, presents relevant actions depending on what you are currently doing, and the add (+) button also offers context-sensitive options.

- **Primary actions.** Some actions open in a new window, for example, a page delete confirmation. The background is then dimmed, meaning that you must finish the primary action to continue.
Action feedback and notifications. Successful actions are confirmed by a message in the notification bar. A notification may also appear in case of an error requiring you to take action.

Drag-and-drop operations. Drag-and-drop is supported in many areas. For instance, you can drag pages, media files and blocks into the rich-text area or content areas, or re-arrange the page tree structure using drag-and-drop.

Tooltips. Hover the mouse over a button or field and a short tooltip is displayed.

Keyboard commands. Standard keyboard commands are supported in many areas, for instance, when moving pages in the page tree or in the rich-text editor.

Search. Supported in many areas to locate, for instance, pages in the page tree or media in the folder structure.

Adaptable work environment. Resize and pin the panes depending on what you are currently doing, and add and remove gadgets of your choice for quick access to functionality.

Support for time zones. Publishing actions in the edit view are done in your local time zone, whereas administrative actions are based on server time.

Context menus are available in many areas, for instance, in the panes, the page tree and in item listings. The menu displays different available options depending on where in the interface you are and what you are doing.
Panes

The user interface has a left-hand and a right-hand pane, which can be adjusted and extended with additional gadgets.

- **Pane pin** is used for expanding and locking the panes in an open position.
- **Settings** for a pane or a gadget allow you to configure or remove a gadget, or rearrange gadgets in a pane.

Left-hand navigation pane

Contains the page tree structure (Pages), language branch (Sites) navigation, tasks management (Tasks), and project items (Project Items) by default.

Right-hand assets pane

Contains the Media and Blocks folder structures by default. Drag and drop items from the assets pane into the content you are currently working on.
Editing

The toolbar on top displays an actions menu with context-sensitive publishing options which vary depending on content status and user access rights. During editing, content status and autosave information are displayed.
When working with content such as pages and blocks in CMS, or catalog content in Commerce, there are two editing views, **On-Page Editing** and **All Properties**, with toggle buttons to switch between them.

- **On-Page Editing** provides quick access to direct editing of a selection of content properties.
- **All Properties** provides access to all available properties including more advanced ones such as access rights and language settings.

When editing content properties, these options are common when adding, deleting, or selecting items:

- ![Click to select](image)
  - Click to select, for instance, a category.
- ![Click to select](image)
  - Click to select, for instance, an image in a media folder, or a page in the page tree.
- ![Click to remove](image)
  - Click to remove, for instance, a category.

### Real-time Updates

Episerver is by default set up to display comments and changes to projects in the user interface immediately. If Episerver experiences problems with these immediate updates, the following dialog box is displayed.
The *Real-time Updates* dialog box can have two main reasons. It appears either because Episerver has encountered a network problem and cannot connect to the web server or because your system does not have the WebSocket protocol enabled, which is used for the real-time updates of the user interface.

**Network problems**

Network problems occur if there is an error in the web server configuration, or if there are problems with your corporate network or the with Internet connection. As long as there is a problem, you are unable to continue working with Episerver.

Whatever the reason, Episerver will try to reconnect to the web server. If it still cannot connect after a number of attempts, you get an error message saying: "The server has been unavailable for an extended period of time. Please verify the internet connection and refresh the browser."

Contact your IT department or Internet service provider if the problem persists.

**WebSocket support**

WebSocket is an Internet protocol used to automatically update the Episerver user interface.

If you are using the projects feature, the WebSocket protocol is used to check for new or updated comments and project items from other users. As soon as one of your colleagues adds a comment or project item, Episerver automatically updates your user interface and displays the comment or item (assuming you have the projects interface open).

However, the WebSocket protocol must have been enabled for your system by an administrator for the real-time updates to work. If it has not been enabled, you can still work with Episerver and with projects and comments but you need to manually refresh the user interface with the **Refresh** button to see new comments or items.

Depending on the system configuration when the WebSocket protocol is disabled, you may or may not see the *Real-time Updates* dialog box.
My settings

Under the global menu > your user name > My settings, you can change some of your account settings. User name and password are usually set in an external system, such as Windows or an SQL database, and cannot be changed in Episerver in that case.

In the Display Options tab, you find the following settings:

- **Personal language.** Select your desired user interface language from the drop-down. This setting affects the language of the user interface, such as texts in buttons and dialog boxes. It does not affect the language of your website.

- **Limit touch support.** On touch-screen devices, browsers may have difficulties prioritizing between input from the screen and from the mouse, which may cause problems such as making it impossible to resize panes using the mouse. If you experience problems with Episerver and the touch screen, enable the Limit touch support feature. This feature prioritizes mouse input over touch screen input and enables the mouse for interactions such as drag and drop, resizing of panes, and so on.

- **Reset all views to system default.** You can reset your user interface views to the settings. If you have changes to the user interfaces, such as added, moved or deleted gadgets, these changes are undone and the default views are displayed.

Roles and tasks

Episerver is designed for interaction with website visitors, as well as collaboration between users. A user in Episerver is someone working with different parts of the platform. A user can belong to one or
more user groups and roles, depending on their tasks as well as the size and setup of the organization. Typical roles and related tasks are described below. Refer to Setting access rights in the CMS Administrator User Guide for information on how to configure user groups and roles in Episerver.

**Visitor**

A visitor is someone who visits the website to find information or to use available services, on an e-commerce website possibly with purchasing intentions. Purchasing on an e-commerce website can be done either “anonymously” (payment and shipping details provided), or by registering an account. Visitors may also contribute to website content as community members, which usually requires registration of an account profile.

**Community member**

Content may be added by visitors or community members, if social features and community functionality are available for the website. This content includes forum and blog postings, reviews, ratings and comments, in which case there might be a need for monitoring this type of content on the website. Monitoring can be done for instance by an editor, or a specific moderator role for large websites and online communities.

**Content editor**

A content editor is someone with access to the editorial interface who creates and publishes content on the website. Content editors with good knowledge of the website content work with search optimization for selected content in search results. Editors may also want to follow-up on content with unusually high or low conversion rate in order to update or delete this content.

**Marketer**

A marketer creates content and campaigns with targeted banner advertisements to ensure customers have consistent on site experience of the various marketing channels. Furthermore, the marketer monitors campaign KPIs to optimize page conversion. A marketer with good knowledge of the website content may also want to monitor search statistics in order to optimize search for campaigns and promote content.

**Merchandiser**

A merchandiser typically works with stock on an e-commerce website to ensure that the strongest products are put in focus. This role also creates landing pages, sets product pricing, coordinates cross-product selling, oversees delivery and distribution of stock, and deals with suppliers. This user wants to be able to identify search queries with unusually high or low conversion rates, in order to adjust either the search or the product line.
**Website owner**

A website owner is someone with overall responsibility for the content and performance of one or more websites. This user monitors website activities such as page conversions, customer reviews or sales progress. Rarely creates content but can be involved in the approval of content created by others. A website owner may have administrative access rights and may be able to install selected add-ons on the website.

**Administrator**

An administrator works with configuration of various system settings from the administration user interface, including search, languages, user access rights and visitor groups for personalized content. Administrators may also install add-ons on the website. Administrators usually have extended access rights compared to other user groups, and can access all parts of the Episerver platform.

**Developer**

A developer is someone with programming skills working with the setup and implementation of the website, as well as maintenance and development of new functionality. Creates the content templates for pages, blocks and catalog content used by editors in CMS and Commerce, configures e-commerce settings, and manages the index and customized search features in Find. Developers may also install add-ons on the website.
The two most common types of e-commerce websites are:

- **Business-to-Consumer (B2C):** designed for selling goods and services to consumers.
- **Business-to-Business (B2B):** used to build strategic relationships with other businesses, and to ease the supply and procurement processes that characterize trade among those organizations.

Sites can have multiple roles, and a single site can provide several functions. Episerver Commerce is a flexible platform allowing for seamless integration with external systems such as financial, CRM, inventory, warehouse, and customer service systems.

A typical B2C shopping flow involves a number of interactions between a site visitor, Episerver Commerce, and any integrated external system. You can automate the shopping flow so that it requires little manual attention. But if needed, you can monitor, access, and manually handle a purchase order from the **Orders** system.

The following example shows a B2C shopping flow and the actions and tasks involved.
1. **Cart created.**

   In the shopping flow example, a customer does not need to register on the site to make a purchase. The order process starts when the visitor selects a product and adds it to a shopping cart. A cart (basket) is created and saved in the system, and is viewed in **Orders > Carts**. If the customer does not complete the checkout procedure, the cart remains in the system for a specified time.

   If the customer returns to the website, the cart is available for continued shopping. Already, in this early step, the system performs inventory and pricing checks for warehouse availability and discounts for products in the cart. These checks are updated if the customer returns to the cart.

2. **Start checkout.**

   When the customer completes the purchase and proceeds to checkout, the first step of the checkout procedure is initiated.

3. **Add address.**

   The shipping and billing address information is added together with the preferred type of delivery (First class, Express, and so on). An anonymous customer can add the address information manually; a registered and logged-in customer can populate the address information automatically. You also can set up the system to split shipments and ship to different addresses.

4. **Add payment.**

   The payment is added to the purchase order-to-be. The system calculates the total, including purchase amount and shipping fee. The customer selects a payment method, such as credit card or PayPal. The payment is registered and verified. Payment can happen instantly or after a specified time, depending on how the payment process is set up and the solution type (B2C or B2B). You can also set up split payments, if the system is configured for this.

5. **Order created.**

   Usually, the purchase order is created in the system when the payment is settled. In the last checkout step, a purchase order number is created, the customer confirms the purchase, and an order confirmation is sent to the customer. The shopping cart is converted to a purchase order, which is visible with status **In Progress** in **Orders > Purchase Orders**.

6. **Order processing.**

   After the order is created, order processing starts to check the warehouse and inventory status for the products in the order, and creates the actual shipment. Inventory status for the products may split the order into more than one shipment.
7. **Shipment released.**

After the shipment is verified, it is released. The purchase order now appears in Orders > Shipping/Receiving with the status Released for Shipping.

8. **Add to picklist.**

Warehouse personnel use a picklist to create the physical shipping of the order's products, and produce a packing slip that is attached to the physical package to be shipped.

9. **Order completed/shipped.**

After the system creates picklists with different orders and their respective packing slips, the order is set to Completed by creating a shipment validation number that is associated with a tracking number. You can enter the tracking number manually, or automatically if such an integration exists. The tracking number connects the physical package with the shipping provider for the delivery, and tracks the package on its way to the delivery address. The purchase order appears in Orders > Purchase Orders again, with status Completed.

10. **Return/Exchanges.**

Only completed orders are subject to a return or exchange. You can create returns automatically or manually by replacing a delivered product with another one in exchange, or a payment refund, or both. When you create a return, it appears in Orders > Shipping/Receiving > Returns. Order status may be Awaiting Exchange.

If the return involves replacement of a new product, the shipping procedure is initiated again. The return also may involve receiving a faulty product, in which case a receiving procedure is initiated involving the acknowledgment of a receiving receipt for the returned product.
Catalogs

A catalog consists of products and variants (SKUs) organized into a structure based on product categories or nodes. Products and variants have associated information such as:

- pricing
- markets
- inventories
- warehouses
- assets, such as images and documents

A product can exist in one or more catalogs. Catalogs are independent from one another. You can create as many catalogs as you want and assign them to one or more websites. And while you often import product catalogs from an externally integrated system, you can create them manually.

Further, you can define dates when a catalog is available, so you can prepare future revisions to items, and review them in advance of the release date.

This documentation describes examples from the sample catalog delivered with the Episerver Commerce sample site. Your installation may look different from the sample catalog.

Catalog structure

A catalog is the top-level container for all types of products. You can structure a catalog in a number of ways. For example, your site has several brands or product lines, and each brand or product line has its own catalog. Or, a retailer may have multiple suppliers, and you can segment each supplier into its own catalog. See Creating a catalog entry for information.

Meta-classes and meta-fields

You can define meta-classes and meta-fields for both catalogs and orders in the Administration part of Commerce Manager. For example, you create a meta-class called Wine. Then, add meta-fields to capture characteristics of wine, such as color, taste, vintage and maturity.

Importing and exporting a catalog

You can import a product catalog from an external system into Episerver Commerce.
When to import or export

When setting up a new e-commerce site, you need to get products into the system. You may also need to import a product catalog when new products are added to an external system’s catalog. Or, you want to move or copy product catalogs between websites.

While you can manually create a catalog and add catalog entries, that option is less useful if you have a large catalog. Instead, one of the methods for importing and exporting products.

Import and export methods

- **Import/Export.** Lets you export a product catalog or import a .zip file into Episerver Commerce, using the export/import feature.
- **CSV Import.** Lets you manage the product catalog in bulk using the CSV catalog import feature with an Excel spreadsheet saved as a .csv file. Before the import or export, the types of product data are mapped to the catalog structure and format. You can use the CSV catalog import feature for your entire catalog, or just portions of it.

Depending on the import or export setup, you may need to manually edit the information for imported products (such as adding images, documents, and associations) and their variations to complete the task.

**Commerce Importing or exporting catalog data**

You can import or export catalog data to and from Episerver Commerce websites using the catalog Import/Export feature. The standard catalog importer imports .zip files exported from Commerce Manager. It is a quick way to import catalogs from other websites and start off with a base to expand your catalog.

**Importing a catalog**

1. Go to Commerce Manager.
2. Access the Catalog management page.
3. Select Import/Export > Import Catalog.
4. Drag and drop the catalog file from the source location. The uploaded files appear in the list of files for import.
5. Click **Start Import**. The progress window shows the status.
6. When the import is complete, close the progress window.

**Exporting a catalog**

1. Go to **Commerce Manager**.
2. Access the **Catalog management** page.
3. All catalog nodes appear. Select the check box for the appropriate ones.
4. Select **Import/Export > Export Catalog**. The Export Catalog screen appears.
5. **Export catalog items in the following ways.**
   - To export everything in the catalog node, click **Start Export**. The progress window shows the status of the export. When the export is complete, close the window.
   - To export selected files, click **Download** next to each item.

6. **Click Download** to copy the exported catalog file to your computer.

**Commerce** **Importing a catalog using CSV files**

You can import and manage catalog entries (such as products, variants (SKUs), and packages) in bulk using an Excel spreadsheet (CSV format) as an alternative to manually creating catalog entries, which is tedious when dealing with a large amount of catalog data.

This section explains how to complete these tasks.

- Import .csv spreadsheets to create catalog entries in Commerce Manager.
- Assign catalog items to your category structure.
- Associate an entry with others (for instance, a variant/SKU appears within a product or a package).
- Edit or delete catalog items.

**Using the CSV import feature**

Follow these steps to import and set up a new catalog.
1. Create CSV data files (using an Excel spreadsheet or Notepad, for example) with information about categories, entries, and entry relations following the specification below. See also Sample CSV files.
   - In the first row, insert headers that correspond to data attributes being imported (for example, product name, price, description, image file location).
   - Use the following attributes to identify each item being imported.
     - **Code.** A unique code to identify each category or entry.
     - **Name.** A unique name for each data row.
     - **Entry Type.** (for catalog entries only) In each row, insert one of the following terms to indicate entry type.
       - **Variation**
       - **Product**
       - **Package**
       - **Bundle**
     - **Parent & Child Entry Code** (for entry relations only). Specify the relationship between entries (for example, to display product variations). Although, the following attribute is:
     - **Action.** Specify the import action.
       - **Insert**
       - **Update**
       - **Delete**

   You must specify a command for each row of the CSV file. If you enter **Insert** for that data already exists, or **Update** if no data exists, an error occurs during import, and those rows are not imported.

   - **Category Code** (by comma). Specify the entry’s category.
   - **SEO URL.** A unique URL for each catalog item.

   An error occurs if you import a file that contains more than one occurrence of the same URL.

2. Create necessary meta fields for the new catalog entries. See also Catalog meta-classes and meta-fields.
3. For each CSV file, create a mapping file, which links data in the CSV file to Commerce Manager attributes.

   Select the type of mapping file you need.
<table>
<thead>
<tr>
<th>Mapping file type</th>
<th>Used to specify</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category w/ Meta Data</td>
<td>Data for categories or subcategories within a catalog</td>
<td>CSV File type 1—Category file</td>
</tr>
<tr>
<td>Entry w/ Meta Data</td>
<td>Data for catalog entries (packages, products, variation/SKUs, and bundles)</td>
<td>CSV File Type 2—Entry files</td>
</tr>
<tr>
<td>Entry Relation</td>
<td>Relationships between entries. For example, many SKUs to one product, or several SKUs and products to a package.</td>
<td>CSV File Type 3—Entry relations file</td>
</tr>
<tr>
<td>Entry Association</td>
<td>Associations among entries (such as, advertising other items under text like &quot;You may also be interested in...&quot;)</td>
<td>CSV file type 4—Associations file</td>
</tr>
<tr>
<td>Variation w/ Inventory</td>
<td>Information for the inventory section of the Pricing/Inventory tab.</td>
<td>CSV file type 5—Pricing/inventory file</td>
</tr>
<tr>
<td>Sale Price</td>
<td>Information for the pricing section of the Pricing/Inventory tab.</td>
<td>CSV file type 6—Sale price file</td>
</tr>
</tbody>
</table>

For each mapping file type, the view displays a different set of fields and attributes. You manually assign attributes to each CSV file data column. Figure 11: Mapping file tab shows an example.

4. In Commerce Manager > Catalog Management, choose an existing catalog folder or create a new one to which to import.
5. Choose Import/export > CSV Import.
6. Drag and drop the CSV files you created in step 1.
7. Import the CSV files and their corresponding mapping files.

Sample CSV files

CSV File type 1—Category file

A category file specifies data for categories or subcategories within a catalog.

- The top row has column headers that match metadata fields. The headers can also have different names.
- **Category Code** in column B is important because it specifies where the entry data is stored.
- The code under **Parent Code** (column C) can be used to create subcategories. If **Parent Code** is set to null or root, the category is created in a catalog’s root level. Figure 1 shows that **Infants** and **Toddlers** categories are created at the root level, while the **Diapering Supplies** category is located under **Infants** as a subcategory.
CSV File Type 2—Entry files

Entry files specify data for catalog entries. The Products, Variation/SKUS, and Packages CSV files for this example are shown in Figures 2, 3, and 4.

Figure 2: CSV file type 2, entry file, products

Figure 3: CSV file type 2, entry file, variations

Figure 4: CSV file type 2, entry file, packages

CSV File Type 3—Entry relations file

The entry relations file links one entry to others. In the following example, Var1 through Var5 (different diaper sizes) are associated with Prod1 (Diapers), while Var9 through Var11 (different quantity for wipes) are associated with Prod2 (Wipes), and so on. Some variants are assigned to packages.
The Prod, Var, and Package codes must be the codes from the entry CSV files (Figures 2, 3, and 4). If you include codes not defined in the entry CSV files, an error occurs when they are imported into Commerce Manager.

Figure 5: CSV file type 3, entry relations file

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Action</td>
<td>Parent Entry Code</td>
<td>Child Entry Code</td>
</tr>
<tr>
<td>2</td>
<td>Insert</td>
<td>Prod1</td>
<td>Var1</td>
</tr>
<tr>
<td>3</td>
<td>Insert</td>
<td>Prod1</td>
<td>Var2</td>
</tr>
<tr>
<td>4</td>
<td>Insert</td>
<td>Prod1</td>
<td>Var3</td>
</tr>
<tr>
<td>5</td>
<td>Insert</td>
<td>Prod1</td>
<td>Var4</td>
</tr>
<tr>
<td>6</td>
<td>Insert</td>
<td>Prod1</td>
<td>Var5</td>
</tr>
<tr>
<td>7</td>
<td>Insert</td>
<td>Prod2</td>
<td>Var9</td>
</tr>
<tr>
<td>8</td>
<td>Insert</td>
<td>Prod2</td>
<td>Var10</td>
</tr>
<tr>
<td>9</td>
<td>Insert</td>
<td>Prod2</td>
<td>Var11</td>
</tr>
<tr>
<td>10</td>
<td>Insert</td>
<td>Prod3</td>
<td>Var6</td>
</tr>
<tr>
<td>11</td>
<td>Insert</td>
<td>Prod3</td>
<td>Var7</td>
</tr>
<tr>
<td>12</td>
<td>Insert</td>
<td>Prod3</td>
<td>Var8</td>
</tr>
<tr>
<td>13</td>
<td>Insert</td>
<td>Package NB</td>
<td>Var1</td>
</tr>
<tr>
<td>14</td>
<td>Insert</td>
<td>Package NB</td>
<td>Var10</td>
</tr>
<tr>
<td>15</td>
<td>Insert</td>
<td>Package3to6</td>
<td>Var2</td>
</tr>
<tr>
<td>16</td>
<td>Insert</td>
<td>Package3to6</td>
<td>Var10</td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**CSV file type 4—Associations file**

The associations file creates associations among different entries. In Figure 6, Var10 is associated to Var1 as an accessory, and Var2 to Var1 as a cross-sell item.

Figure 6: CSV file type 4, associations file

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Action</td>
<td>Baby Catalog Association Name</td>
<td>Parent Entry Code</td>
<td>Child Entry Code</td>
<td>Sort Order</td>
</tr>
<tr>
<td>2</td>
<td>Insert</td>
<td>Accessories</td>
<td>Var1</td>
<td>Var10</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Insert</td>
<td>Customers Who Bought This Item Also Bought</td>
<td>Var1</td>
<td>Var2</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**CSV file type 5—Pricing/inventory file**

The pricing/inventory file specifies information for each entry's Pricing/Inventory tab.

Figure 7: CSV file type 5, pricing/inventory file
CSV file type 6—Sale price file

The sale price file specifies information for the pricing section of the Pricing/Inventory page.

Figure 8: CSV file type 6, sale price file

<table>
<thead>
<tr>
<th>Action</th>
<th>Entry Code</th>
<th>Sale Type</th>
<th>Sale Code</th>
<th>Unit Price</th>
<th>Currency</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert</td>
<td>Var1</td>
<td>BBV1</td>
<td></td>
<td>16.99 USD</td>
<td>USD</td>
<td>1/1/2009 6:00</td>
<td>10/1/2009 18:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var2</td>
<td>BBV2</td>
<td></td>
<td>17.99 USD</td>
<td>USD</td>
<td>1/1/2009 6:00</td>
<td>10/1/2009 18:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var3</td>
<td>BBV3</td>
<td></td>
<td>17.99 USD</td>
<td>USD</td>
<td>1/1/2009 6:00</td>
<td>10/1/2009 18:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var4</td>
<td>BBV4</td>
<td></td>
<td>16.99 USD</td>
<td>USD</td>
<td>1/1/2009 6:00</td>
<td>10/1/2009 18:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var5</td>
<td>BBV5</td>
<td></td>
<td>18.99 USD</td>
<td>USD</td>
<td>1/1/2009 6:00</td>
<td>10/1/2009 18:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var6</td>
<td>BBV6</td>
<td></td>
<td>25.99 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/3/2009 23:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var7</td>
<td>BBV7</td>
<td></td>
<td>25.99 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/2/2009 22:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var8</td>
<td>BBV8</td>
<td></td>
<td>25.99 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/1/2009 19:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var9</td>
<td>BBV9</td>
<td></td>
<td>4.49 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/2/2009 22:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var10</td>
<td>BBV10</td>
<td></td>
<td>15.99 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/2/2009 22:00</td>
</tr>
<tr>
<td>Insert</td>
<td>Var11</td>
<td>BBV11</td>
<td></td>
<td>25.99 USD</td>
<td>USD</td>
<td>1/2/2009 11:00</td>
<td>6/2/2009 22:00</td>
</tr>
</tbody>
</table>

Example: Importing and setting up a new catalog

The following example shows how to use CSV import using the guidelines. Create a new catalog called Baby Stuff in the Catalog Management system.

Figure 9: Baby stuff catalog with categories and entries
Step 1: Create CSV files containing data for new entries

The example below is based on a set of sample .csv files.

This example uses these files.

- BabyStuffCategories.csv
- BabyProducts.csv
- BabyPackages.csv
- BabyVariations.csv
- BabyVariationInventoryPricing.csv
- BabyEntryRelations.csv
- BabyAssociations.csv
- BabySalePrice.csv

Step 2: Create meta fields for new catalog entries

The example files use default attributes only, so you do not need to create additional meta fields. If you want to create new meta fields, follow these steps. See also Catalog meta-classes and meta-fields.

1. Commerce Manager > Administration > Catalog System > Meta Classes.
2. Select Create New > New Meta Class.
   a. Enter a Name, Friendly Name (for example, Baby Catalog), and a description (optional) for the meta-class.
   b. For Object Type, choose Catalog Entry.
   c. Click OK.
3. Select Create New > New Meta Field.
   a. Enter in a Name, Friendly Name (for example, Baby Diaper Size), and an optional description.
   b. Choose the data type and other properties by selecting check boxes.
c. Click **OK** to save.
d. Repeat for all fields.

4. Associate the new meta fields with the meta-class you created.
   a. From the left navigation frame, click the **Meta Classes** node.
   b. For **Element**, select **Catalog Entry**.
   c. Under Type, choose the meta-class (for example, Baby Catalog) you created earlier.
   d. Select desired meta fields from the list at the bottom of the screen.
   e. Click **OK** to save.

**Step 3: Upload CSV data files to CSV import page**

1. Click **Catalog Management > Catalogs**. The Catalog List view appears in the main area.
2. Above the main view, select **Import/Export** and **CSV Import Catalog**. The CSV Import Catalog page appears.
3. On the **CSV Import** tab, drag and drop a file to import from the source location. The uploaded file is added to the **Files available for import** list.

4. Repeat step 3 for each CSV file you want to upload.

**Step 4: Create a mapping file for each CSV file**

1. In the main view, select the **Mapping file** tab.

   Figure 11: Mapping file tab
2. Complete the fields as follows.

   » **Edit existing mapping file section**
     
     » **Load mapping file.** Retrieves previously created and saved mapping files. Because this example has no existing mapping file, leave this section blank.

   » **Meta Class, Language section**
     
     » **Mapping Type.** Select **Category w/ Meta Data.**
       
       - For CSV Entry files, select **Entry w/ Meta Data.**
       - For CSV Entry Relations file, select **Entry Relation.**
       - For CSV Associations file, select **Entry Association.**
       - For CSV Pricing/Inventory file, select **Variation w/ Inventory.**
       - For CSV Sale Pricing file, select **Sale Price.**
     
     » **Meta Class.** Select **Default Catalog Node.**
     
     » **Language.** Select the language version you want to update. To update the status of a non-master language version, map the **Is Available** field with that status. You
can also update the **Available from** and **Expires on** fields with the Start Publish and Stop Publish times, respectively.

### Data file and CSV adjustment section

- **Data File**: The drop-down values are based on the CSV data files you uploaded on the CSV Import tab in step 2. For this example, select `BabyStuffCategory.csv`. Leave the remaining fields alone and move to the next section.
- **Delimiter**: Select the default value.
- **Text Qualifier**: Select the default value.
- **Encoding**: Select the default value.

### Fields and Attributes, Column headers in the data file, and Custom values section

Values in the **Fields and Attributes** column are representative of the Meta Class selected in the **MetaClass, Language** section (which was previously imported or created in Commerce Manager).

Values in the **Column headers in the data file** column's drop-down menus are representative of the Data file selected in the **Data file and CSV adjustment** section (which was previously imported).

- Select an appropriate **Column header** drop-down value to map with the meta-class **Fields and Attributes** to the left. The selected value appears in the **Custom values** column.

### Save mapping file section

- **Enter file name**: For this example, save the mapping files using the same CSV file names.

3. Click **Save**. The browser redisplay the **CSV Import** tab, and the mapping file is added to the list in the **Choose mapping file** section.

4. Repeat steps for each CSV file you want to import.

When all mapping files are saved, the CSV Import view should look like Figure 12.
Step 5. Import CSV files and corresponding mapping files to a catalog

At the CSV Import tab view (Figure 12), do the following:

1. In the Files available for import section, select and highlight the CSV file you want to import. For this example, select BabyStuffCategories.csv.
2. In the Choose mapping file for import section, select and highlight the mapping file that corresponds to that CSV file. For this example, select BabyStuffCategories.xml.
3. From the Catalog drop-down, select the catalog into which you want to import CSV data. In this example, choose Baby Stuff.
4. Click Start import. The Importing catalog dialog box shows completion percentage and logging messages.
5. Click Close Window.
6. Repeat the steps to import all the remaining CSV and Mapping pairs.

Step 6. Verify import

In the Catalog Management system, expand Catalog > Baby Stuff and verify that the CSV file's content was imported into the appropriate catalog.
Browsing and searching catalogs

Go to Commerce > Catalog to explore catalogs and their related products and variants. You also can search for catalog entries, such as products and variants (SKUs).

Browsing catalogs

Click Catalogs to browse the list of catalogs. The following image shows multiple catalog nodes containing different types of products.

Select a catalog node (such as Books-Art) to expand the underlying subcategories, which appear in the main content area. The node view displays the name, code, price, and availability of products and their variants. To filter a catalog listing by market, use the Market selector at the top. You can also display or hide thumbnail images by clicking the display button in the top right.

Select a category and drill down until you see products, packages, and bundles. Select the arrow next to a product, package or bundle to display related products and variants. Inventory and pricing information appears for variants.
Items in the main content area have icons, which help you identify their content type.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="category" /></td>
<td>category</td>
</tr>
<tr>
<td><img src="image2" alt="bundle" /></td>
<td>bundle</td>
</tr>
<tr>
<td><img src="image3" alt="package" /></td>
<td>package</td>
</tr>
<tr>
<td><img src="image4" alt="product" /></td>
<td>product</td>
</tr>
<tr>
<td><img src="image5" alt="variant" /></td>
<td>variant</td>
</tr>
</tbody>
</table>

Select a product or variant to view and edit an item’s content. See also Editing and publishing catalog entries.
Searching for catalog entries

To search for catalog entries from the Catalogs view, enter keywords into the search field. If you enter keywords inside quotation marks (such as "barbra paperback"), the search only fetches entries with those exact terms. See the Search section in the CMS Editor User Guide for information about Episerver search features.
Accessing products in CMS

You also can access catalog entries from edit view through the Catalogs gadget in the assets pane. The gadget is useful when dragging-and-dropping catalog entries into content areas. See also Managing content.

Creating and editing a catalog

To manually create a catalog, define its properties then add catalog entries, such as products and variants. You can create a catalog only under the catalog root level. (Alternatively, you can import catalog content from an external source.)

1. Select the Catalog Root context menu > New > Catalog. Or, click Add at the top.
2. Enter the catalog details. The system automatically saves the catalog, but it is not available on the website until published. See Publishing and managing versions in the CMS Editor User Guide for information about publishing.
   - **Name.** Enter the name to appear in the catalog listing.
   - **Name in URL.** Automatically created link, based on name and place in the navigation; depends on the implementation if this is visible in links on the site.
   - **Default currency.** Enter the default currency for this catalog's entries. See available currency options.
   - **Default language.** Enter the default (master) language for this catalog's entries.
   - **Base weight.** Enter the standard weight unit applied to catalog entries when calculating weight values for shipping totals in the checkout.
   - **Available languages.** Select languages (in addition to the master language) for this catalog's content. See Managing multi-lingual content in the CMS Administrator User Guide for information about working with languages with catalog content.

Catalog properties are global, meaning catalog entries inherit settings from the default (master) language catalog. You can edit properties only from the default (master) language, so if you need to edit properties, switch to the default language. The default language is usually the first language listed next to Languages in the header.

- Changing a catalog's default language is rarely needed. But, if you do, some catalog properties might have empty values.

## Deleting a catalog

Deleting a catalog may cause things to stop working on your site. Before doing so, you may want to export it and save it for future use. The delete operation may take some time, depending on catalog size.

Select the desired catalog in the catalog tree, click **Delete** in the context menu, and **Delete Catalog**.

---

**Commerce Working with Commerce Categories**

By applying a category to a product, you can adjust a catalog's structure and range to optimize the selling potential of its products. You can also

- copy or move products between categories
- link a product to a category by creating relation link
- detach relation links
When creating a catalog, consider the maintenance and performance of its structure. Do not create hierarchies of categories, products, or variants that are too deep. On the other hand, a flat catalog structure with too many entries in a category can negatively impact performance.

Categorization involves the following tasks.

- **Move.** Lets you restructure a catalog by moving catalog entries to another catalog node; related products and variants are also moved. Links to other catalog entries are kept intact. See *Working with Commerce Categories.*

- **Duplicate** Creates a copy of a catalog entry in a new catalog location. See *Working with Commerce Categories.*

- **Link.**

  Creates a *relation link* between catalog entries. For example, you assign a new sneaker to the *Featured Products* category. Then, instead of duplicating the product, you link it to the *Sport Shoes* category. The sneaker is visible and editable from both locations.

  Use links to promote new, popular, or sale products by displaying them as featured products on category and search result pages. You can display top selling products in your store, and create up-sell or cross-sell items, like *Product Accessories* or *You May Also Like* displays. See *Linking a catalog entry to a category.*

- **Detach.** Removes a relation link. See *Detaching a catalog entry from a category.*

### Creating a category

A category can have its own rich content including assets, such as descriptions of *wine regions* for a subset of wine products.

1. From the **Commerce > Catalog** interface, expand the catalog tree or select the main catalog listing and navigate to the desired catalog or category node. Or, use the catalog search feature to find a product.

2. Choose **Add > Category.** Or, from a catalog node, click the context menu and select **New > category.**

3. Enter a **name** for the category and select the appropriate category type (meta-class). Episerver Commerce suggests types based on the context and previous similar actions.
4. Complete the category properties. See also: Working with Commerce Categories. The system saves the category automatically, but it is not available on the website until published.

Viewing an item's categories

Viewing an item's categories

To view an item's categories, when working with a catalog entry, click Properties then the Belongs To tab.

View items assigned to a category

To view all items assigned to a category, select it from the catalog tree. Its items appear on the right side of the screen.

Editing a category

1. In the Catalog view, select the desired category.
2. From the context menu, click Edit.
3. Update the category information you want to change, such as the name, SEO information, or description.
4. Publish the changes, or schedule for later publishing using the save and publish flow for content.

See Creating a catalog entry for information about editable properties.

Deleting a category
If you delete a category, the following happens, depending on how the category is linked to other catalog entries:

- If the category being deleted is linked to other categories, all links to the deleted category are removed, while other category links are left intact.
- Categories, products, and variants that are linked only to the category being deleted (and no other categories) are also deleted.

⚠️ After deleting a catalog entry, you cannot recover it.
If you delete a category with many subitems, the deletion may take a while.

To delete a category, select it in the catalog tree, click **Delete** from the context menu, and click **Delete**. You can also click **Delete** from the context menu for the category in the item listing, or from the upper menu.

Linking a catalog entry to a category

To learn about linking, see [link](#).
1. Pin the **catalog view** so that it does not move.
2. In the right panel, select the catalog entry or variant to be linked. To select an item, move the cursor to the far right until you see the context menu, then click.
3. Drag and drop the item to the desired catalog tree node (on the left).
4. In the Select Action dialog, click **Link**.

The top category is always a product’s *home* location, which means that the product is located in this category and linked to other categories. If you edit a product, the catalog tree selection displays the home category. If a product’s URL is based on the **Name in URL** property, the URL is automatically based on the home category path.

So, if you change a product’s home location, the product is moved, and its URL changes accordingly.

---

**Detaching a catalog entry from a category**

To detach a catalog entry from a **relation link**, follow these steps.

1. In the **Catalog** view, in the right panel, select the catalog entry or variant to be detached. To select an item, move the cursor to the far right until you see the context menu, then click.
2. From the context menu, click **Detach from this category**.

To detach multiple catalog entries simultaneously, select them and click the **Detach** toolbar button.

If a product or variant is linked to only one category, **Detach** is not available. This prevents products or variants from becoming *orphans*, without a category and, therefore, difficult to locate in a product catalog.

---

**Commerce** Creating a catalog entry

The **Catalog** interface in Episerver Commerce provides multiple options to work with catalog data. Marketers may want to create new products and variants, and merchandisers may want to enrich new products being added to e-commerce channels. Ecommerce solutions integrated with an external ERP system may have existing products with core data that only need to be completed within Episerver Commerce. In other scenarios, you can create new products from scratch. When working with catalog entries, you typically complete the following tasks.

- Locate "incomplete" products added from integrated systems, add content and media, then categorize and publish them.
- Create products, add content and media provided from external sources, then categorize and publish them.
- Add product codes, internal and display names, properties, media, pricing and inventory information to variants.

When creating a catalog structure, carefully consider its maintenance and performance aspects. You should not build hierarchies of categories, products and variants that are too deep in the product catalog. On the other hand, a flat catalog structure with too many entries in the same category can negatively impact performance.
You can import a catalog into the system, or manually create a catalog. If you have an existing catalog, you can add one or more entry types to it.

**Types of catalog entries**

Each catalog entry has a type.

- **Category.** A way to group products, such as Art Books or Cocktail Dresses. For more information, see Working with Commerce Categories.
- **Product.** Merchandise you can display on the front-end site. A product typically consists of several variants. Customers purchase the variants.
- **Variant or SKU.** A product with specific characteristics, such as details for size, color, sleeve length, and price.
- **Package.** Similar to a variant because it must be purchased as a whole. For example, a shirt and hat combination is shrink-wrapped together and sold as a unit. Although multiple variants make up a package, it has a unique SKU number and appears as a single line item in a shopping cart. For more information, see Editing a package or bundle.
- **Bundle.** A collection of variants, allowing customers to purchase two or more items at once. Pricing is SKU-specific and separate. For example, a matching shirt and hat, presented together on the front-end so a user can buy both items at once. Each item appears on its own line in a shopping cart. For more information, see Editing a package or bundle.

You can create a new entry from the catalog tree’s context menu, the main listing, or the Add content button at the top. When you expand the catalog tree, context-sensitive options appear. For example, after selecting a category, you can create a new category, product, variant, package, or bundle. After selecting a product, you can create new products or variants.
Because variants belong to the lowest level in the product hierarchy, you cannot add sub-entries for them; you only can edit them.

The catalog tree in the left pane does not display products or variants; only category nodes. Use the main catalog entry listing in the middle of the screen to access options for products and variants (SKUs).

Creating a variant

A catalog can contain only products, both products and variants, or only variants. The following example shows how to create a variant.

1. Expand the catalog tree or select the main catalog listing and navigate to the desired catalog entry (category or product). Or, use catalog search to find the product you want to work with.
2. Select the catalog entry for which you are creating the variant. Then, either select Add > Variant/SKU at the top of the screen or, from the context menu, select New > Variant/SKU.
3. Enter a **name** for the variant and select the appropriate variant type (meta-class). The system suggests types based on the context and previous similar actions.

4. Complete the category properties. The system saves the item automatically but it is not available on the website until published. See also: *Creating a catalog entry.*

**Translating catalog content**

Like other types of content, catalog entries can exist in multiple languages. See *Multi-language management* for information about translating catalog entries.

**Saving and publishing**

After editing a catalog entry, you can either publish the changes immediately, or schedule for later publishing using the save and publish flow for content. Certain information, such as *pricing*, is immediately published upon edit.

**Moving a catalog entry**

1. From the **Catalog** view, in the right panel, select the catalog entry or variant to be moved. To select an item, place the cursor on the far right until you see the context menu, then click.
2. Drag and drop the item to the desired catalog tree node (on the left).
3. In the Select Action dialog, click **Move**.

**Duplicating a catalog entry**

You can duplicate an existing entry to start a new entry. When you create a duplicate entry, it gets a unique ID, and you can edit the following details to make it unique. You can also move it to any location in the catalog tree.

- **Category.** Creates a new code, name in URL, and SEO URL, based on the original. Name, internal name, and content are the same as the original. Sub-entries, such as products and variants in the category, are not duplicated.
- **Product.** Creates a new URL name, SEO URL, and product code based on the original. Name, internal name, content, and market availability are the same as the original.
- **Variant (SKU).** Creates a new URL name, SEO URL, and product code based on the original. The internal name, content, pricing information, and market availability are the same as the original.

You can duplicate one or several catalog entries. The following example duplicates multiple variants and adds them to another category.

1. Expand the **catalog tree** and go to the desired catalog or category node, so that products and variants you want to duplicate appear in the main listing.
2. Pin the **Catalogs** pane so it remains open.
3. In the list, check the boxes of items to be duplicated.
4. Drag your selection to the desired catalog tree location.
5. The Select Action dialog box appears. Click Duplicate. The selected entries are duplicated in the desired location.

You also can use the List menu’s Copy and Paste options to duplicate multiple entries, or the Context menu’s Copy and Paste options to duplicate a catalog entry.

**Editing a product or variant**

After you import products and variants to the system, you can add, edit or delete them.

Properties for products and variants are almost the same except that pricing and inventory options are only defined for variants, which is why you see a tab displaying variants (SKUs) related to the product. Categories also have some properties described here.
Changes to relations and pricing are immediately published and visible on the website, and are not part of the publishing flow. Changes to content and assets must be published to become visible on the website. See Publishing and managing versions for publishing information.

To learn about product and variant properties, see Creating a catalog entry

Catalog-specific editing options

The Commerce interface has a view selector with editing additional options. Using these, you can work with items in a Item List, or access the Pricing, Inventory and Relations views.

Editing multiple catalog entries

When viewing a product, you can work with several catalog entries at once by

1. Selecting several items on the list.
2. Applying actions such as cut, copy, paste, detach and delete.
Updating multiple catalog entries at once

As a catalog grows larger, use the batch update tool to update multiple catalog entries at once. The Catalog Batch Update option in Commerce Manager lets you make multiple changes to your catalog without having to update each catalog entry individually. When you search for catalog entries to update, you can filter the results.

1. Go to Catalog Management > Catalog Batch Update. The Batch Update screen appears.

- **Main Adjustment**
  - **Entry Type.** Select Product, Variation/SKU, Bundle, or Package.
  - **Meta Class** and **Field** menu items depend on the Meta Class you select. Your selection populates the Field drop-down selections.
Additional Filters. **Language**, **Catalog/Category** and **Keywords**.

- If your entries are in more than one language and you want to edit an entry in another language, apply the Language filter.
- If you want to narrow the results to a specific catalog, use the Catalog filter to search for entries within that catalog.
- To narrow your search even further, enter keywords, such as **Wine Glass**.

2. Within search results, you have the following options:
   - Select a catalog entry and go directly to its edit page.
   - Use the **Field** drop-down to select a field to edit directly. For example, you want to change the **display price** for a list of variation/skus at one time. Change the **Field** drop-down menu to **Variation: Display Price**. The right column changes, letting you directly edit the display price for all catalog entries at once.

3. Click **Save All**.

**Deleting a product or variant**

When deleting a product or a variant the following happens depending on how the entry you want to delete is related to other catalog entries:

- If a product is deleted, all links from other catalog entries to it are removed.
- If a product with associated variants is deleted, the variants are left associated with the same category as the deleted product.
- If a variant is deleted, all links from other catalog entries to the variant are removed.

Be aware that deletion of catalog entries cannot be undone.

To delete a product or variant, click **Delete** from the context menu for the item in the item list.
To delete multiple catalog entries at the same time, select the entries in the item list and click **Delete** in the toolbar.

**Catalog entry properties**

Catalog entries have several groups of properties that let you further define each item's inventory, pricing, category information, and so on. To access the properties, click the catalog entry's **Select view** button, then the relevant tab or drop-down menu option.
The header provides an overview of product information. Much of it is created automatically and rarely needs to be changed, unless you manually create catalog entries. In the top left, a clickable structure path shows the product hierarchy. Header properties are described below.

Change appears next to some properties. Click it to edit the property value.

- **Display name.** Name on the content display page.
- **Name.** Name in catalog listings and edit view.
- **Name in URL.** URL automatically created, based on name and place in the navigation; whether it is visible in site links depends on implementation.
- **SEO URL.** Automatically created based on Name; whether it is visible in site links depends on implementation.
- **Code.** Product code/identification key, often provided by an external system.
- **Markets.** Markets where the item is available. By default, a product or variant is available in all markets. See also: Markets.
- **Visible to.** Which users and groups can see the item. By default, catalog content is publicly visible and editable by CommerceAdmins group members.
- **Languages.** The content is available in the displayed languages. The active language is the one that is not underlined.
- **ID, Type.** The ID set by the system; the content type upon which the item is based.

### Tabs

#### Content tab

The content tab properties depend on the product or variant. For example, a book product has media type and author fields, as shown in the following image.
Descriptions can include formatted text, images, and links, using a rich-text editor.

**Belongs To tab**

The **Belongs To** tab displays categories, products, packages and bundles to which a product or variant belongs. For example, a variant belongs to a product and has a home category. Also, an item may be part of a *Weekly specials* campaign category, and a *Spring package* sales offering, as the following image shows. See also: Working with Commerce Categories.
Variants tab

Only visible for products. Displays a product’s variants. To add or remove them, click **Edit variants**.

To add a variant, drag it from the Assets pane > **Catalogs** tab. Or, click **Edit variant** then **Add Variant**. To remove a variant, click **Remove** on the item list.
Use the **Assets** tab to link a catalog entry to a media file, such as an image or a document (PDF for example).

To add a media file, open the assets pane and drag it from the **Media** tab to the **Assets** tab. Or, click **Add Media**.
When uploading media items, you can sort them into groups, such as *Banner*.

To rearrange items in the list, click **Move Up** or **Move Down** from the context menu. On the sample site, the item tagged with the default group at the top of the list is used for the main display.

**Related Entries tab**

Provides an overview of relations between a selected entry and other catalog entries. See also: Catalog entry properties
Several relation types may be available for selection. These are implementation-specific and cannot be changed from the Related entries tab.

Settings tab

Settings is a default tab with a set of built-in, date-related properties that you rarely need to change. See Editing content properties for information about the options.
Menu options

Variants

Lets you view and update a product’s variants.

Pricing

The Pricing view lets you view and update price information for a product’s variants. You can filter the view by Customer Group, market, or both. For each variant, you can modify the following.

- market
- price
- valid date range
- sale type
- sale code
- minimum quantity

See also: Managing pricing

Inventories

Inventory information is often transferred from external systems, so you rarely need to change it. Sometimes you cannot edit it. On other sites, you can update quantities but other information is read-only.
You can view (and possibly edit) the following inventory properties for a product or variant.

- **Location.** The physical stock location of the inventory, as defined in warehouse settings.
- **Code.** Product code/identification key; often provided by an external system.
- **In Stock.** The quantity of in-stock items for an inventory.
- **Backorder Availability.** If customers can backorder this item, enter the first date when it is possible.
- **Backorder Quantity.** The quantity of this item which may be backordered.
- **Preorder Availability.** If customers can preorder this item, enter the first date when it is possible.
- **Preorder Quantity.** The quantity of this item which may be preordered.
- **Reorder Min. Quantity.** Indicates the in-stock quantity level at which items should be reordered. For example, when an inventory location has three or fewer items, it is time to order more.
- **Is Tracked.** If selected, shoppers can only complete orders for this product/variant if you provide inventory information from the Inventory Locations. If **Is Tracked** is not selected, orders can be placed without inventory amounts.
- **Purchase Availability.** First date and time when this item can be sold from this inventory.

**Categories**

The categories view lets you view and update the categories assigned to a product or variant. For more information, see Working with Commerce Categories.

**Related Entries**

Provides an overview of relations between a selected entry and other catalog entries. See also: Catalog entry properties

**Commerce** Editing a package or bundle

A package contains multiple products or variants, with a single SKU and price. A package appears as a single line item in a shopping cart.
In contrast, a bundle is a collection of variants each of which is priced individually, allowing customers to purchase several items at once. Each item in a bundle appears as a separate line item in a shopping cart.

**Working with packages**

Like catalog entries, packages have several tabs and menu options that let you view and edit their information. To learn about most settings, see [Catalog entry properties](#). The **Package entries** tab is unique to packages, so is described below.

The **Package Entries** tab shows catalog entries or variants included in a package.

- Click **Edit entries** to edit the information.
- Click **Add Entry** to add an entry to the package. You can also drag an entry from the Assets pane.
- Click **Manage Entry Groups** to add package groups to associate packages with. The same groups are available for bundles.
- Click **Back** in the upper notification bar to return the main package screen.

---

![Edit Package](#)

**Working with bundles**

Like catalog entries, bundles have several tabs and menu options that let you view and edit their information. To learn about most settings, see [Catalog entry properties](#). The **Bundle entries** tab is unique to packages, so is described below.
Bundle entries tab

The **Bundle Entries** tab shows entries that are included in the bundle. You can associate bundle entries with groups the same as packages.

- **Edit entries.** Select to edit the information.
- **Add Entry.** Select to add an entry to the bundle. You can also drag an entry from the Assets pane.
- **Pricing** tab. This tab is only available for packages because you can set unique pricing only for packages and not bundles. It shows the pricing for that particular package for your different markets and customer groups. Click **Edit prices** to compare and edit the price for the package. See [Managing pricing](#) for information about editing prices.
- **Inventory** tab. Shows inventory status information for packages, which is often retrieved from external systems. A package has inventory information attached, which a bundle does not have. See [Editing products and variants](#) for information about working with inventory information.
- **Assets** tab. Just like products and variants (SKUs), packages and bundles can have associated assets such as images and documents. Add media files of your choice by dragging items from assets pane into the assets area of the package or bundle, or click **Add**. See [Assets in the CMS Editor User Guide](#) for information about working with assets.
- **Belongs To** and **Related Entries.** Packages and bundles also can belong to and have relations to other categories, products or variants in the catalog. See [Editing products and variants](#) for information about editing categories and relations.
Deleting a package or bundle

If you delete a package or bundle, all links to it from related products and variants are removed.

⚠️ After deleting a package or bundle, you cannot recover it.

To delete a package or bundle

1. Open the item’s context menu.
2. Click Delete.
3. Click delete to confirm.

To delete multiple catalog entries at once, select them from the item list and click Delete from the toolbar.

Managing pricing

The Edit Prices view lets you view and edit pricing for products and variants. The view displays a compact list of prices, which can be filtered by market or customer group. Market filtering displays both active and inactive markets.

The same item can be available in several markets. For each market, you can define multiple currencies and establish a different price for each one.

For each product or variant, you can define the following pricing information.
In many cases, pricing information comes from an external system, which may prohibit modifications in Episerver Commerce.

Price changes are immediately available on the website. They are not part of a product’s publishing workflow.

Viewing prices

1. In the Catalog view, select a category or product.
2. From the view selector in the upper right corner, click Pricing.

3. If desired, use the Customer Group and Market filters to make it easier to find pricing information.

Only catalog entries or variants with a price appear on the list.
Adding and editing prices

Follow the steps in Viewing prices to access the Edit Prices view. From there, you can complete these tasks.

» To adjust a product's or variant's price information, modify these fields.
  » Market. Associate the price with a market.
  » Price. The item's price and currency for that market.

The list of currencies is determined by those available for the selected market.

» Valid. The time interval when this price is available.
  » To create a future price change.
    1. Select the item.
    2. Click Duplicate from the context menu.
    3. Change the new item's pricing information.
    4. Set the new available dates.

» Sale Type. Make the price available to All Customers, a specific Customer, or a Customer Price Group. With the last option, you can create tiered pricing (also known as differentiated pricing).

» Sale Code. Use this field to assign a price to a specific customer group. For example, create a new price, select Customer Price Group as its Sale Type, then insert the customer group name into the Code field.

» Min. quantity. The minimum number of units that must be purchased to get the listed price.

Use this feature to provide a bulk rate. For example if a customer purchases 10 or more, the cost is $50.00 each. If fewer than 10, $60.00 each.

» From a product's or variant's context menu:
  » click Duplicate to create a copy of price information, which you can then modify to create a new pricing setup.
  » click Delete to remove a set of price information.

You cannot undo the deletion of price information.

See Editing catalog entries for information about editing other properties of catalog entries.
Setting customer group pricing

Use Customer Groups to set permissions and create targeted marketing campaigns.

Prerequisite: Customer groups are created in Commerce Manager.

To create a customer group price:

1. Follow the steps in Viewing prices to access the Edit Prices view.
2. In the Edit Prices view, click Add Price.
3. Click Customer Price Group.
4. Select the customer group to which the price applies.
Order management is a central part of the e-commerce system. Since the majority of orders are created from the front-end site, the ordering process is usually automatic following an order management workflow. In some cases, orders need to be manually managed. **Order Management** in Commerce Manager provides shopping carts (baskets), order capture, order fulfillment, payment functions and item return or exchange support.

**Meta-classes and meta-fields**

You can define your own meta-classes and meta-fields for both products and orders in Commerce Manager. For instance, if you create a meta-class called *Wine*, you want to add meta-fields that are characteristic for wine, such as *color*, *taste*, *vintage* and *maturity*.

When you create meta-fields and meta-classes, you can use them in the product catalog. Meta-classes and meta-fields for catalogs are defined in the **Catalog System** part of **System Administration**. For more information, see [Catalog meta-classes and meta-fields](#).

**Browsing orders**

Customers create the majority of orders on the front-end in an online store, and you likely have a significant amount of orders in your system. Episerver Commerce lets you browse and search orders in several ways.

- Filter and search orders by customer, status, market, date range and other properties.
- Use wild cards to limit search results.
- Preview orders while browsing.
- Viewing orders per market.

**Searching and viewing orders**

Go to **Commerce Manager > Order Management** and click **Order Search**.

Search filtering options include markets and customer contact details. You can use wild cards ("**"`) to indicate partial search for instance on a customer name. You can click column headers to sort the order list.
When browsing orders, you can for example see information about order creation date, market, and from where the order derives.

Order summary preview

Click the **Order Summary** icon next to the purchase order ID to display a summary of the order information.

Viewing orders by time range or status

Using the options under **Purchase Orders** in the left column you can view orders by **time range**. You can for example display orders using "Last 7 days" and "Last 30 days", to see the last orders from the previous month, in the beginning of a month.
Using the options under Purchase Orders By Status in the left column you can view orders by status.

**Viewing orders per market**

When viewing purchase orders, carts or payment plans, you can filter all views per market to work with items for a specific market.

---

**Commerce Creating an order**

While customers create the majority of orders on the front-end in an online store, you may sometimes need to manually create an order from Commerce Manager.

You can create orders from within Order Management or directly for a Contact in Customer Management. The order management option is the fastest and most common way, providing more order alternatives. The Customer Management system, while a bit slower, lets you to double-check a customer's information before beginning an order.

> When you create an order, it appears in the Purchase Orders list with an order status of In Progress.
Creating an order from order list

1. Go to **Order Management** > **Purchase Orders**.
2. Click **New Order**. A dialog box appears.
3. Select the **Site** and **Customer** to which the new order applies. Select **Customer > More** if your customer is not listed.

4. Click **OK**. The basic order information appears.
5. Fill out the purchase order and click **Apply**.

   ![Basic Order Info](image)

   - **Customer**: Enter the name of the contact.
   - **Currency**: Select the currency to associate with the purchase order.
   - **Coupon**: If applicable, apply a coupon code that was created with a promotion to associate with the purchase order.

6. Click **New Item** to add items from the site catalog to the purchase order. A dialog box appears so you can select items from a site catalog.
7. Search for items by entering search terms into the search field and clicking **Find**. To sort search results, select the column header.

Use the following fields to refine search results.

- **Select catalog.** Select which catalog to search.
- **Select language.** Select a language (such as German for items described in German).
- **Select entry type.** Select a type of entry, such as variantSKU or bundle.

8. Select an item from the list and click **Configure Selected Entry**. The New Line Item dialog appears.
Display Price. The price displayed on the public website. This is set at the catalog-entry level.

Price. The actual cost of the item that is charged when the item is added to the order.

Quantity. Set how many of the item to add to the order.

Discount. You can apply a discount to the item, either value or percentage based.

If you are using the new Discount system, discounts that you manually add to an order are included in the total discount calculations, and are listed under the order’s Promotions as Manual.

Total. The total is calculated, factoring in the actual price, quantity, and any discounts.

9. Click Add item to the order. The item appears on the Purchase Order form.

10. Enter a Billing and a Shipping Address. You can select the contact’s existing address.
Select Add to customer's address book if you want to save the address with the contact.

If the Shipping Address is the same as the Billing Address, click Same as Billing Address. The Shipping Address form is populated with the Billing Address information.

11. Select the order's Shipping Method. Select Recalculate to generate and display the cost summary.

12. Click OK to save the order.
Creating an order within a contact

2. Click New Order. The New Order dialog box appears.

3. Select the site where you want to apply the order and click OK. The Purchase Order New form appears, prompting you to enter order information.
4. Follow the steps in Creating an order from order list to complete the order.

Processing an order

Order processing (or fulfilling) includes adding a payment and releasing the order for shipping. These steps are needed to complete the order and ship it to the customer. When payment is cleared, the order is released for packing and shipping. Depending on how your system is set up, this process may be automatically handled by the system. This topic describes how the procedure is done manually.

When an order is processed and released for shipping, it has In Progress status in the order list, and appears in the Released for Shipping list under Shipping/Receiving.

1. Go to the Order Management and open the order you want to process.
2. Click Create Payment to add a payment to the order.
3. Enter the amount of the payment. The **Amount** field auto-populates the value of the total order, including shipping costs. However, you can change the value of the payment (for split payments between two or more payment methods at the request of the customer).

4. Select the **Payment Method** from the drop-down list.

5. Click **OK**. The order appears in Edit Mode.

6. Click **Save** to exit Edit Mode and save your changes. The payment is automatically processed for the amount specified.
7. Click **Details** to see that the **Shipment Status** changed to **Awaiting Inventory**. When you determine the availability of the item, click **Release Shipment** to release the order to your shipping department.

When you click **Release shipment**, the status changes to **Released**. To further process the order, your shipping department goes to **Order Management > Shipment**.

⚠️ If you click **Cancel shipment**, you cancel the entire order. You cannot undo the cancellation.
Splitting a shipment

If an order has two or more items, you can split it into separate shipments, up to the number of items in a single order. You may split an order...

›› to expedite items that are immediately ready for shipment while other items have added shipping lead time.
›› to ship multiple heavy items, back-ordered items, or a large volume of items for ease of delivery and pickup.

1. In Order Management, go to an existing purchase order or create a new one.
2. Click Details and look for Shipment # 1.

3. Click Move next to the item you want to move. The Move Line Item dialog box appears.

4. Select the data for the line item and click OK to save your changes.
Quantity to move. Select the quantity of the item to move.
Move to existing shipment. Select an existing shipment.
Create new shipment.
Address. Select an address.
Shipping method. Select a shipping method.

The Details page shows the new shipment, which you can process separately from one another, but tied to a single purchase order.
Setting up a payment plan

A payment plan works exactly like processing an order, except that a payment plan spreads payments over time, giving you flexibility in how you sell your products, and how a customer pays for them. Use a payment plan for large and complicated orders, orders that need to be shipped in sequence, magazine or grocery subscriptions, or expensive items.

A Customer Service Representative (CSR) sets up a payment plan to generate recurring payments. Payment plans are handled in the background through the Subscription payment plan scheduled job.
1. Go to Order Management > Payment Plans (recurring).
2. Open up the Payment Plans List and click New Payment Plan.
3. Select a customer contact to whom the payment is attached. The Payment Plan New page appears.
4. Complete the form as you would when creating an order.
5. Set the cycles and parameters of the Payment Plan Details.

» Plan Cycle. (Cycle Mode)

You can choose from the following plan cycles, which determine how often the customer is charged.

» No Cycle. No recurring payment is created. The customer is charged once when the initial purchase order is created.

» Daily Cycle. Recurring payment happens daily from start date.

» Weekly Cycle. Recurring payment happens weekly from start date.

» Monthly Cycle. Recurring payment happens monthly from start date.
Custom1/Custom2. These are placeholders for developers to create custom cycles within the Mediacommerce.Orders.PaymentPlanCycle class.

Cycle Length. Entering a value of 1 or higher determines the unit of time for the Plan Cycle. For example, if the Plan Cycle is set to Daily, and the Cycle Length is 3, then a transaction occurs every three days. If the Plan Cycle is set to Monthly and the Cycle Length is 1, then a transaction occurs once each month; if 2, every two months, and so on.

Max Cycles. Determines the maximum number of cycles to run for this payment plan. For example, if the Max Cycles is set to 2, then the maximum number of transactions cycles is two and then the payment plan stops. Set the Max Cycles to 0 if you want the plan to go on indefinitely.

Completed Cycles. This tallies the number of completed cycles so far after the payment plan was created. When initially creating the payment plan, set this field to 0.

Start Date. Set the start date and time when recurring transactions begin.

End Date. Set the end date and time when recurring transactions end.

Is Plan Active. True enables the payment plan. Set False to create the payment plan but keep it inactive.

Last Transaction Date. Logs the last transaction date. Leave the date and time fields as is when you create the payment plan.

6. Click OK.

Payment plan order detail page explained

The payment plan begins when the first purchase order is generated. You can create the purchase order manually (by clicking Create First Purchase Order) or automatically by the payment plans scheduled job.

After you create a new payment plan, a new Order page appears. This is slightly altered from the original Order detail page that appears after creating a new order. The changes include:

- Inability to manage shipments (release shipments for further processing).
- An Orders tab that shows a history of processed purchase orders from this payment plan.
- A Create First Purchase Order button that a CSR selects to create the first purchase order related to this payment plan. The button disappears after creating the first purchase order manually or when the payment plan scheduled job runs and generates the first purchase order. After the first purchase is generated, the payment plan goes into effect.
- The generated purchase order number includes the parent ID of the payment plan. For example, if the payment plan parent ID is 35, the subsequent purchase orders are numbered as PO35XXX.
- When a payment is added to a payment plan, the customer is not charged. The payment plan simply collects the payment information until converted to a purchase order. The customer is charged once the purchase order is generated for the first time (and through subsequent purchase orders).
Editing and canceling a payment plan

1. To edit an existing payment plan, go to Order Management > Payment Plans (Recurring) or Today/This Week/This Month/All. Click the payment plan ID number to open the payment plans order details page and make edits.
2. To cancel a payment plan, click Summary and then click Cancel Payment Plan.

Creating a recurring payment plan using Authorize.Net

Episerver Commerce supports the Authorize.Net recurring payment plan gateway. For information about setting up payment methods, see Payments.

1. Go to Administration > Order System > Payments > (Language) and create a new payment method or select an existing payment method (such as Pay by Credit Card).
2. When you set up the parameters of the payment method, select the Mediachase.Commerce.Plugins.Payment.Authorize.AuthorizePaymentGateway class name.
3. Click Yes for Supports Recurring.
4. Click OK.
5. Click the name of the payment method again and click Parameters.
Configure your Authorize.net account for both regular payments and recurring payments.

**Configure Authorize.Net Account**


<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>API User Id</td>
<td>4y58fuW7jm</td>
</tr>
<tr>
<td>Transaction Key</td>
<td>4cAmW927n8uLf5J8</td>
</tr>
<tr>
<td>Regular Payments Processing URL</td>
<td><a href="https://test.authorize.net/gateway/transact.dll">https://test.authorize.net/gateway/transact.dll</a></td>
</tr>
<tr>
<td>Payment Options</td>
<td>Authorization</td>
</tr>
<tr>
<td></td>
<td>Sale</td>
</tr>
<tr>
<td>Recurring Payments</td>
<td>Processing URL</td>
</tr>
<tr>
<td>Recurring Method</td>
<td>Internal</td>
</tr>
<tr>
<td>Cancel Status</td>
<td>OnHold</td>
</tr>
</tbody>
</table>

**Editing, canceling, and deleting orders**

**Editing an order**

1. Go to **Order Management**.
2. Select the order to edit.
3. Edit the order.
4. Click **Save**.

**Canceling an order**

1. Go to **Order Management**.
2. Select the order to cancel.
3. Click **Cancel Order** under the **Summary** tab. The status of the order changes to **Cancelled** but it remains in the order list for viewing. The cancellation of the order is logged under the **Notes** tab.
Deleting an order

When you delete an order, it is completely removed from the order list.

1. Go to Order Management.
2. Select one or more orders to delete and click Delete Selected.
3. Click OK to confirm.

Shipping and receiving

Completing the order processing includes these tasks:

- Completing the shipment by preparing the physical package to be shipped.
- Creating picklists for picking up the physical items in the warehouse.

Shipping and Receiving are split into two areas: shipments and returns.

- A shipment controls items released for shipping and picklists, or items that are packed and prepared for shipping or ready for pick up.
- Returns are incoming items that are returned by customers for some reason, such as faulty items that need to be replaced by exchanges. Episerver processes returns similarly to outgoing shipments, and manages returned items as incoming packages. You can track them at Order Management > Shipping/Receiving > Shipments > Returns.

The Shipments view contains the following information.
Orders | 99

- **Order Created.** This column specifies when an order was created. This is useful, for example, if you want to ship orders by date and time.
- **Last Modified.** If any changes were made to an order, a date stamp for its last modification will be displayed here.
- **Number #.** This column is for the individual IDs assigned to each order. The first number is the unique tracking number. The second number is the unique tracking number assigned to the order for shipping purposes.
- **Customer.** The full name of the customer as it appears on the package. This is useful, for example, if you want to ship orders all together to one customer.
- **Shipping Method.** Specifies the shipping method used by each order. Depending on how many methods of shipping you have specified in the administration area, a different shipping method can show up in this column.
- **Address.** The address that the package is being shipped to.
- **Warehouse.** A warehouse is (most likely) a physical location where you store your goods before delivery. You can select from any of the warehouses you have put into your system. Remember to select the correct one when attempting to check for shipments. You can change the Default Warehouse in the Administration section of the Commerce Manager. If you have only digital products, the default warehouse should be adequate.

**Commerce** Creating a picklist

After you create and process an order, the status of the order is **Released for Shipping.** You need to add an order to an existing picklist or creating a new picklist to move an order in the workflow, else orders cannot be completed nor shipped. You add the shipment to a picklist, and select the warehouse from where the physical item is packed and shipped.
After an order is added to a picklist, its status is **In Progress** in the order list. It disappears from the **Release for Shipping** list and appears in the **Picklist** listing under **Shipping/Receiving**.

1. Go to **Order Management > Shipping/Receiving > Shipments > Released for Shipping**. The **Released Shipments** list appears.

2. Select a **Warehouse** to determine from where the item is packed and shipped.

3. Select the orders you want to add to the picklist and click **Add Shipment to Picklist**. The **Add Shipments to Pick List** dialog box appears.

4. You can create a **New Pick List** (by default, the **List Name** shows the date and time the pick list was generated) or add the shipments to an existing pick list you can select from the **List Name** drop-down list.
5. Click **OK**.

**Commerce**  **Completing a shipment**

This is the final stage of an order where you prepare the physical shipment by assigning tracking information, preparing packing slips and sending the package when the order is completed. The order becomes available for creating returns if needed; returns are creates for completed orders only.

A completed order has the status **Completed** in the order list and disappears from the **Picklist** listed under **Shipping/Receiving**. The picklist remains in the list even if there are no packing shipments remaining.

Use either of the following methods to complete a shipment.

**Method 1**

1. Select the box next to the shipment and then click **Complete**. The **Complete shipment** dialog box appears.

The default shipment number is based on the number after the purchase order number. For example, in the previous image, the PO number for the selected order is PO10728-9. The last number after the dash is the number you want to enter into the text field, in this case it is 9.
2. Click Validate. When validated, you see the customer name, shipping address, shipping method, and a field to enter the tracking number provided by the shipping provider. Enter a tracking number and click OK. The shipment is sent out and completed. The purchase order status changes to Completed.

The Complete shipment dialog box appears over the purchase order number. To reference the shipment number without closing the dialog box, you can move the dialog box so you can see the PO number by hovering your mouse cursor over the Complete shipment title bar.

Method 2

1. To complete a shipment, click Complete Shipment. The Complete shipment dialog box appears.
The shipment # is already validated with the last number of the PO number.

2. Enter a tracking number provided by the shipping provider and click OK to complete the shipment and order.

**Printing a picklist and packing slip**

1. Go to Order Management > Pick Lists. You can filter the view by choosing which warehouse the pick list was generated in. You also can sort existing picklists by Name, Packing Shipments, Warehouse, and Created By.

2. Select an existing picklist. The Packing Shipments window appears.

   - To print a picklist, select one or more purchase orders and click Print Picklist to generate a printable and exportable (Excel or PDF) picklist.
To print a packing slip, select one or more purchase orders to include in the packing slip and then click **Print Packing Slip**.

**Commerce** Removing items and deleting picklists

Removing items from a picklist

1. Go to *Order Management > Picklists > Shipping/Receiving*.
2. Select a picklist to display the related order shipments.
3. Select the shipments you want to remove and click **Remove from Pick List**.
4. Click **OK** to confirm.

Deleting picklists

A picklist must be empty of packing shipments (0 shipments remaining) before you can delete it.

1. Go to *Order Management > Picklists > Shipping/Receiving*.
2. Select one or more picklists and click **Delete Selected**.
3. Click **OK** to confirm.

**Commerce** Shopping carts

A visitor creates a shopping cart when the visitor clicks *Add to basket* option on any page. You can manually create and manage a shopping cart from **Order Management > Carts** where you can view registered and anonymous customer carts and manually convert a cart into a purchase order. For information about the shopping workflow, see *Shopping process flow*. 
Creating a shopping cart

Each shopping cart is unique and has its own ID. When you manually create a cart, select a customer, and the system automatically redirects you to an open cart for a customer (if that customer already has a cart open). You can have only one cart open per customer at a time. When a cart is turned into an order, it disappears from the Carts list, and appears in the purchase order listing.

1. Go to Order Management > Carts.
2. Click New Shopping Cart.
3. Select a customer for whom you want to create the cart. If you do not see the customer in the list, click More to search for them.
4. Enter product items to the cart by clicking New Line Item.
5. Return to the Carts view to verify that the cart is there.

Converting a shopping cart

In most cases, a shopping cart is automatically converted into a purchase order when a customer proceeds to checkout and finalize their purchase there. However, you may need to manually complete a purchase by converting a shopping cart into an order for further processing.

1. Go to Order Management > Carts. You see the Shopping Carts list. You also can select Today, This Week, or This Month to filter by date range.
2. Select the ID number of the shopping cart you want to convert to a purchase order. The Cart View window appears with customer cart details.

The following image shows an anonymous user Cart View.
Edit Information. You can change the currency of the purchase order.

Open Customer Profile. You can view the profile of the registered customer (this option is not available for anonymous shopping carts).

Line Items. The list of items in the customer’s shopping cart, displaying the Quantity of each item, List Price, and Total.

Notes. Add, edit, or delete notes about the shopping cart.

3. Select More Actions > Convert to Purchase Order. The page refreshes and shows the Order view page for further processing of the purchase order.

**Commerce** Returns and exchanges

After a package is finalized and shipped out, you can process returns and exchanges directly in the order. A return is the actual return of the faulty delivery item. You either can refund the customer or offer an exchange of the same product item or something else.
A separate exchange order (denoted by EO, instead of PO) is tied to the original purchase order. An exchange order is similar to processing a purchase order, because it involves payment processing and releasing packages for shipment.

You can process returns and exchanges only after a purchase order’s status is **Completed**.

### Initiating a return

1. Go to a purchase order that has been finalized and shipped.
2. Go to the Details tab and click **Create Return** in Returns/Exchanges. The Create/Edit Return form appears.

3. Click **New Item** to add the items to be returned. The Line Item drop-down menu defaults to the items that were in the original purchase order.
4. Set the **Return Quantity** and the **Return Reason** from the drop-down list (Faulty, Unwanted Gift, Incorrect Item). You also can add information to the return.

5. Click **OK** to save your changes. The purchase order goes into Edit Mode.
6. Click **Save** to continue the return process. Otherwise, click **Cancel** to cancel the return. In the Order List, the order appears with status **Completed/Awaiting Return Completion**.
7. Click the Returns tab to process the return further, for example, after you get a notice from the shipping department that they have received the returned item.

8. Click Acknowledge Receipt Items. (You also can choose to edit the return or cancel the return completely.)

9. After you click Acknowledge Receipt Items, click Complete Return to open the Create Refund form.
» **Amount.** Defaults to the invoice cost of the item (not including the shipping costs). For example, if the item cost $49.99 and the shipping cost was $2, then the Amount box shows $49.99.

However, you can specify a different amount to refund to the customer, including the full cost of the order, items plus shipping cost. By default, the refund is deposited based on the payment method the customer used to make the order.

» **Existing Payments.** If the customer wants the refund processed and deposited to a different credit card or payment method (such as cash, money order, or electronic transfer), click **New Credit.** You can enter their alternate credit card information or other refund information.

» **Payment Method.** Select the method.

10. Click **OK** to create and process the refund. The status of the purchase order changes to **Completed**.
Initiating an exchange order

1. Go to a purchase order, click the **Details** tab, and click **Create Return**.
2. Add the items for exchange.
3. Click the **Returns** tab and click **Acknowledge Receipt Items**.
4. Click **Create Exchange**. The **Create Exchange Order** form appears.
5. Click **New Item** and then select the item to be exchanged by clicking **Configure Selected Entry**.

You can adjust the price, quantity, and applicable discounts before you add the item to the exchange order by clicking **Add item to the order**.
6. Enter a shipping and billing address.
7. Select the shipping method to use for the exchange order.
8. Click **Recalculate** to adjust the Summary total.
9. Click **OK**.
10. After you create an exchange order (EO), click **View Exchange** to view the details of the EO. (An EO is similar to how a PO is set up.)

11. Click the **Payments** tab to add a payment to the exchange order.
12. Select a payment method for processing the EO. You can adjust the amount if needed (the amount default value is based the item cost plus shipping). The exchange order enters **Edit Mode**.
13. Click **Save** to process the payment and the order. The payment Transaction Type changes to **Authorization**. In the **Order List**, there is an exchange order with prefix EO instead of PO, and with status **Awaiting Exchange**.

14. Go back to the original purchase order and click the **Returns** tab.

15. Click **Complete Return** to enable the Customer Service Representative (CSR) to release the EO shipment. Optionally, you can cancel the shipment to cancel the exchange order. After you release shipment, the CSR repeats the same process as shipping a purchase order.
The Customer Management system in Episerver Commerce is based on contacts and accounts. A contact is a website visitor who registers with an account on the front-end site. You can use organizations to manage your contacts in structures appropriate for your e-commerce business.

Organizations

Create an organization hierarchy by creating parent-child relationships between organizations. For example, you can create a hierarchy of organizations such as Administration > EU Headquarters > EU Management.

You then may associate contacts with the appropriate level of the organization hierarchy. You can set permissions to determine which users can view organizations in the hierarchy.

The same principle applies for creating hierarchies for customer groups. For example, you could have a customers organization with sub-organizations of Gold, Silver, and Bronze levels of customer groups. You could then leverage those customer groups to display different prices for each of your valued customer groups. See Organizations.

Contacts

When a visitor registers on the front-end of the site (for example to make a purchase) a contact and account is automatically created. You can manage contacts within customer groups and organization customer groups, to which you can apply specific pricing and discounts, and personalization. See Contacts.

Anonymous shopping is allowed in a default implementation of Episerver Commerce. This means that customers are not required to create an account in order to purchase, and will not be available as contacts.
Under Organizations, you can create new organizations. Categorize organizations into different types such as regional branches and departments, and also business categories such as Computer and Electronics or Clothing and Accessories.

You can assign an organization to a customer group, to which you can apply specific pricing and discounts, and personalization.

You can structure an organization into a tree structure with sub-units with different permissions assigned to each. For example, you can set up your company as a parent level organization while your departments such as Sales & Marketing, IT/Development, and Operations as organization units. With this scenario, you can let users in each departments have access only to relevant systems, screens, and functionality within Commerce Manager.

**Browsing organizations**

To browse organizations, go to Commerce Manager > Customer Management > Organization.

The Organization List page appears.

In this view, the organization details display the following information:

- **Name.** Name of the organization.
- **Description.** Additional details about the organization.
- **Type.** Organization or Organization Unit.
- **Business Category.** Under which category the organization falls.
Viewing organization details

Select an organization in the list to display detailed information about the type of organization and related contacts, organizations (parent/sub), addresses and credit cards.

Searching for an organization

You can also use the search field on top of the Organization List to find specific organizations by name. Enter your search terms and click Search. To conduct a new search, click Reset to reset the form and enter new search terms.

Customizing views for browsing organizations

As an organization list gets longer, you can create and customize views to filter the list. Define the columns you want to be displayed for the view, and the filters to be applied when selecting what to include in the view.

1. On the **General** tab, enter a **Title** for the custom view. Click **Show this view for all users** if you want other users to see this custom view.

2. On the **Fields** tab, select which columns you want to appear in the custom view. Select an available column and click **Right Arrow** to move it to the **Visible columns** list. To
deselect and column select a visible column and click **Left Arrow**. Click **Up** and **Down** arrows to re-order the list.

3. On the **Filters** tab, set the view filters. Click + to add another filter.
2. Click **Save** to return to the **Organization List** screen. The new view appears in the **View** drop-down box.

![View drop-down menu example]

**Editing and deleting views**

To edit an existing view, select the view from the drop-down menu and click **Edit**. The **View Editing** dialog is displayed and you can edit all properties.

![View Editing dialog]

To **delete** a custom view, click **X**.

**Customized view example**

The following example creates a view that shows only organizations that match a business category and organization name. Create a filter condition that displays organizations with a **Business Category** that equals **Business & Professional Services** and an **Organization Name** that equals **Company X**.

![Customized view example]

1. Click **Add (+)** and from the drop-down click **Business Category**. Two fields, which default to **Equals** and **Arts & Entertainment**, automatically appear.
1. Click **Equals** and a drop-down appears. Keep the field as "Equals."
2. Select the field to the right of it and select a **Business Category** name (such as **Business and Professional Services**).
3. Click the next **Add (+)** and click **Name** to add another filter so that the organization matches **Business Category** and **Name**.
   1. Click **Equals**.
   2. Enter in the name of the organization in the **Text** field.

4. Click **Save**.
5. To apply the view, select it from the drop-down. Based on the columns and filters you applied for the custom view, your organization list reflects those options.

**Printing a list of organizations**

Click **Printer Version** to generate a printer-friendly list of organizations. A new window appears and renders a simple table suitable for printing.

**Creating or editing an organization**

1. Go to **Commerce Manager > Customer Management** and **Organizations**. The **Organizations** page appears listing any existing organizations.
2. Click **New Organization** or any existing organization. A data input screen appears.
3. Enter data for the new organization.

- **Name.** Enter in the organization name. (This is the only required field.)
- **Description.** Enter details about the organization.
- **Type.** Select an option to assign a type to the organization. If the organization is a parent organization, click **Organization**, if the organization is a sub-organization, click **Organization Unit**. You can add more types to the drop-down by clicking the icon.
- **Organization Customer Group.** Select a customer group to assign for the organization, which lets you apply pricing, discounts, and personalization of content for this group.
- **Business Category.** Select from the drop-down menu to assign a category to the organization. You can add more categories by clicking the icon.
- **Parent.** You can assign a parent organization to an organization. If the organization you are creating is a sub-unit (child) of a larger organization, then select the parent in the drop-down menu. If you do not see the Organization listed on the drop-down menu, click **More...**
4. Click OK to save the organization. The **Organization Info** window of the organization appears where you can view **Information** about the organization you just created. You also can see associated **Contracts, Organizations, Addresses, and Credit Cards** that Episerver provides by default. Click **Edit** to edit the organization. Click **Organizations** to return to the organization List.

---

**Creating an organizational hierarchy**

You can create an organization hierarchy by assigning a parent organization to a child organization and then another organization to the child. You can set permissions determine which users can view certain organizations in the hierarchy. In the following example, *Company X* is the parent organization and *Company X West* is the organization unit.

1. Go to Organizations and click **New Organization**.
2. Enter data for the organization (see previous section).
3. Under the **Parent** option, assign the desired parent organization (*"Company X"*). If you do not see the organization on the drop-down menu, click **More...**
4. Click OK to save the organization. In the Organization Info page, the organization unit (Company X West) becomes the child to the Organization (Company X) you selected.

![Organization Info Screenshot](image)

5. Repeat the steps above to create further organization units for the parent organization.

### Commerce Deleting an organization

1. Go to Commerce Manager > Customer Management > Organizations. The Organizations page appears, listing existing organizations.
2. In the list of organizations, select the organization you want to delete and click **Delete**. A confirmation message appears.

![Organization List Screenshot](image)

3. Select either **Delete Organizations Only** or **Delete Organizations, Child Organizations and Contacts** and click OK to complete the deletion.

© Episerver 2016
You can delete organizations with children without deleting the child organizations and contacts with no repercussions. This only leaves the contacts and child organizations as orphans that you can later reassign using the same methods described in Creating an organization.

### Adding dictionary values for an organization

This topic is intended for administrators and developers with administration access rights in Episerver.

You can create your own organization types, customer groups, and business categories. For example, you can create a customer group called Partner, and a business category can be an industry branch called Automotive or Food & Dining. This type of data is managed in dictionaries. This section describes how to add dictionary values.

1. In **Commerce Manager > Customer Management**, open the Organization Edit page by creating a new organization or editing an existing one. Click **Edit Dictionary** next to the **Type** drop-down menu.
2. On the dialog box that appears, click **Edit** to modify an existing organization type dictionary. To add a new item to the dictionary, click **New Item**.

3. Select the order of the item from the drop-down on the left and enter a name for the item on the field next to the drop-down.

4. Click **Save**.

5. Click **Close**. You can select the dictionary item in the **Type** drop-down.
To delete a dictionary item, open the dictionary list and click **Delete** next to the item.

If you change the number to a position higher in the list, the list is not automatically reordered. You must therefore manually edit the entire list. However, having multiple copies of the same numerical value does not affect the system. Therefore, you can use the numbers as a ranking system, or you can devise your own internal method of numbering.

**Creating, editing and deleting business categories**

Episerver provides a list of categories that you can assign to an organization. You can add categories the same way you add organization types.

1. Click **Edit Dictionary** next to the **Business Category** drop-down menu.
2. On the resulting dialog box, click **Edit** to modify the existing business categories. Click **New Item** to add a new item to the dictionary. Click **Delete** to delete an item from the list.
3. Select the order of the item from the drop-down on the left and enter a **name** for the item on the field next to the drop-down.
4. Click **Save**. You can select the new business category in the **Business Category** drop-down menu.

**Commerce Contacts**

A contact and a related account is created automatically when a visitor registers on the public front-end site. You also can manually create a contact from Commerce Manager.

You can assign a contact to **customer groups** and **organization customer groups**. A customer group is assigned to an organization, which determines eligibility for selling prices and discount campaigns in the system.

A contact in an organization is a member of that organization's customer group, even if the contact is assigned individually to a different customer group.

**Commerce Browsing contacts**

To browse contacts, go to **Commerce Manager > Customer Management > Contacts**. The **Contact List** page shows a list of existing contacts.
Select a contact to detailed information about the contact, such as addresses, order history and so on.
You can add objects or metadata to the default View Form via Business Foundation.

**Searching for a contact**

On the **Contact Info** page, use the search form to search for a contact. Click **Search** (magnifying glass). Contacts that match the search criteria appear on the list.

To clear the search and revert back to show all contacts, click **Reset** (eraser).

**Customizing views for browsing contacts**

As an contact list gets longer, you can create and customize views to filter the list. Define the columns you want to be displayed for the view, and the filters to be applied when selecting what to include in the view.

1. On the General tab, enter a Title for the custom view. Click Show this view for all users if you want other users to see this custom view.
2. On the Fields tab, select which columns you want to appear in the custom view. Select an available column and click Right Arrow to move it to the Visible columns list. To deselect and column select a visible column and click Left Arrow. Click Up and Down arrows to re-order the list.

3. On the Filters tab, set the view filters. Click + to add another filter.
2. Click **Save** to return to the **Contacts List** screen. The new view appears in the **View** drop-down box.

**Editing and deleting views**

To edit an existing view, select the view from the drop-down menu and click **Edit**. The **View Editing** dialog is displayed and you can edit all properties.
To **delete** a custom View, click **X**.

**Printing a list of contacts**

Click **Printer Version** to generate a printer-friendly list of contacts. A new window pops up and renders a simple table suitable for printing.

<table>
<thead>
<tr>
<th>FullName</th>
<th>FirstName</th>
<th>LastName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receiving Manager</td>
<td>Receiving</td>
<td>Manager</td>
</tr>
<tr>
<td>Order Manager</td>
<td>Order</td>
<td>Manager</td>
</tr>
<tr>
<td>jennifer Browne</td>
<td>Jennifer</td>
<td>Browne</td>
</tr>
<tr>
<td>Mary Smith</td>
<td>Mary</td>
<td>Smith</td>
</tr>
<tr>
<td>Shipping Manager</td>
<td>Shipping</td>
<td>Manager</td>
</tr>
<tr>
<td>admin</td>
<td>admin</td>
<td></td>
</tr>
<tr>
<td>Order Supervisor</td>
<td>Order</td>
<td>Supervisor</td>
</tr>
<tr>
<td>Carlos Nevada</td>
<td>Carlos</td>
<td>Nevada</td>
</tr>
<tr>
<td>Lisa Prescott</td>
<td>Lisa</td>
<td>Prescott</td>
</tr>
</tbody>
</table>
Creating a contact with an account

Creating system users and assigning access rights (roles) to work with CMS and Commerce is done from the CMS admin view, see Access rights for Commerce. The procedure described here relates to website visitors and shopping customers.

The following procedure creates a contact with an account account.

1. In Commerce Manager > Customer Management, click New Contact on the Contact List page. The Contact Edit page appears where you can enter information about the contact.

2. Enter information about the contact.
Full Name. Required. Enter the contact’s full name.
First Name. Required. Enter the contact’s first name.
Middle Name. Optional. Enter the contact middle name.
Last Name. Required. Enter the contact’s last name.
Email. Required. Enter the contact’s email address.
Parent Organization. Optional. Select a parent organization to which the contact is assigned.
Customer Group. Optional. Select a customer group to which the contact is assigned.
You can add customer groups by editing the Customer group dictionaries. Customer groups are useful for targeted Marketing campaigns.
» **Preferred Currency.** Optional. Select a currency for the contact. For example, if the contact is in France, select the Euro currency. You set available currency options in Administration > System Settings > Dictionaries > Currencies.

» **Preferred Language.** Optional. Select a language for the contact. You set available languages in Administration > System Settings > Dictionaries > Languages.

» **Preferred Shipping Address.** Automatic; related to company accounts.

» **Preferred Billing Address.** Automatic; related to company accounts.

» **Registration Source.** Optional. Enter notes about the contact (such as which website the contact is currently registered under).

The Registration Source field is automatically filled when a user creates a new account from the public website.

3. Click **OK** to save the contact. The **Contact Information** form is displayed. To display the Contacts List, click **Contacts** or **Cancel**.

You can enter additional information for the contact, view order history, and add notes for both orders and the contact. You can customize the form using Business foundation.

A customer account is automatically created for a customer who registers from the front-end public website, allowing them to log in and view personalized information. To manually create an account, continue with the procedure.

4. Click **Create account** on the **Contact Info** page. The **Create Account** dialog appears.
5. Enter data in the **Create account** dialog.

![Create account dialog](image)

- **User Name**: Required. Enter a name that may include spaces and special characters.
- **Password**: Required. Enter a password for the account.
- **Description**: Optional. Add information about the contact account.
- **Email**: Enter the contact's email address.
- **Approved**: Click **Yes** to enable. Click **No** to keep the account inactive and inaccessible by the contact.

6. Click **OK** to create the account. User account information appears under the **Account** section of the **Contact Information** form.

- **Is Locked out**: Last time a user was locked out due to too many failed log in attempts.
- **Last Activity**: Last time the user logged in or made any changes to the site.
- **Last Login**: Last time the user logged into his or her account.
Last Password Changed. Last time the user account password changed.

Editing or deleting a contact and account

Go to Commerce Manager > Customer Management > Contacts to do the following:

- **Edit a contact.** Select the contact in the contact list and click Edit. Edit the information and click OK.
- **Edit an account.** Select the related contact in the contact list and select the Edit Account option in the lower part of the dialog box. Edit the information and click OK.

You cannot change the User Name unless you remove the account and recreate the same account again.

- **Delete a contact.** Select the contact in the list of contacts click Delete. Click OK to confirm.
- **Delete an account.** Select the related contact in the contact list and click Remove Account in the lower part of the dialog.

Adding dictionary values for a contact

You can create your own customer (contact) groups that you can apply when you add contacts to your organization. By default, customer groups can be of type Customer, Partner or Distributor. This type of data is managed in dictionaries. You can use customer groups when you define pricing or restrict promotions.
1. In **Commerce Manager > Customer Management**, open the **Contacts Edit** page by creating a new contact or editing an existing one. Click **Edit Dictionary** next to the **Customer Group** drop-down menu.

2. On the dialog box that appears, click **Edit** to modify an existing customer group dictionary. To add a new item to the dictionary, click **New Item**.

3. Select the order of the item from the drop-down on the left and enter a name for the item on the field next to the drop-down.
4. Click **Save**.
5. Click **Close**. You can select the dictionary item in the **Customer Group** drop-down.

To delete a dictionary item, open the dictionary list and click **Delete** next to the item.

If you change the number to a position higher in the list, the list is not automatically reordered. You must therefore manually edit the entire list. However, having multiple copies of the same numerical value does not affect the system. Therefore, you can use the numbers as a ranking system, or you can devise your own internal method of numbering.

**Roles and tasks**

Episerver is designed for interaction with website visitors, as well as collaboration between users. A user in Episerver is someone working with different parts of the platform. A user can belong to one or more user groups and roles, depending on their tasks as well as the size and setup of the organization. Typical roles and related tasks are described below. Refer to Setting access rights in the CMS Administrator User Guide for information on how to configure user groups and roles in Episerver.

**Visitor**

A visitor is someone who visits the website to find information or to use available services, on an e-commerce website possibly with purchasing intentions. Purchasing on an e-commerce website can be done either "anonymously" (payment and shipping details provided), or by registering an account. Visitors may also contribute to website content as community members, which usually requires registration of an account profile.

**Community member**

Content may be added by visitors or community members, if social features and community functionality are available for the website. This content includes forum and blog postings, reviews, ratings and comments, in which case there might be a need for monitoring this type of content on the
website. Monitoring can be done for instance by an editor, or a specific moderator role for large websites and online communities.

**Content editor**

A content editor is someone with access to the editorial interface who creates and publishes content on the website. Content editors with good knowledge of the website content work with search optimization for selected content in search results. Editors may also want to follow-up on content with unusually high or low conversion rate in order to update or delete this content.

**Marketer**

A marketer creates content and campaigns with targeted banner advertisements to ensure customers have consistent on site experience of the various marketing channels. Furthermore, the marketer monitors campaign KPIs to optimize page conversion. A marketer with good knowledge of the website content may also want to monitor search statistics in order to optimize search for campaigns and promote content.

**Merchandiser**

A merchandiser typically works with stock on an e-commerce website to ensure that the strongest products are put in focus. This role also creates landing pages, sets product pricing, coordinates cross-product selling, oversees delivery and distribution of stock, and deals with suppliers. This user wants to be able to identify search queries with unusually high or low conversion rates, in order to adjust either the search or the product line.

**Website owner**

A website owner is someone with overall responsibility for the content and performance of one or more websites. This user monitors website activities such as page conversions, customer reviews or sales progress. Rarely creates content but can be involved in the approval of content created by others. A website owner may have administrative access rights and may be able to install selected add-ons on the website.

**Administrator**

An administrator works with configuration of various system settings from the administration user interface, including search, languages, user access rights and visitor groups for personalized content. Administrators may also install add-ons on the website. Administrators usually have extended access rights compared to other user groups, and can access all parts of the Episerver platform.
**Developer**

A developer is someone with programming skills working with the setup and implementation of the website, as well as maintenance and development of new functionality. Creates the content templates for pages, blocks and catalog content used by editors in CMS and Commerce, configures e-commerce settings, and manages the index and customized search features in Find. Developers may also install add-ons on the website.
Markets

A market can be a country or a set of countries, regions or specific customer groups, where you want to apply specific products, languages, currencies or promotions. You can define many markets, each with its own product, catalog, language, currency, and promotions, to be used on a single-site. The market features opens up for targeted merchandising and a more personalized user experience.

Markets are defined under Market Management in Commerce Manager for usage in other parts of the system. With the multiple market options, you can customize which products appear and which payment methods to use for a specific market. You also can filter reports per market by using the market definitions, and personalize content for targeted customer groups.

Defining markets

This section describes how to define markets in Episerver Commerce.

Browsing markets

Go to Commerce Manager > Market Management > Markets and expand the markets. The market overview displays existing markets with their languages, currencies and status (active or not).
The Default Market defines the language and currency used as fallback for markets that are not specified.

Creating or editing a market

1. Go to Commerce Manager > Market Management > Markets. The markets list appears.
2. Select Create New > New Market, or select an existing market in the list. The Market Overview tab appears.
Market Overview

- **Market ID:** BENELUX
- **Market Name:** Benelux
- **Market Description:** Belgium Luxemburg Netherlands
- **Is Active:** Yes

### Countries

**Available Countries**
- Namibia
- Nauru
- Nepal
- Netherlands Antilles
- New Caledonia
- New Zealand
- Nicaragua
- Niger
- Nigeria

**Chosen Countries**
- Belgium Luxemburg
- Netherlands

### Languages

**Available Languages**
- German (Germany)
- Spanish (Spain)

**Chosen Languages**
- English (United States)
- French (France)

Default Language: English (United States)

### Currencies

**Available Currencies**
- Australian dollar
- Canadian dollar
- Swiss franc
- Czech koruna
- Danish krone
- Estonian kroon
- Pound sterling
- Hungarian forint
- Icelandic krona

**Chosen Currencies**
- Euro

Default Currency: Euro

> **Market ID.** Enter an identifier for the market.
> **Market Name.** Enter the name that is displayed in the markets list.
Market Description. Enter notes about the market.
Is Active. Yes to activate; No to deactivate.
Countries. For each country you want, select the country and click Add.
Languages. For each language you want, select the language and click Add.
Currencies. For each currency you want, select the currency and click Add.
Default currency. Set the default fallback currency.

A website can exist in many languages. By defining market languages, you provide the possibility to read content in a desired language for a selected market; Selecting English as preferred language does not automatically mean that a visitor belongs to the US or UK markets. You can provide content in English for a Swedish market, for non-Swedish speaking visitors located in Sweden.

3. Click OK.

Deleting a market

1. Go to Commerce Manager > Market Management > Markets. The markets list appears.
2. Select the check box next to the market you want to delete.
3. Select More Actions > Delete Selected.
4. Select OK to confirm.
Marketing

The marketing system provides a new Campaigns user interface, in addition to the legacy campaign system, for managing campaigns and discounts.

Use Episerver's Marketing system to create discounts and promotions that can be applied to products, orders, or shipping. Typically, promotions are created and managed by marketing and catalog managers, and other users who handle pricing and discounts.

The marketing features allow you to create campaigns with unique and compelling discounts. Discounts are typically based on a percentage or fixed value. You can target discounts to specific customers, time periods, or markets.

Common marketing tasks are listed below. Available tasks depend on whether you are using the new Marketing system, or the legacy marketing system.

**Marketing view**

- Creating and managing campaigns.
- Creating discounts.
- Prioritizing discounts.
- Discount exclusions.
- Built-in discounts

**Marketing system in Commerce Manager (Legacy)**

- Creating and managing campaigns, which can be targeted to specific groups of users.
- Configuring customer segments, for targeting of promotions to specific groups of users and customers.
- Creating different types of promotions with discounts and coupons.
- Configuring expressions and policies for defining additional rules and promotion types.

Campaigns and discounts

The marketing system provides a new Campaigns user interface, in addition to the legacy campaign system, for managing campaigns and discounts.

In Episerver Commerce, you use campaigns to manage discounts when deploying targeted marketing efforts. You can assign a campaign to a specific market, to serve local needs, or to all markets. You can also limit a campaign to members of selected visitor groups.
When setting up a campaign, you define its essential information, such as active date range, target market, eligible visitor groups, and discounts.

**Campaign overview**

To view existing campaigns or create new ones, go to the global menu and select **Marketing**. The Campaign view displays each campaign’s status and discounts. From this screen, you can perform tasks such as create new campaigns, edit existing ones, create and edit discounts, and so on.

The view sorts campaigns by *status* (identifiable by background color), described below.

- **Active** (green). *Active* box is checked, *Available from* date is in the past, and *Expires on* date is in the future.
- **Scheduled** (orange). *Active* box is checked but *Available from* date is in the future.
- **Expired** (red). *Active* box is checked, but *Expires on* date is in the past.
- **Inactive** (gray). *Active* box is unchecked.

Below each campaign, its discounts appear on a white background.

On the Campaign view, each discount has an icon that illustrates the discounted object.

- ![Discount Code](image) Discount applies to entire order.
- ![Discount Item](image) Discount applies to items.
Discount applies to shipping costs.

Creating a campaign

To create a campaign, identify the following:

- Schedule
- State (active or inactive)
- Market
- Revenue goals
- Google tracking code
- Visitor groups
- Discounts

You can watch the following Demo of creating a campaign and discount video. (4:43 minutes)

1. From edit view, select Commerce > Marketing.
2. Select Create > Sales Campaign.
3. Assign a name to the campaign. The Edit Campaign view appears.
4. Complete its fields using the following information, then click **Save**.

### Campaign fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The campaign name appears. Edit if desired. The name appears on the Campaign view screen and on dialogs that let users select campaigns.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Enter a description of the campaign. It only appears on this screen.</td>
</tr>
<tr>
<td><strong>Scheduling and Status</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Available from</strong></td>
<td>Select the date and time when the campaign is available. The campaign is active only if the shopping date/time is between the <strong>Available from</strong> and <strong>Expires on</strong> dates/times and the <strong>Active</strong> box is checked.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Expires on</td>
<td>Select the date and time when the campaign is no longer available.</td>
</tr>
<tr>
<td>Active</td>
<td>Select the box to make the campaign active, or clear it to make it inactive.</td>
</tr>
<tr>
<td></td>
<td>For a campaign to be active, the <strong>Active</strong> box must be selected <em>and</em> the shopping date/time must be between the <strong>Available from</strong> and <strong>Expires on</strong> dates/times.</td>
</tr>
<tr>
<td></td>
<td><strong>Active check box examples</strong></td>
</tr>
<tr>
<td></td>
<td>▶️ When you set up a new campaign (including its discounts), keep <strong>Active</strong> cleared. When everything is correct, select <strong>Active</strong>, and the campaign goes live.</td>
</tr>
<tr>
<td></td>
<td>▶️ An active campaign is configured incorrectly. Clear <strong>Active</strong> to pause the campaign, correct it, then select <strong>Active</strong> to enable it.</td>
</tr>
<tr>
<td>Market and Revenue</td>
<td></td>
</tr>
<tr>
<td>Target market</td>
<td>Select a target market or <strong>ALL</strong>. If you choose a market, only products assigned to it are eligible for the discount.</td>
</tr>
<tr>
<td></td>
<td>Also, if you create a discount for this campaign that involves an amount reduction, the list of currencies is determined by the active currencies for countries in this market.</td>
</tr>
<tr>
<td>Revenue goal</td>
<td>Specify a revenue goal for the campaign.</td>
</tr>
<tr>
<td></td>
<td>The Commerce system does not currently use this value—you must manually track campaign revenue.</td>
</tr>
<tr>
<td>Tracking Code</td>
<td>Use to enter a tracking code for campaign analytics. This field must be specifically implemented for your site.</td>
</tr>
<tr>
<td>Personalization</td>
<td>If you want to limit this campaign to certain visitor groups, select them. If you do, only group members can use the campaign's discounts. See also <strong>Personalization</strong>.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Discounts</td>
<td>See Discounts</td>
</tr>
</tbody>
</table>

**Editing a campaign**

1. From the Campaign view, hover over a campaign. On the far right side, a context menu appears.
2. Select **Edit**.
3. Modify the **fields**.

**Deleting a campaign**

1. From the Campaign view, hover over a campaign. On the far right side, a context menu appears.
2. Select **Delete**.

Deleting a campaign cannot be undone, and all discounts created for the campaign are also deleted.

See also: **Discounts**

**Commerce** **Discounts**

Episerver Commerce has a powerful and flexible feature for applying discounts to create targeted **campaigns**. Episerver Commerce offers a set of **standard discounts**, featuring the most common setups, which you can easily customize to accommodate specific campaigns.

**Discount colors**

A discount is color-coded to help you identify its components.

- **Gray**. Products or categories from which purchases must be made to activate the discount.
- **Blue**. Discounted items.
- **Green**. Discount amount or percentage.
Buy Products for Discount from Other Selection

Buy at least X items from catalog entries and get related catalog entries at a discount.

Buy at least...
X items

From these entries
You can add these content types
All

No items
Drag and drop items here, or Browse...

☑ Include subcategories

Get...
these entries
You can add these content types
All

No items
Drag and drop items here, or Browse...

☑ Include subcategories

Limit number of discounted items
Unlimited

At the following discount

☐ Percentage off
☐ Amount off

Creating a discount
Discounts are a key component of an effective marketing campaign, for example "buy 3, get the cheapest for free."

If you create several concurrent promotions that apply to one line item with quantity greater than one, be sure you understand the impact of all promotions on an order.

**Prerequisite:** A campaign. If no campaigns exist, **create one.**

You can watch the following Demo of creating a campaign and discount video. (4:43 minutes)

1. Access the Discount view using any method listed below.
   - From the Campaigns view's top left corner, select **Create > Discount.**
   - When using this option, you select a campaign then define the discount.
   - From a campaign's context menu, select **New > Discount.**
   - While editing a campaign or creating a new one, select **+ New Discount.**

2. Assign a name to the discount.
3. Choose a discount type. (See Built-in discounts.) The Edit Discount view appears.
4. Complete the fields using the following information, then click **Save.**

**Discount fields**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the name of the discount.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description of the discount. The description only appears on this view. Use it to communicate the discount's purpose to other merchandisers.</td>
</tr>
<tr>
<td>Banner Image</td>
<td>If you want to use a banner image with this discount, upload it to the Episerver media folder, then select it here. See also: Uploading media in the CMS Editor User Guide. The image can illustrate the discount on the web page. Your developer determines how to display the banner.</td>
</tr>
</tbody>
</table>

**Scheduling and Status**—By default, a discount's start and end dates match its campaign's dates. To change the discount's active dates, click **Different start and end dates, within the campaign dates** and complete the following fields.

| Available from   | Select the date and time when the discount is available. The discount is active only if the shopping date/time is between the Available from and Expires on dates/times, and the |

© Episerver 2016
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Active</strong> box is selected.</td>
<td>The time refers to local time on the Episerver server. For example, you manage the website from Stockholm, Sweden and set a campaign to expire at 11:00 PM. Due to a nine-hour difference, for a customer in California, USA, the campaign expires at 2:00 PM.</td>
</tr>
<tr>
<td><strong>Expires on</strong></td>
<td>Select the date and time when the discount is no longer available.</td>
</tr>
</tbody>
</table>
| **Active**          | For a discount to be active, the shopping date/time must be between the available and expiration dates/times, and the active box must be selected. **Active check box examples**  
  - While setting up a new discount, keep **Active** cleared. When everything is correct, select **Active**, and the discount is live.  
  - An active discount is configured incorrectly. Clear **Active** to pause it, correct it, then select **Active** to enable the discount. |
| **Promotion codes** | If applicable, enter a promotion code for this discount. Promotion codes as also known as coupons. See also Using promotion codes.                                                                           |
| **Discount**        | Complete the information to define the discount. See Example: Buy three items, get cheapest free and Built-in discounts.                                                                                       |
| **Redemption limits** | If applicable, enter one or more redemption limits for this discount; that is, the maximum number of times a discount can be redeemed. See also: Applying redemption limits.                                      |

**Example: Buy three items, get cheapest free**

Assume you want to implement the following discount: If a customer buys 3 automotive accessories, the least expensive item is free. To create that discount, follow these steps.

**Prerequisite:** A campaign. If no campaigns exist, create one.
1. From the Campaigns view’s top left corner, select Add > Discount.
2. Select the campaign to which the discount will belong.
3. Assign the name AutoAcc Buy 3 get cheapest free.
4. For Type, select Get Cheapest for Free.
5. At the Scheduling and Status area, select the discount’s beginning and ending dates and whether the discount is active.
6. This example assumes that the discount does not use a Promotion code, so ignore that field. See also Using promotion codes
7. At the Buy... at least X items field, enter 3.
8. From the top right corner of the view, click Catalogs.
9. Select Automotive > Accessories then drag and drop it to the area below from these categories/entries. See also Selecting discount-eligible items.

10. At the Get cheapest Y for free field, enter 1.
11. Click Save.

Selecting discount-eligible items
To select discount-eligible items, either drag and drop them from the catalog or click Browse.

If you select no items, the discount is not applied.

When working in the gray area of the view, you can select:
One or more categories. Its products are eligible. Use the Include subcategories box to determine if products in selected categories’ subcategories also are eligible. By default, the box is selected.

Individual products, SKUs, or packages.

Some discounts let you select a catalog. If you can, Catalog appears on the view.

You can add these content types: Category, Product, VariantSKU, Package, Catalog.

A package counts as one item when calculating the X in Buy at least X items. If a bundle is purchased, its items are treated like they were ordered separately.

How Episerver Commerce determines which items to discount

Sometimes, an order has several discount-eligible items but not all can be discounted. For example, if a customers buy 5 shirts, they get a discount on two. Or, the limit number of discounted items drop-down restricts how many items get discounted. To determine which items are discounted, Episerver Commerce calculates the maximum customer savings.

Example

Discount: Buy at least 9 eligible items, and get a 25% discount on three. Assumes no redemption limits.

Sample order before discount

<table>
<thead>
<tr>
<th>Item</th>
<th>Quantity</th>
<th>Cost per item</th>
<th>Item total</th>
</tr>
</thead>
<tbody>
<tr>
<td>White shirt</td>
<td>5</td>
<td>$5.00</td>
<td>$25.00</td>
</tr>
<tr>
<td>Blue shirt</td>
<td>2</td>
<td>$10.00</td>
<td>$20.00</td>
</tr>
<tr>
<td>Yellow shirt</td>
<td>2</td>
<td>$15.00</td>
<td>$30.00</td>
</tr>
</tbody>
</table>

Total cost = $75.00

After discount

To maximize customer savings, the discount is first applied to the two most expensive items, the yellow shirts. Next, it is applied to one of the next most expensive items, a blue shirt. Since only three items are discounted, the second blue shirt is full price.

<table>
<thead>
<tr>
<th>Item</th>
<th>Quantity</th>
<th>Cost per item</th>
<th>Line item total</th>
</tr>
</thead>
<tbody>
<tr>
<td>White shirt</td>
<td>5</td>
<td>$5.00</td>
<td>$25.00</td>
</tr>
<tr>
<td>Item</td>
<td>Quantity</td>
<td>Cost per item</td>
<td>Line item total</td>
</tr>
<tr>
<td>---------------</td>
<td>----------</td>
<td>-----------------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Blue shirt</td>
<td>1</td>
<td>$10.00</td>
<td>$10.00</td>
</tr>
<tr>
<td>Blue shirt</td>
<td>1</td>
<td>$7.50 (25% discount on 1 item)</td>
<td>$7.50</td>
</tr>
<tr>
<td>Yellow shirt</td>
<td>2</td>
<td>$11.25 (25% discount on 2 items)</td>
<td>$22.50</td>
</tr>
</tbody>
</table>

**Total cost of order = $65.00**

### Using promotion codes

A promotion code is an additional criterion that you can apply to any discount. A typical use case is: customers who enter promotion code **CouponABC** during checkout receive 10% off the order.

To apply a promotion code to a discount, create the discount as you normally do. Then, in the discount view's **Promotion codes** field, enter a unique promotion code.

### Edit Discount

**Name**: handbag sale

**Description**: Enter any internal notes and comments

**Scheduling and Status**

- Same as the campaign (Aug 24, 12:00 AM to Tomorrow, 12:00 AM)
- Different start and end dates, within the campaign dates
- **Active**

**Promotion Codes**

Specify a promotion code for customers to qualify for discount.

**Promotion code**: BuyABag

### Discount: Reduction on Related Items

Buy at least X items from catalog entries and get related catalog entries at a discount.
If you create such a discount, it is activated if the customer enters the promotion code and the other discount criteria are satisfied (for example, the discount is active, date is within the active date range, eligible products are selected, and so on).

**Applying redemption limits**

When creating a discount, you can set redemption limits, that is, the maximum number of times a discount can be redeemed on a single order form. Set these limits on the Edit discount view. See also Creating a discount.

### Redemption Limits

The number of times a promotion can be redeemed. If limits are increased during a campaign period the previous redemptions will be kept.

<table>
<thead>
<tr>
<th>Type</th>
<th>Limit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>Unlimited</td>
<td>Redeemed in total across all orders</td>
</tr>
<tr>
<td>Order</td>
<td>Unlimited</td>
<td>Per order</td>
</tr>
<tr>
<td>Customer</td>
<td>Unlimited</td>
<td>Per registered user</td>
</tr>
</tbody>
</table>

There are three types of redemption limits.

- **Total.** The maximum number of times a discount can be redeemed across *all orders and customers.*
- **Order.** The maximum number of times a discount can be redeemed on a single order form.
  
  This limit is not available to discounts that apply to an entire order.
- **Customer.** The maximum number of times that one *customer* can redeem a discount. If you set this limit, the discount is not available to anonymous (not logged-in) users.

You can adjust redemption limits at any time during a campaign. If you do, it does not affect the number of redeemed discounts.

**Combining redemption limits**

You can set a redemption limit on the total number of discounts, or per order, or per customer. And, you can combine limits. If you set more than one, during validation, the lowest number of available
discounts determines if the discount is still available. For example, a discount has three limits:

- Per discount: 500
- Per customer: 10
- Per order: 5

If a discount was redeemed 497 times, and the logged-in customer has not redeemed it yet, and the discount was not used on this order, the maximum number of redemptions is 3.

To continue the example, once the discount is redeemed 500 times, it is no longer available.

Here is another example.

- Per discount: unlimited
- Per customer: 10
- Per order: 2

If a customer creates an order and tries to apply this discount to three items, only two items (the per order limit) are discounted. The third item is full price.

**Viewing the number of redeemed discounts**

The Campaign View shows the current number of redemptions for each discount.

<table>
<thead>
<tr>
<th>Campaign</th>
<th>Active</th>
<th>Redemptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Handbag sale</td>
<td>Aug 24 - Tomorrow</td>
<td>1</td>
</tr>
</tbody>
</table>

**Built-in discounts**

Episerver Commerce provides many common discounts out-of-the-box. This topic explains the built-in discounts.

- **Item discounts**
  - Cheapest items for free
  - Most expensive items for free
  - Buy products for fixed price
  - Buy products for discount from other selection
  - Buy products for discount on all selections
  - Buy products for discount in same categories
Spend for discounted selection
Spend for free items

Order discounts
Spend for discount on order
Buy products and get discount on order

Shipping discounts
Spend for discount on shipping cost
Buy products for discount on shipping cost
Buy products for free shipping
Spend for free shipping

Cheapest items for free
Buy at least $X$ eligible items, and get the cheapest $Y$ items for free. For example, on an order that has 5 electronic accessories, the cheapest one is free.

Cheapest Items For Free
Buy at least $X$ items from catalog entries, get the cheapest $Y$ for free.

Buy at least...

$X$ items

From these entries

You can add these content types
All

No items

Drag and drop items here, or Browse...

Include subcategories

Get cheapest $Y$ for free

Example
Buy at least 10 eligible products, get the cheapest 3 for free. Assumes no redemption limits.
Sample order before discount

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Cost per product</th>
<th>Line total</th>
</tr>
</thead>
<tbody>
<tr>
<td>White shirt</td>
<td>5</td>
<td>$5.00</td>
<td>$25.00</td>
</tr>
<tr>
<td>Blue shirt</td>
<td>3</td>
<td>$10.00</td>
<td>$30.00</td>
</tr>
<tr>
<td>Yellow shirt</td>
<td>3</td>
<td>$15.00</td>
<td>$45.00</td>
</tr>
</tbody>
</table>

Total cost of order = $100.00

After discount

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Cost per product</th>
<th>Line total</th>
</tr>
</thead>
<tbody>
<tr>
<td>White shirt</td>
<td>5</td>
<td>$5.00</td>
<td>$10.00; 3 of 5 shirts are free</td>
</tr>
<tr>
<td>Blue shirt</td>
<td>3</td>
<td>$10.00</td>
<td>$30.00</td>
</tr>
<tr>
<td>Yellow shirt</td>
<td>3</td>
<td>$15.00</td>
<td>$45.00</td>
</tr>
</tbody>
</table>

Total cost of order = $85.00

The view has two sections:

- **Buy at least X items...** Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.
- **Get the cheapest Y for free.** Enter the number of items to which no charge will be applied at checkout. Only this number of the cheapest items will be free.

**Most expensive items for free**

Buy at least X eligible items, and get the most expensive Y items for free. For example, if an order includes 5 hardcover books, the most expensive one is free.
Most Expensive Items For Free

Buy at least $X$ items from catalog entries, get the most expensive $Y$ for free.

The view has two sections:

- **Buy at least $X$ items...** Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.
- **Get most expensive $Y$ for free.** Enter the number of items to which no charge will be applied at checkout. Only this number of the most expensive items will be free.

Buy products for fixed price

Buy a fixed number of items from selected categories for a set price. For example, buy 3 men's shirts for £50.

The discount is applied only if the fixed price is less than the items' cost. For example, you create a fixed price discount: **Buy 2 from Top-Tunics for $250.**

- Buyer A selects two Top-Tunics items: $150 each, $300 total. In this case, the discount is applied, because the fixed price ($250) is less than the $300 total.
- Buyer B selects two Top-Tunics items: $100 each, $200 total. In this case, the discount is not applied, because the fixed price ($250) exceeds the $200 total.
The view has two sections:
Buy at least X items.... Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.

Receive catalog entries at fixed price. For the above items, enter a fixed price for each currency. If no amount is entered for a currency, no discount is available for it.

The list of currencies is determined by the campaign's target market.

Buy products for discount from other selection

Buy a minimum amount from a group of items to get a discount on a second group of items. For example, customers who purchase a winter coat get a 30% discount on scarves, gloves, and hats. There is no relationship between the first set of items and the second.
Buy Products for Discount from Other Selection

Buy at least X items from catalog entries and get related catalog entries at a discount.

The view has three sections:
Buy at least X items.... Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.

Get... these entries. Select items to be discounted. This area has a context-sensitive menu that includes Move up and Move Down options for each item. A product’s position has no effect on how discounts are processed.

At the following discount. Choose how to calculate the discount.

- **Percentage off.** Enter the discount as a percentage of the items’ cost.
- **Amount off.** Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

The list of currencies is determined by the campaign’s target market.

**Buy products for discount on all selections**

Buy a minimum number of selected items and get a discount on all items. For example, purchase 2 or more long-sleeved shirts and get a 15% discount on all long-sleeved shirts. The discount can be an amount or a percentage.
Buy Products for Discount on All Selections

Buy at least X items from catalog entries and get a discount on every selected items.

Buy at least...
X items

From these entries

You can add these content types
All

No Items
Drag and drop items here, or Browse...

☑ Include subcategories

At the following discount

☐ Percentage off

☐ Amount off

The view has these sections:

Buy at least X items…. Enter the minimum number of items then the categories, products, and so on from which customers must pick. See also Selecting discount-eligible items.

This area has a context-sensitive menu with Move up and Move Down options for each item. A product’s position has no effect on how discounts are processed.
At the following discount. Choose how to calculate the discount.
  
  Percentage off. Enter the discount as a percentage of the items’ cost.
  
  Amount off. Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

The list of currencies is determined by the campaign’s target market.

Buy products for discount in same categories

When creating this discount, you select a category then a discount amount or percentage. The discount applies to all items in that category and its subcategories.

When calculating redemption limits, this discount counts each eligible item as 1. For example, if the order redemption limit is 5, and a shopper purchases 10 items in the selected category or subcategories, the discount only applies to 5 items. This is different from the way that Episerver Commerce typically handles redemption limits, where item quantity does not affect them.

How Episerver Commerce determines which items to discount explains what happens if only some items are discounted because a redemption limit is reached.

Buy Products for Discount in Same Categories

Buy any items from category to get a discount on them.

At the following discount

- Percentage off
- Amount off

The view has these sections.

- Buy from. Select a category. All items in it and its subcategories are eligible for the discount.
- At the following discount. Choose how to calculate the discount.
  
  Percentage off. Enter the discount as a percentage of the items’ cost.
  
  Amount off. Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.
The list of currencies is determined by the campaign’s target market.

**Spend for discounted selection**

Spend a minimum amount to get a discount on selected items. For example, spend at least €100 and get 10% off all belts. The discount can be an amount or a percentage.

The second group of items is independent of the first group. You have total flexibility in determining both groups.
Spend for Discounted Selection

Spend X amount and receive a discount off items from selection.

<table>
<thead>
<tr>
<th>Currency</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUD</td>
<td>Not set</td>
</tr>
<tr>
<td>DKK</td>
<td>Not set</td>
</tr>
<tr>
<td>EUR</td>
<td>Not set</td>
</tr>
<tr>
<td>GBP</td>
<td>Not set</td>
</tr>
<tr>
<td>NOK</td>
<td>Not set</td>
</tr>
<tr>
<td>NZD</td>
<td>Not set</td>
</tr>
<tr>
<td>RUB</td>
<td>Not set</td>
</tr>
<tr>
<td>SEK</td>
<td>Not set</td>
</tr>
<tr>
<td>USD</td>
<td>Not set</td>
</tr>
</tbody>
</table>

Get...

these entries

You can add these content types
All

No items

Drag and drop items here, or Browse...

- Include subcategories

Limit number of discounted items
Unlimited

At the following discount

- Percentage off

- Amount off
The view has three sections:

- **Spend at least...** Enter a minimum order amount needed to qualify for the shipping discount. This section displays all currencies for the campaign's target market. Enter a minimum qualifying amount for each eligible currency. If no amount is entered, the discount is not available in that currency.
- **Get... these entries.** Select items to be discounted. This area has a context-sensitive menu that includes Move up and Move Down options for each item. A product’s position has no effect on how discounts are processed.

The Get these entries section also has a Limit number of discounted items dropdown that lets you set a maximum number of discount-eligible items, if desired. See also How Episerver Commerce determines which items to discount.

- **At the following discount.** Choose how to calculate the discount.
  - **Percentage off.** Enter the discount as a percentage of the items’ cost.
  - **Amount off.** Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

  The list of currencies is determined by the campaign's target market.

**Spend for free items**

Spend a minimum amount on an order and get free items.
Spend for Free Items

Spend at least X amount and get all variants/skus as gift items.

Spend at least...

<table>
<thead>
<tr>
<th>Currency</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUD</td>
<td>Not set</td>
</tr>
<tr>
<td>DKK</td>
<td>Not set</td>
</tr>
<tr>
<td>EUR</td>
<td>Not set</td>
</tr>
<tr>
<td>GBP</td>
<td>Not set</td>
</tr>
<tr>
<td>NOK</td>
<td>Not set</td>
</tr>
<tr>
<td>NZD</td>
<td>Not set</td>
</tr>
<tr>
<td>RUB</td>
<td>Not set</td>
</tr>
<tr>
<td>SEK</td>
<td>Not set</td>
</tr>
<tr>
<td>USD</td>
<td>Not set</td>
</tr>
</tbody>
</table>

Get free items

You can add these content types
Variant/SKU, Package

No items
Drag and drop items here, or Browse...

The view has two sections:

- **Spend at least...** Displays all currencies for the campaign's target market. Enter a minimum qualifying amount for each eligible currency. If no amount is entered, the discount is not available for that currency.
- **Get free items.** Select variants/SKUs or packages that are automatically added to an order when the minimum amount is spent.
  To give away the same product more than once, select it multiple times.
**Spend for discount on order**

Spend a minimum amount to get a discount on an entire order. For example, spend at least €100 and get 10% off the order total.

Shipping and taxes excluded from the calculation of the order total. Also, if other discounts are applied to an order before this discount which reduce the order total below the minimum, this discount is not applied.

⚠️ With this discount, you typically set a redemption limit of 1 per order. See [Applying redemption limits](#).

For example, you create the discount "Spend at least $1000 and get $100 discount off total order amount" but set no redemption limits. If a customer purchases $2000 worth of items, a discount of $200 is applied. To limit the discount to $100, set a redemption limit of 1.
Spend for Discount on Order

Spend at least X amount and receive a discount off total order value.

The view has two sections:

- **Spend at least...** Define a minimum order value for each currency for which you want to provide a discount. If no amount is entered for a currency, no discount is available for it.
- **At the following discount.** Choose how to calculate the discount.
  - **Percentage off.** Enter the discount as a percentage of the items' cost.
  - **Amount off.** Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

The list of currencies is determined by the campaign's target market.
Examples

Spend at least $1000 and get $100 discount off total order amount.

- Customer buys a projector for $1000. There are no shipping costs or taxes. No other discounts or coupons are applied. Customer gets $100 discount, so order total is reduced to $900.
- Customer buys a tablet for $999. The order has a shipping cost of $20 and taxes of $10. Customer does not get the $100 discount because the order total (excluding shipping and taxes) is less than the minimum.
- Customer buys a laptop for $1010. There are no shipping costs or taxes. The order has a promotional code worth $50, which is applied before this discount. Since the adjusted order total, $960, is less than the minimum, the customer does not get the $100 discount.

Buy products and get discount on order

Buy a minimum number of products and reduce the cost of the order. You determine which products are eligible, and whether the discount is an amount or a percentage.
Buy Products and Get Discount on Order

Buy at least X items from catalog entries and get discount on order value.

The view has two sections:

- **Buy at least X items...** Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.

- **Get the following discount.** Define the discount as an amount or a percentage
  - If an amount, enter an amount for each currency for which you want to provide a discount.
  - The list of currencies is determined by the campaign's target market.
  - If a percentage, it applies to all available currencies.

**Spend for discount on shipping cost**

Spend a minimum amount on an order and get discounted shipping costs. The discount can be an amount or a percentage. Also, you choose which shipping methods qualify.
With this discount, you typically set a redemption limit of 1 per order. See Applying redemption limits.

For example, you create the discount "Spend at least $100 and get 25% off shipping cost" but set no redemption limits. If a customer purchases $200 worth of items, he gets a 25% discount for each $100, so a 50% discount. To limit the discount to 25%, set an order redemption limit of 1.
Spend for Discount on Shipping Cost

Spend at least X amount and receive a discount off selected shipping methods.

The view has three sections:

- **Spend at least...** Enter a minimum order amount needed to qualify for the shipping discount. This section displays all currencies for the campaign's target market. Enter a minimum qualifying
amount for each eligible currency. If no amount is entered, the discount is not available in that currency.

» **Get selected shipping methods**... Select shipping methods eligible for a discount. This section displays all shipping methods for a campaign's target market.

» **At the following discount**. Choose how to calculate the discount.

» **Percentage off**. Enter the discount as a percentage of the items' cost.

» **Amount off**. Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

The list of currencies is determined by the campaign's target market.

**Buy products for discount on shipping cost**

Buy a minimum number of items to get a reduction in shipping cost. For example, buy at least 3 shirts and get 25% off shipping. You determine which shipping methods are eligible, and whether the price reduction is an amount or a percentage.

With this discount, you typically set a redemption limit of 1 per order. See **Applying redemption limits**.

For example, you create the discount "Buy at least three items and get 25% off shipping cost" but set no redemption limits. If a customer purchases six items, he gets a 25% discount for each three items, so a 50% discount. To limit the discount to 25%, set a redemption limit of 1.
Buy Products for Discount on Shipping Cost

Buy at least X items from categories/entries and receive a discount off selected shipping methods.

Buy at least...

X Items

From these entries

You can add these content types

All

No items

Drag and drop items here, or Browse...

Include subcategories

Get selected shipping methods...

- Default Shipping
- In Store Pickup
- Online Download

At the following discount

- Percentage off

- Amount off

The view has three sections:

- **Buy at least X items...** Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.

- **Get selected shipping methods...** Select shipping methods eligible for a discount. This section displays all shipping methods for a campaign's target market.

- **At the following discount.** Choose how to calculate the discount.

  - **Percentage off.** Enter the discount as a percentage of the items' cost.
  
  - **Amount off.** Enter a discount amount for each eligible currency. The discount is only available for currencies with amounts.

The list of currencies is determined by the campaign's target market.
Buy products for free shipping

Buy a minimum number of items to get free shipping. For example, buy at least 3 ties and get free shipping. You determine which shipping methods are eligible.

Buy Products for Free Shipping

Buy at least X items from categories/entries and receive free shipping for selected shipping methods.

The view has two sections:

- **Buy at least X items...** Enter the number of items then the categories, products, and so on from which customers may pick. See also Selecting discount-eligible items.
- **Get selected shipping methods...** Select the shipping methods that will be free with this discount. This section displays all shipping methods for a campaign's target market.

Spend for free shipping

Spend a minimum amount of money to get free shipping. For example, spend €100 and get free shipping. You determine which shipping methods are eligible.
Spend for Free Shipping

Spend at least X amount and get free shipping for selected shipping methods.

The view has two sections:

- **Spend at least...** Enter a minimum order amount needed to qualify for free shipping. This section displays all currencies for the campaign's target market. Enter a minimum qualifying amount for each eligible currency. If no amount is entered, the discount is not available in that currency.

- **Get selected shipping methods...** Select the shipping methods that will be free with this discount. This section displays all shipping methods for a campaign's target market.
Prioritizing discounts

Marketers often run multiple campaigns and discounts in parallel, with possible overlaps. The **Discount Priority** view lets you prioritize discounts, so you can determine the sequence in which active ones are applied. The view displays discounts in priority order (highest one at top), and includes all statuses (active, inactive, scheduled, and expired).

![Discount Priorities](image)

**Adjusting discount priorities**

From the Campaign view, click **Discount Priorities and Exclusions** in the top right ( ).

To prioritize discounts, use the context menu or drag and drop them within the list. Click **Save** when done.

**How prioritization works**

- Only active discounts are applied.
- If multiple discounts apply to a product, the top active discount is applied first, followed by lower ones.

Assumption: Product’s original cost is $100.

**Example 1: Two discount percentages**

- First discount: percentage 20%
- First discount amount: $20
- Adjusted price: $80
- Second discount: percentage 30% (of $80)
- Second discount amount: $24
- Final adjusted price: $56

**Example 2: Two discount amounts**

- First discount: amount $20
- Adjusted price: $80
Example 3: One percentage, one amount
- First discount: percentage 20%
- Adjusted price: $80
- Second discount: amount $30
- Final adjusted price: $50

Example 4: One amount, one percentage
- First discount: amount $30
- Adjusted price: $70
- Second discount: percentage 20%
- Second discount amount: $14
- Final adjusted price: $56

Discount exclusions
To any discount, you can apply exclusions: campaigns or discounts that cannot be combined with the current discount. You can apply an exclusion to individual discounts, all discounts in one more campaigns, or all other discounts.

For example, you are running a sale where automotive supplies are 20% off. Customers should not be able to combine this discount with the Get cheapest item free discount. To create this exclusion, follow these steps.

1. From Campaign view, click Discount Priorities and Exclusions in the top right ( ).
2. Select the discount to which you will apply exclusions. To continue the above example, select automotive supplies 20% off.
3. Click Add to the right of the Cannot be combined with field.
4. Select campaigns or discounts that cannot be combined with the one selected in step 2. To continue the above example, select the Get cheapest item free discount.

5. Click Save then Close.

Additional notes about exclusions

- You can apply an unlimited number of exclusions to a discount.
- If you select a campaign, you exclude all of its discounts, both current and future.
- The Cannot combine with field
  - After you select an exclusion, it appears in the Cannot combine with field for reference and possible removal.
  - The Cannot combine with field displays campaigns first, followed by discounts.
  - If you select All (the campaign root folder), only that tag appears in the Cannot combine with field.
  - Similarly, if you exclude a discount then later exclude its parent campaign, the discount’s tag is removed from the Cannot combine with field. This is because the parent campaign includes the child discount.
  - If more than two items are excluded, an ellipsis in the Cannot combine with field indicates additional entries. To view all exclusions for that discount, click Add or hover over the ellipsis.
The marketing system provides a new Campaigns user interface, in addition to the legacy campaign system, for managing campaigns and discounts.

A campaign is the first step in deploying targeted marketing efforts on your e-commerce website, and provides a way to organize marketing activities.

- Discounts (promotions) must be associated with campaigns.
- You also can connect a campaign to customer segments for targeted marketing purposes. For example, you can create a seasonal campaign of promotions targeted for the Spring season.
- You can restrict a campaign and promotions to specific markets to serve local needs without discounting a product world-wide.

**Browsing campaigns (Legacy)**

In Commerce Manager, go to Marketing > Campaigns, and open the Campaign List to see existing campaigns.

Select a campaign to view its properties.
Managing campaigns (Legacy)

This section describes how to work with campaigns from Commerce Manager.

1. Click New Campaign on the Campaign List page, or select a campaign from the list. The Campaign Edit page appears.
2. Fill out the **Campaign Edit** page.
» **Campaign Name.** Enter a name such as *Graduation Special.*

» **Comments.** Enter notes about the Campaign.

» **Available From.** Enter a date directly (or click on the Calendar icon to select a date) and time that indicates when you want the Campaign to start.

» **Expires On.** Enter a date and time in the field that indicates when you want the Campaign to end.
Target Segments. Select segments from the list. Segments are created under the Customer segments section.

Target Markets. Select markets from the list. Markets are defined in the Defining markets section.

Active. Click Yes to activate the campaign; otherwise No.

Archive. Click Yes to archive the campaign; otherwise No.

3. Click OK.

Deleting a campaign

In the Campaign list, check the box next to the name of one or more campaigns and then click More Actions > Delete Selected. Click OK to confirm.

Commerce Promotions (Legacy)

The marketing system provides a new Campaigns user interface, in addition to the legacy campaign system, for managing campaigns and discounts.

A promotion applies discounts to products, order totals, or shipping, and is a marketing tool to increase sales of certain products or product lines. You can employ incentives such as lowered pricing and other discounts as part of a promotion.

A promotion is connected to one or more campaigns, which means that you need to create a campaign before you can create a promotion.

You can create a promotion that is visible prior to checkout or during the checkout.

You can apply conditions to promotions using expressions, such as the number of items, the percentage discount, shipping rates, and many others.

You can apply built-in types of promotions to individual catalog entries, orders, and shipping:

- Entry level promotions
- Order level promotions
- Shipping level promotions

You can build your own custom promotions.
Browsing promotions (Legacy)

To open the Promotion List page and browse promotions, click Promotions.

Select the name of a promotion to view its properties.
Creating an entry-level promotion (Legacy)

Episerver provides the following catalog entry promotion types, which are available in the Promotion Type field when you create a promotion:

- **Catalog Entry: Build Your Own Discount**
- **Catalog Entry: Buy Catalog entry X, get catalog entry Y at a discount**
- **Catalog Entry: Buy X Get $ Off Discount**

The following examples show how to create each type of promotion.

**Example: Build your own discount - "40% off wine decanter"**

1. Click **Promotions**. The **Promotions List** page appears.
2. Select a promotion name to open its properties.
3. Fill out the promotion identification properties.
Promotion Type. Select Build Your Own Discount from the drop-down menu.

Promotion Name. Enter a name such as 40% Off Wine Decanter.

Display Name. Enter a display name for each language type you use.

4. Fill out the promotion properties.

Campaign. Select an existing campaign created earlier.

Target Markets. Displays the associated markets for which the campaign is available.

Promotion Group. Automatically specified by the promotion type.

Combination with other promotions. Select from the following options:

  » Combine with other Promotions. The selected promotion is combined with other promotion types that may be in use.
Exclusive within Selected Groups. If the selected promotion is applied, no other promotions within that group are applied (but other promotions in other groups may be applied).

Exclusive within all Groups. If the selected promotion is applied, no other promotions are applied.

Priority. Enter the priority number (higher priority values are evaluated first).

Coupon Code. Optionally enter a code that a customer can redeem from the front-end public site to get receive a discount.

Status. Select from the following options:

- Active. Enable the promotion.
- Inactive. Disable the promotion.
- Suspended. Pause the promotion.
- Deleted. Delete the promotion.

5. Set your own Purchase Condition to receive the discount Rewards. For example, to apply a 40% discount for a wine decanter, use the settings in the following image.

**Purchase Condition and Reward:**

This type of promotion allows you to create your own custom promotion.

Use the condition below to restrict how the promotion will be applied.

**Purchase Condition:**

\[
\text{And} \quad \text{TargetLineItem.CatalogEntryId Equals (Text) F00146}
\]

Use the actions below to assign rewards.

**Rewards:**

\[
\text{And} \quad \text{get % off item reward 40.00%}
\]

6. Fill out the redemption limits:

Redemption Limits:

<table>
<thead>
<tr>
<th>Max. Total Redemptions:</th>
<th>500 (Re Redeemed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max. Redemptions Per Order:</td>
<td>1</td>
</tr>
<tr>
<td>number of times the promotion can be used by all customers, enter 0 for unlimited</td>
<td></td>
</tr>
<tr>
<td>Max. Redemptions Per Customer:</td>
<td>1</td>
</tr>
<tr>
<td>number of times the promotion can be used by a single customer, enter 0 for unlimited</td>
<td></td>
</tr>
</tbody>
</table>

© Episerver 2016
Max. Total Redemption. Enter in the maximum number of times the promotion can be redeemed.

Max. Redemption Per Order. Enter in the maximum number of times the promotion can be redeemed per customer order.

Max. Redemption Per Customer. Enter in the number of times a promotion can be by a single customer.

7. Enter the date and time when the promotion is Available and when it Expires.

8. Click OK to save the promotion. The promotion appears in the Promotion List.

When you apply the promotion, the price on the front-end changes.

Example: Buy catalog entry X, get catalog entry Y at a discount

The steps to create this discount are similar to creating a custom discount. The difference is the Purchase Condition and Reward.

Select catalog entry X. Select a catalog entry.

Select catalog entry Y. Select another catalog entry.

Quantity of "X" needed to qualify for the promotion. Enter a value, such as 4, the customer must purchase 4 of Catalog Entry X as a prerequisite for the discount.

Quantity of "Y" needed to qualify for the promotion. Enter a value such as the customer must purchase 1 of Catalog Entry Y as a prerequisite for the discount.

Amount. Enter a number and select Percentage Based or Value Based from the drop-down. For example, if you enter 40 and select Percentage Based, the promotion takes off 40%; if you select Value Based, 40 currency units are taken off the total price.
Example: Buy X get $ off discount

This type of promotion gives a discount per item by purchasing the minimum quantity specified under these Purchase Conditions.

Purchase Condition and Reward:

This type of promotion gives $ off discount per item for the minimum quantity.

Minimum quantity: 2
Amount: 20 Percentage Based
Variations: Chateau Haut-Batailley [81725M] (5) more...

» Minimum quantity. Enter the quantity that the customer needs to purchase to receive the discount.

» Amount. Enter a number and select Percentage Based or Value Based from the drop-down. For example, if you enter 40 and select Percentage Based, the promotion takes off 40%; if you select Value Based, 40 currency units are taken off the total price.

» Variations. Select a variation from the drop-down menu and click add variation. Repeat this for as many variations as you want to add. Click X next to the Variation to delete it.

Creating an order-level promotion (Legacy)

An order-level promotion is a discount applied if the overall order satisfies the conditions specified by the promotion.

Episerver provides the following order-level promotion types, which are available in the Promotion Type field when you create a promotion:

» Order: Buy X, get N quantity of Y at a discount

» Order: Sub Total Volume Discount. If the order subtotal minimum is met, then the customer receives the discount.

» Build Your Own Discount. You can create a custom order-level promotion based on a range of purchase conditions and rewards (similar to creating a custom catalog entry discount).

The following examples show how to create each type of promotion.

Example: Buy X, get N quantity of Y at a discount

The following promotion lets a customer buy a designated number of items at a reduced price.
**Purchase Condition and Reward:**

*This type of promotion is eligible to buy designated number of item at a reduced price.*

- **Entry X variation:** Chateau Guiraud [80758H] (2) more... Exclude
- **Select catalog entry Y:** Domaine Sautereau [761518]
- **Max quantity Y:** 1
- **Amount:**
  - 20 Percentage Based

- **Entry X variation**. Select an entry and click **add variation**.
- **Select catalog entry Y**. Select an entry. Entries are discounted based on the Purchase Conditions.
- **Max quantity Y** for the maximum number of Y entries eligible for a discount.
- **Amount**. Enter a value and select whether the value is **Percentage Based** or **Value Based** (fixed price discount).

**Example: Order Sub Total Volume Discount**

<table>
<thead>
<tr>
<th>Purchase Condition and Reward:</th>
</tr>
</thead>
<tbody>
<tr>
<td>This type of promotion discounts the order subtotal if minimum order amount is met.</td>
</tr>
</tbody>
</table>

- **Minimum order amount**. Enter the order amount. For example, if you set it to $200, then the customer must have $200 or more in his shopping cart to qualify for the discount.
- **Amount**. Enter a value and select whether the value is **Percentage Based** or **Value Based** (fixed price discount).

**Example: Build Your Own Discount**

Like a custom **catalog entry** discount, you can create your own custom order-level discount based on a list of **Purchase Conditions** and **Rewards** as shown in the following image which shows how to create a promotion that gives 20% off for a shopping cart subtotal of $100 or more. The discount appears on the shopping cart on front-end public site.
Creating a shipping-level promotion (Legacy)

A shipping level promotion gives a discount based on the overall shipment. The discount appears on the order page just before you submit the order.

Episerver provides the following shipping-level promotion type, which is available in the Promotion Type field when you create a promotion:

**Shipping: Build Your Own Discount.** Create a custom shipping promotion based on a range of purchase conditions and rewards (similar to creating a custom catalog or order entry discount).

Example: buy N quantity get % off shipment discount
Creating a custom promotion (Legacy)

You can create a custom promotion for a catalog, order, or shipping level.

The following example builds a promotion that gives a $10 discount to customers who order products that contain Bordeaux or Sauternes in the display name.

Using the Catalog Entry: Build Your Own Discount promotion type, construct the purchase condition as follows to use either Bordeaux or Sauternes.

\[
\text{And} \ (\text{Or} \ (\text{DisplayName} = \text{Bordeaux}, \ \text{DisplayName} = \text{Sauternes}))
\]

The formula is translated by the rules engine to the following formula:

\[
\text{And} \ (\text{DisplayName} = \text{Bordeaux} \text{ Or } \text{DisplayName} = \text{Sauternes})
\]

If the Or is not added first the results are not as desired as the DisplayName would have to contain Bordeaux and Sauternes.

Set the Reward to $10.
Customer groups are useful when you set permissions, promotions, and targeted marketing campaigns. Customer groups are controlled at the campaign level by means of customer segments and not applied directly to a single promotion. Customer segments define conditions, one of which is Customer Group. If any condition is satisfied, the customer in question qualifies for the segment.

1. Go to Commerce Manager > Marketing > Customer Segments and click New Segment or edit an existing one in the list. An Overview tab appears.

2. Click New Condition or edit an existing condition.

3. Select the green plus sign to start entering criteria for the condition.
4. Click **CustomerGroup** and select a specific customer group that was previously created in Commerce Manager.

5. Click **OK**. The Customer Segment reflects the added condition (only the name is displayed for the condition). You should use a condition name indicating the customer group.
6. You can add more options to customize the selection of customers. For example, you can change **Equals** to **NotEquals** to exclude multiple customer groups when they do not match any other conditions for the segment.

7. After you define the customer segments, the **Campaign** dialog box associates a marketing campaign with one or more customer segments. Promotions created for the campaign apply only for users in the selected customer segments. In this example, only contacts with an **EffectiveCustomerGroup** matching the selected customer group are eligible for promotions in the campaign.
**Commerce**

Editing and activating promotions (Legacy)

Editing a promotion

To edit a promotion, go to Marketing > Promotions and select a promotion. The Promotion Overview page appears.
Update the information (see Creating a custom promotion (Legacy)) and click OK to save your changes.

**Activating and inactivating promotions**

After you create a promotion, you can activate it from the Promotion List view by selecting the name then selecting More Actions > Flip status (active/inactive). You can inactivate the promotion if you want to keep it and reuse it again.
Deleting a promotion

In the Promotion List list, select the check box next to the name of the promotion and select More Actions > Delete Selected. Click OK to confirm.

Creating an expression (Legacy)

An expression is a condition that lets users extend the marketing system. An expression is XML statements that create custom promotions, customer segments and policies. For example, if you want to set up a promotion to get 40% off Item X, the expression or condition includes Catalog ID for Item X and Reward of 40%.

Only advanced Episerver Commerce users with knowledge of XML should create expressions.

1. Go to Marketing > Expressions > Promotions/Segment/Policy. The Expressions List page appears.
2. Click **New Expression**. The **Expression Edit** page appears.

- **Expression Name**: Enter a name for the expression, such as `EntryCustomDiscount`.
- **Description**: Enter the reason for the expression.
- **Expression XML**: Add the XML code for the expression.
- **Category**: Select **Promotion**, **Segment**, or **Policy** to apply the expression to the respective folders.
3. Click OK. The following image shows a completed expression.

**Commerce Creating a policy (Legacy)**

A policy is a business rule about eliminating similar promotions for the same order or same product. A policy executes whenever a promotion is applied. You can configure one or more policies for each store and optionally associate them with one or more promotion groups. A policy can be local or global.

- **Local policy.** Associated with a promotion group, and applies only to those promotions in the group to which this policy is associated.
- **Global policy.** Not associated with a promotion group because it applies to all promotions. This lets a marketing manager declare rules just once for the whole site such as *Do not allow negative orders.*

*Only advanced Episerver Commerce users should create policies.*

2. Click New Policy. The Policy Edit page appears.

   - **Policy Name.** Enter a name for the policy.
   - **Status.** Enter the status of the policy.
   - **Is Local.**
     - **No.** Default. This policy is not part of a promotion group and is available for all promotions.
     - **Yes.** This policy is part of a promotion group and is applicable only for that promotion group.
   
   Status and Is Local are global, meaning they cannot be limited to a promotion group.

   - **Expression.** Select an existing policy expression.
   - **Groups.** Select the groups to which this policy applies.

3. Click OK.
The marketing system provides a new Campaigns user interface, in addition to the legacy campaign system, for managing campaigns and discounts.

A customer segment determines the target audience for promotions or campaigns. Within a campaign, a promotion is applied to whatever customer segments are associated with the same campaign.

You can define the member groups of customer segments or you can use expressions to create dynamic groups whenever you run a promotion. For example, you can have a customer segment that targets users from the Los Angeles area, then create an expression that includes the customers whose home city is Los Angeles. So when a visitor from Los Angeles registers on the site, the visitor immediately becomes part of the target customer segment.

You can create a customer segment and manually assign specific contacts to the customer segment, or you can use conditions to apply rules that automatically make selected customers become part of the customer segment.

To open the Customer Segments List page and browse customer segments, click Customer Segments.

Select the name of a customer segment to view its properties.
Creating or editing a customer segment (Legacy)

A customer segment defines a specific groups of customers to be targeted by promotions or campaigns.

1. In Commerce Manager, go to Marketing > Customer Segments.

2. Click New Segment or select an existing customer segment. The Segment Edit page appears.
3. Fill out the Segment Edit page.

   - **Segment Name.** Enter a name, such as *Los Angeles Customers.*
   - **Display Name.** Enter the name that appears to users when associating this customer segment when *Creating a Marketing Campaign.*
   - **Description.** Enter notes about the segment.
   - **Members.** Select from a list of contacts to assign to this customer segment. Select the name from the drop-down and then click **add member.** You can exclude a member by clicking **Exclude member** and then clicking **add member.**

4. Click **OK** to save the customer segment.

**Creating a customer segment with conditions**

Instead of assigning members manually to a customer segment, you can use conditions to apply rules. If a customer satisfies the conditions, then the customer is part of the customer segment.
The following example shows how to specify conditions *Company X* or *Winearts* emails as part of this customer segment.

1. Click **New Condition** on the **Segment Edit** page.
2. Enter an **Expression Name**, such as *Company X* or *Email Addresses*.
3. Set up the conditions based on the following image.

![Condition Dialog](image)

4. Click **OK** to save the conditions.

![Deleting a customer segment (Legacy)](image)

In the **Customer Segment** list, check the box next to the name of the customer segment(s) and then select **More Actions > Delete Selected**. Click **OK** to confirm.
By default Episerver Commerce provides a set of common types of reports.

- **Sales Report**: Website sales performance over a time period.
- **Shipping Report**: The shipping method, number of orders, and total shipping cost over a time period.
- **Best Sellers Report**: Products that sell most in terms of quantity and total revenue over a time period.
- **Low Stock Report**: Products that are low in inventory, reported when a product's inventory is less than its reorder minimum quantity.

You can also develop custom reports, refer to the technical documentation on Episerver World for more information.

### Managing reports

You can do the following tasks with a Commerce report:

- Generate a report by clicking Reporting and select one of the default reports available under Sales and Products: Sales Report, Shipping Report, Best Sellers Report or Low Stock Report. The report display is generated.

- Filter a report by date, time, currency, and markets by selecting Market, Currencies and set the Start Date and End Date ranges and time. You can also group the report data by Day, Month, or Year. Click Apply Filter to filter; click reload to regenerate the report after changing the filtering.
Export a report by selecting **Select a format > Export > Open or Save**. You can export to Excel or PDF.

Print a report by clicking **Print**.
You can configure and administer Episerver Commerce through general settings for the entire system, and specific settings for parts of the system, such as Catalog and Order management.

Languages supported by Commerce are added from the Episerver CMS administrative and editorial interfaces, as described in Managing multi-lingual content in the CMS Administrator User Guide.

You can do the following from the administration interface:

- Add countries, currencies, and return reasons to the e-commerce system, which is done through Dictionaries.
- Track changes and monitor system activities through the log features.
- Configure common settings such as default language, currency, and length and weight units to be used by the system.
- Customize, create and publish business objects to extend the attributes of the Customer Management system, and provide more flexibility for fields and attributes displayed and collected.
- Update the search index for the website to reflect changes to the product catalog.
- Customize the left menu by adding your own menu items.
- Define warehouses, tax categories, and meta-classes and meta fields used by the Catalog Management system.
- Define payment gateways, shipping methods and providers, and configure taxes used by the Order Management system.
- Manage Commerce-specific scheduled jobs from the Episerver CMS administration view, as described in Scheduled jobs.

You can set language, currency, units and metadata fields and classes, and many other possible configurations by selecting Administration > System Settings.
You add languages in Commerce from the Episerver CMS administrative and editorial interfaces, as described in Managing multi-lingual content in the CMS Editor User Guide.

**Commerce Dictionaries**

This topic is intended for administrators and developers with administration access rights in Episerver.

Dictionaries and dictionary values enrich data when you work with currencies, countries, customer organization, customer contact groups, return reasons, and catalog content.

You add languages in Commerce from the Episerver CMS administrative and editorial interfaces, as described in the Managing multi-lingual content in the CMS Editor User Guide.

**Commerce Adding a country to dictionaries**

This topic is intended for administrators and developers with administration access rights in Episerver.

A country helps to define a market.
1. Open Commerce Manager and go to Administration > System Settings > Dictionaries > Countries.

![Administration tree showing Dictionaries and Countries]

2. Click New Country and fill in the following displayed in the Overview tab:

![Overview tab form]

- **Overview tab**
  - **Country Name.** Enter a name of the country.
  - **Code.** Enter the country code, which you can get from the MSDN site Table of Country/Region and State/Province Names and Codes [C++] (use the ISO Short Code or ISO Long Code as long as you remain consistent).
  - **Sort Order.** Enter a number starting from 0 (the lower number is listed at the top).
  - **Visible.** Select Yes to make the country name visible on the public site; otherwise No.

- **Regions tab**
New Region Name. Enter a name, such as CA, to identify a state, province, or prefecture. Then click Add. You also can select whether the region name is Visible on the public site.

When you click Edit, you can change the Ordering of the region. Click Update to save those changes.

Adding a currency to dictionaries

This topic is intended for administrators and developers with administration access rights in Episerver.

A currency helps to define a market and for catalogs.

1. Open Commerce Manager and go to Administration > System Settings > Dictionaries > Currencies.

2. Click New Currency. The Currency Overview tab appears.
Overview tab

- **Currency Name.** Enter the name of the currency that shows on the public site and various Commerce Manager administration pages.

Rates tab

- **Add Rate.** Select to add a foreign exchange rate when you want to convert from one currency to another. The Edit Currency Rate Information dialog box appears.

  ![Edit Currency Rate Information](image)

  - **From Currency.** Displays the current currency.
  - **To Currency.** Select the currency to which you want to convert from the current currency.
  - **End of Date Rate.** Enter the end-of-day rate.
  - **Average Rate.** Enter the average rate.
  - **Currency Rate Date.** Enter a currency rate date.

3. Click **Save Changes.**
Creating a return reason

This topic is intended for administrators and developers with administration access rights in Episerver.

Return reasons add data about returns in the order management process. The built-in return reasons in Episerver Commerce are **Faulty**, **Incorrect Item**, and **Unwanted Gift**. You can add more return reasons.

1. Go to **Administration > System Settings > Dictionaries > Return Reasons**. The **Return Reasons** screen appears.
2. Click **New Return Reason**. The **Return Reason Edit** dialog appears.
   - **Return Reason**. Enter a name, such as *Changed Mind*.
   - **Sort Order**. Enter a number. The lower the value, the higher the position the return reason is on the list screen.
   - **Visible**. Select **Yes** to enable to return reason; otherwise **No**.
3. Click **OK**. The new return reason appears on the list.

Deleting a return reason

- To delete an individual return reason, click **Delete**.
- To delete multiple return reasons at one time, select the check boxes next to the return reason and select **More Actions > Delete Selected**. Click **OK** to confirm.

Logging

This topic is intended for administrators and developers with administration access rights in Episerver.
**Logs** contains the system log and application log. These logs track the activities within the Episerver Commerce system specifically. This is useful when troubleshooting, and to track events and changes in the system during a specific time period.

There is also a change log for tracking changes to content in the system. See Change Log in the Administrator User Guide for more information.

To access the logs, go to **Administration > System Settings > Logs**.

**System log**

This log tracks system-related activities within Episerver Commerce.

- Filter the logs by **Operation**, **Object Type**, or the **Created Before** date and time and click **Apply Filter**.
- Click **Export Log** to move the content of your filtered records to a csv file.
- Select **More Actions > Delete Selected** or **Delete All** to remove log items.

**Application log**

This log tracks changes made in the Catalog management system. For example, when you add a SKU to a catalog, it gets logged.
Filter the logs by Source Type, Operation, Object Type, or the Created Before date and time and click Apply Filter.
Click Export Log to move the content of your filtered records to a csv file.
Select More Actions > Delete Selected or Delete All to remove log items.

**Commerce Common settings**

This topic is intended for administrators and developers with administration access rights in Episerver.

Go to the Administration > System Settings > Common Settings to select your default language, currency, length unit, and weight unit.

You have the following options:

- **Language.** Select from the available languages as defined in the language settings.
- **Currency.** Select from the available currencies as defined in the currency settings.
- **Length units.** Select Centimeters or Inches. Length settings are used for calculating shipping costs.
- **Weight units.** Select Kilograms or Pounds. Weight settings are used for calculating shipping costs.
See Multi-language management for information about working with language settings in Episerver Commerce.

**Business foundation**

This topic is intended for administrators and developers with administration access rights in Episerver.

Business Foundation extends the attributes of the Customer and Asset Management systems to give you more flexibility with the displayed and collected fields and attributes. Business Foundation works with the metadata engine to allow no-code customization of the data mode with which you can define new objects and relations between these for the Customer Management system.

You can define the layout of customizable forms and specify the fields you want to display. You also can work with system fields. For example, you can set a standard height and width for an image that is uploaded to the Asset Management system, or create a Gift Card field in the Customer Management system to track how much money a customer has on a gift card.
Business Foundation only supports the Customer and Asset Management subsystems. The Asset Management subsystem in Commerce Manager was replaced by the Episerver Asset system.

Creating a business object

This topic is intended for administrators and developers with administration access rights in Episerver.

A business object extends customer and asset forms to track and relate types of data. You can create a new business object to support customized business scenarios. The following example shows how to create a Contract business object.

Creating a contract business object

Do the following to add a contract business object:


![New Business Object dialog](image)

**Base Info**

- **System Name.** Enter the name of the business object, after which the Friendly Name and Plural Name fields are automatically populated.
- **Friendly Name.** Alternative to the System Name.
- **Plural Name.** Plural version of the system or friendly name, such as inventories.
- **Supports Extensions.** Select the check box to extend an existing meta-class with extra properties. For example, you can extend a download class with imagedownload, which contains extra parameters such as height and width.

**Field Info**
3. **Click Save.** The details of your newly created business object appear.

### Commerce Customizing a business object

This topic is intended for administrators and developers with administration access rights in Episerver.

A good starting point to model business objects for your needs is to customizing an existing business object. Episerver Commerce includes a number of business objects that you can edit and customize.

**Editing an existing business object**

You can edit and delete many, but not all, default business objects and related fields. For example, you can edit but cannot delete the **Address** and **Organization** business objects. Business objects that you can edit and delete have an **Edit** and **Delete** icon next to them.
Editing an existing field of a business object

You can edit or delete fields that have an **Edit** and **Delete** icon next to them.

![Image of field editing interface]

You cannot edit locked fields such as **Field Name** and **Field Type** (which are grayed out) in the following image.

![Image of locked field editing interface]

Update the fields that are unlocked and click **Save** to save the changes to the business object.

**Adding fields to a business object**

This topic is intended for administrators and developers with administration access rights in Episerver.

You can customize existing Business Foundation objects to have additional data entry fields. For example, you can add fields to the built-in Commerce Manager **New Credit Card** form.

Do the following to add fields to an existing business object:

1. Click **Administration**, expand **System Settings**, and click **Business Foundation** to access the list of objects. This example uses the **CreditCard** business object.
2. Select the business object in the list to open it for editing, or click **New Field** to add a new field to the business object.

3. Fill out the **New Field** form to specify the type of data field you want created for the business object.
Business Object. Automatically populated with the business object name.

Field Name. Enter the system ID or name of the field. This name automatically populated the Friendly Name field.

Friendly Name. Automatically populated using the Field name of the business object. You can change it, but must be unique from an existing field name (special characters and spaces are permitted).

Description. Optionally enter text that appears below the data entry field.

Allow Nulls. Select the box to make this an optional field that the user fills in while editing a form. Deselect the box to make it a required field.

Add Field to. Select the Forms you want the field to render in, such as the Edit Form (to enter and submit information) or View Form (read information only).

Field Type. Select a field type from the drop-down, such as integer, URL or date.

Format. Select a format. The drop-down menu options depend on your Field Type selection.

Maximum Length. The value depends on the Field Type selection.

Unique value. Leave unselected.

4. Click Save. The new field appears on the list of fields.

5. To verify the new field, check the form associated with that new field.
Commerce Customizing a form

This topic is intended for administrators and developers with administration access rights in Episerver.

This section describes how to customize and adapt a form for your Episerver Commerce users.

Forms dictate how fields appear to the Episerver Commerce user when viewing and editing information in the system. Every field is associated with a form, and each business object is associated with one or more types of forms. Common types of forms are Edit Forms, Short Info Forms, and View Forms.
Editing a form

1. Select a Business Object and then click the Forms tab to see the list of associated forms.

2. Click Edit next to the form you want. The form customization window appears.
Editing a form’s layout

1. Click Edit Form.

![Edit Form dialog box]

1. Select a View Type (layout of the form).
   - Two Columns (1:1)
   - Two Columns (1:2)
   - Two Columns (2:1)
   - Three Column (1:1:1)

2. Enter in a pixel value for the Cell Padding (spaces between each cell).

2. Click Save.

Adding a section

A section separates groups of fields on a form with its own header and border. After you set the layout, you can add sections and fields.
1. Select **Add > Add Section** to add a new section.

   - **Title.** Enter the name of the section to display on the form (if enabled).
   - **Show border line for this section.** Select the check box to show the border around the section.
   - **Show the name of this section on the form.** Select the check box to show the Title of the section on the form.
   - **View Type.** Choose one.
     - One Column
     - Two Columns (1:1)
     - Two Columns (1:2)
     - Two Columns (2:1)
   - **Cell Padding.** Enter the number of pixels for **Cell Padding** to determine the amount of space between each cell in the section.

2. Click **Save**.

   **Editing a section**

   You can edit a section by selecting a section and click **Edit**.
Adding a field to a section

1. Highlight a section and click **Add > Edit**.

2. Select an existing associated field in the drop-down menu. The Add field dialog box appears.
Field is Read Only. Select the check box to make the field unavailable for editing. The field is grayed out on the rendered form.

Item label showing on the form.
- Hide Label. No label appears next to the text box.
- System Label. Shows the system name next text box.
- Custom Label. Enter in a custom label.

Label Width. Enter a number. (Default is 120px.)
Tab Index. Enter an index for the tab.
View Type. Select either One Column or Two Column. In the drop-down box, select the number of text box rows, up to 3.

3. Click **Save**.

Editing a field

To edit a field, select and highlight the field and click **Edit** to change your previous settings.
Re-arranging fields

You can re-arrange fields on a form using the arrow controls on menu bar. Highlight the field and then click the directional arrow you want the field to move to. In the following example, the Security Code field is moved to the right where the Customer Service Phone Number field is placed by clicking the right directional arrow. Fields are moved from cell to cell within a section.
Deleting a section or field

1. Highlight a section or field.
2. Click Remove. Click OK to confirm.

Recreating a form

You can recreating a form with a single field rather than customize a form with all fields already in place.

1. Click Recreate Form on the upper right corner of the window. A confirmation dialog box appears.
2. Click **OK** to recreate the form. After you confirm, the fields clear from the form except for the required field.

### Relating business objects

This topic is intended for administrators and developers with administration access rights in Episerver.

Business objects must be related to other business objects to connect, track and record relevant data.

You can have the following relationship types:

- **1-to-Many Relationship.** Associate (or relate) one object with multiple object-related data. For example, you can associate one organization with multiple contacts.
- **Many-to-1 Relationship.** Associate multiple object-related data with a single object. For example, you can relate multiple contacts to a single organization.
- **Many-to-Many Relationship.** Associate multiple object-related data with multiple objects. For example, you can associate different SKUs with a number of warehouses for tracking and storage.
Adding a one-to-many relationship

This topic is intended for administrators and developers with administration access rights in Episerver.

You can relate business objects with a one-to-many (1:N) relationships. For example, if you have one organization, you can relate many types of data to that organization, such as multiple contacts, addresses, or organizational units or divisions within an organization. Within a 1:N relationship, the business object you selected will be 1.

In the following example, 1 = Organization and N = Related Objects such as Address, Contact, CreditCard and so on.

To add a one-to-many relationship to a business object, you need to create a new business object or use an existing one.

1. On the Business Object Customization page, click 1:N Relations.

2. Click New Relation "one to many" to create a new relation.

3. Fill in the Relation 1:N dialog box.
» **Primary Object.** Automatically set to Organization.

» **Related Object.** Select the drop-down item to relate the Organization object.

» **Field Name.** Automatically populated using the system name of the business object, but must be unique from an existing field name. Use only letters, numbers and underscores (_); no spaces or special characters.

» **Friendly Name.** Automatically populated using the system name of the business object. You can change it, but must be unique from an existing field name (special characters and spaces are permitted).

» **Allow Nulls.** Select the box to make this an optional field that the user fills in while editing a form. Deselect the box to make it a required field.

» **Add Field To.** Select the Forms you want the field to render in, such as the Edit Form (to enter and submit information) or View Form (read information only).

» **Display Region.** Select a region in the drop-down box. Additional options, such as **Display Text** and **Display Order**, appear based on your drop-down menu selection.

4. Click **Save**.

The Related Object has the Primary Object appear under the opposite relationship (N:1) on its configuration form. For example, if Organization is the Primary Object and the Related Object is Address, the relationship is automatically generated under the **N:1 tab in Address.**
Adding a many-to-one relationship

This topic is intended for administrators and developers with administration access rights in Episerver.

You can relate business objects with a many-to-one (N:1) relationship. For example, you can relate multiple contacts to a single organization or unit.

In the following example, N = Organization and 1 = Related Objects such as ParentId, PrimaryContactId and so on.

1. To create **many-to-one relationships**, select a business object and click the **N:1 Relations** tab.

2. Click **New Relation "Many to one"** to create a new relationship.

3. Fill in the Relation N:1 dialog box. (The Relation N:1 form is very similar to the Relation 1:N form, except you can select the Primary Object from the drop-down, whereas the Related Object...
defaults to the name of the Business Object.)

**Primary Object.** Select the drop-down item to relate an the Organization object.

**Related Object.** Automatically set to Organization.

**Field Name.** Automatically populated using the system name of the business object, but must be unique from an existing field name. Use only letters, numbers and underscores (_); no spaces or special characters.

**Friendly Name.** Automatically populated using the system name of the business object. You can change it, but must be unique from an existing field name (special characters and spaces are permitted).

**Allow Nulls.** Select the box to make this an optional field that the user fills in while editing a form. Deselect the box to make it a required field.

**Add Field To.** Select the Forms you want the field to render in, such as the Edit Form (to enter and submit information) or View Form (read information only).

**Display Region.** Select a region in the drop-down box. Additional options, such as Display Text and Display Order, appear based on your drop-down menu selection.

4. Click **Save**.

*Like an 1:N relationship, if you create a N:1 relationship with a Primary and Related Object, a 1:N relationship is automatically generated for the Primary Object on the 1:N tab.*
Adding a many-to-many relationship

This topic is intended for administrators and developers with administration access rights in Episerver.

You can create a many-to-many (N:N) relationship with business objects. For example, a many-to-many relationship helps to track many SKUs and their inventory levels with many warehouse locations, or multiple contacts a part of multiple organizations. A many-to-many relationship between two objects also is called a bridge.

In the example both Organization and Organization_Contact = N.

1. To create a many-to-many relationship, select a business object and then click the N:N Relations tab.

2. Click New Relation "many to many" to create a new N:N relationship.

3. Fill in the Relation N:N dialog box.
Current Object. Defaults to the name of the Business Object you are editing.

Related Object. Select an object from the drop-down menu.

Relation Name. Automatically populated by Current Object Name_Related Object Name. You can change it, but it must be unique and you can use only letters, numbers, and underscores (_); no spaces or special characters.

Friendly Name. Enter a unique name (special characters and spaces are permitted).

Display Region. Select a region where the field appears for the Current Object (SKU) and the Related Object (SKU_Warehouse) from the drop-down menu.

Display Text. Enter the text associated with the objects.

Display Order. Enter the number associated with the objects.

4. Click Save.

A many-to-many relationship is automatically generated for the related object when you click its N:N tab on its configuration form.

Commerce Publishing business objects

This topic is intended for administrators and developers with administration access rights in Episerver.
When you publish a business object, you can do the following actions.

- Publish objects as a node in the left navigation in Commerce Manager.
- Add functionality to a specific system without modifying code.
- Set access permissions for the business object, controlling which user groups have access to use it.

For related information, see Customizing the left menu.

1. Click **Publish** on the Business Object Customization page.

2. You can set permissions by customizing **Access Permissions**. This string is auto-generated. To change it, you can copy and paste string values from other objects.
3. Click **Publish**.

Refresh your browser after you publish a business object to make it appear in the left hand navigation.

---

**Deleting business objects**

This topic is intended for administrators and developers with administration access rights in Episerver.

Go to Administration > System Settings > Business Foundation to delete any customized business object that was published.

To remove an object from the left menu, go to Administration > System Settings > Left Menu and click **Delete**.

---

**Updating a catalog search index**

This topic is intended for administrators and developers with administration access rights in Episerver.
Indexing a catalog ensures that your search results are accurate and up-to-date. You can index a catalog in the following ways:

- **Build.** Indexes items that have changed since the previous build.
- **Rebuild.** Indexes everything in a catalog, which you want when you create a new catalog or if you made structural changes to your catalog (such as moving categories or renaming products).

1. Go to **Administration > System Settings > Search Index.**

2. Click **Rebuild Index** or **Build index.** After performing either operation, you see the changes or additions reflected in your search results.

---

**Customizing the left menu**

This topic is intended for administrators and developers with administration access rights in Episerver.

You can customize the left navigation frame in Commerce Manager by adding business objects. Before you customize, see **Publishing business objects**, which describes setting permissions and publishing of business objects.

**Adding a left menu item**

To add a **Left Menu** item, you can either configure the entire menu item first within Business Foundation, or you can add an empty container by clicking **Add** and then going back to Business Foundation to fill in the page contents (objects).
A dialog box appears for publication settings.
Display Region. Select on an item in the navigation tree to display the parent node of the new left menu item.

Display Text. Defaults to the system name of the Business Object. You can rename it.

Item Link. Enter a URL to display when the new left menu item is selected.

Display Order. Defaults to 10000. You can change the value to determine the position of the node.

Access Permissions. Automatically populated (if the menu item was created in Business Foundation). See Access rights for more information about roles and Commerce functions. If you are creating a new menu item, you can leave the field blank, or copy permissions from other menu items.

Item Icon. Click Browse to upload an icon that represents the menu item.

Click Add to add the menu item under the Display Region item in the left menu.

To verify if the object was published, go to the Display Region where you specified the object to be published. Click Refresh on the left navigation frame.

To Edit a user-generated node in the left menu, click Edit.
If the left menu item was created via the **Left Menu** page, the following dialog box appears.

If the left menu item node was created using **Business Foundation**, the following dialog box appears.
To change the sort order of the left menu item, adjust the numerical value in **Display Order**. The lower the value, the higher the position of the item within the navigation tree relative to items with a higher Display Order value.

To save changes, click **OK**.

To delete a left menu item, click **X**.
Go to **Administration > Catalog System** to set up warehouses, tax categories, and catalog specific meta fields and meta-classes.

A warehouse is the physical inventory location with an address from where product items are shipped or picked up by customers. As an e-commerce manager in an organization with many fulfillment centers, you can define and manage physical store locations, multiple stock locations, stock figures for a product variant (SKU) by warehouse, and total product availability among warehouses. Depending on how you set up your warehouses, you can check in-store stock, reserve and pick up in-store, and deliver to store. When you create a product variant, you specify the warehouse where the item is being stored.

1. In Commerce Manager, go to **Administration > Catalog System > Warehouses**. The warehouse list appears.
2. Click **New Warehouse**.

3. Enter information for the **Overview** tab.

   - **Name**: Enter the name of the warehouse.
   - **Code**: Enter the location code for the warehouse.
   - **Available**: Select **Yes** to make the warehouse available; otherwise **No**.
   - **Is Primary**: Select **Yes** to make this a primary warehouse; otherwise **No**.
Is Fulfillment Center. Select Yes to make this a fulfillment center where you can place orders for outgoing shipments; otherwise No.

Is Pickup Location. Select Yes to make this a pickup location where you can place orders for in-store pickups; otherwise No.

Is Delivery Location. Select Yes to make this a delivery location that you can use for future in-store pickups; otherwise No.

4. Enter information for the Address tab.

<table>
<thead>
<tr>
<th>Overview</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name:</td>
<td>John</td>
</tr>
<tr>
<td>Last Name:</td>
<td>O´Brien</td>
</tr>
<tr>
<td>Organization:</td>
<td></td>
</tr>
<tr>
<td>Line 1:</td>
<td>Galway Street</td>
</tr>
<tr>
<td>Line 2:</td>
<td></td>
</tr>
<tr>
<td>City:</td>
<td>Dublin</td>
</tr>
<tr>
<td>State:</td>
<td></td>
</tr>
<tr>
<td>Country Code:</td>
<td>IR</td>
</tr>
<tr>
<td>Country Name:</td>
<td>Ireland</td>
</tr>
<tr>
<td>Postal Code:</td>
<td>888999</td>
</tr>
<tr>
<td>Region Code:</td>
<td>IR</td>
</tr>
<tr>
<td>Region Name:</td>
<td>Ireland</td>
</tr>
<tr>
<td>Day Phone:</td>
<td></td>
</tr>
<tr>
<td>Evening Phone:</td>
<td></td>
</tr>
<tr>
<td>Fax Number:</td>
<td></td>
</tr>
<tr>
<td>Email:</td>
<td><a href="mailto:john@mail.com">john@mail.com</a></td>
</tr>
</tbody>
</table>

5. Click OK to save your changes. The warehouse appears in the list.

Deleting a warehouse

Select the warehouse and select More Actions > Delete Selected. Click OK to confirm.
**Tax categories**

This topic is intended for administrators and developers with administration access rights in Episerver.

A tax category for a catalog works in coordination with your tax configuration setup for orders, which includes specific taxes such as state, local, and federal taxes. You can add a luxury items tax category for specific products, or VAT for different regions. See Tax configuration for information.

1. Go to Administration > Catalog System > Tax Categories. A list of existing tax categories appears.

2. Click New to create a new category. A dialog box appears. In the Tax Category Name field, enter a name and click OK to save the tax category.

**Deleting a tax category**

To delete a tax category, click the Delete icon next to the item in the Tax Categories List. To delete multiple items, select the check boxes next to items, click More Actions > Delete Selected.
Catalog meta-classes and meta-fields

This topic is intended for administrators and developers with administration access rights in Episerver.

You can extend the metadata of catalog items and order forms. For example, if you create a meta-class called *Wine*, add meta fields that are characteristic for wine, such as *color*, *taste*, *vintage*, and *maturity*.

You also can define single and multiple dictionary types of value selectors with options. This results in a drop-down selector where editors can select values for product properties, such as *fabric types* for clothing, or *genre* for media.

After you create meta-classes and meta-fields in Commerce Manager, others can use them when they work with catalog entries in the product catalog.

Creating a catalog meta class

1. Go to **Administration > Catalog System > Meta Classes**. The Meta Classes page appears.
2. Select **Create New > New Meta Class** and fill in the fields.

   > **Name.** Enter the name of the meta-class used in your code, this cannot have any spaces.
» **Friendly Name.** Enter the name of the meta-class displayed for practical use in Catalog Management.

» **Description.** Enter a description of the meta-class.

» **Object Type.** Select **Catalog Node** or **Catalog Entry**.

3. Click **OK** to save changes. The newly created meta-class appears in the **Type** drop-down menu.

If you select the meta-class, you see available meta-fields listed but with none selected.

**Creating a catalog meta field**

1. Go to **Administration > Catalog System > Meta Fields**. The Meta Fields page appears.
2. Click **New Meta Field**. The Meta Field edit page appears.

You also can select **Create New > New Meta Field** on the **Meta Classes** page.

3. Enter **Meta Fields** details.
Name. Enter a system name without spaces or special characters (such as `NumberMegapixels`).

Friendly Name. Enter a user-friendly name seen by end-users on the back and front-end (such as `Number of Megapixels`).

Description. Enter information about the meta field.

Type. The drop-down menu shows the following field types.

- datetime
- decimal
- float
- money
- Integer
- Boolean
- Date
» Email
» URL
» Short String
» Long String
» Long Html String
» String Dictionary
» File
» Image File

» Dictionary (single and multiple line dictionary type option selector)

» **Supports Multiple Languages.** Select if the meta-field can appear in two or more languages.

» **Use in comparing.** Select to be able to compare items (only works if you have compare functionality on the front-end site).

» **Allow Null Values.** Allows a null value for this field.

» **Search Properties.** Depending on the data field type selected, you may have the option to set the search properties of the data field. The options are:

» **Allow search.** Permit searching on this meta field.

» **Enable Sorting Search Results.** Enable sorting of search results on this meta field.

» **Include Values in Search Results.** Include the original value of this meta field in the search results.

» **Tokenize.** Prepare individual words (word breaking) in a long product description property.

» **Include in the Default Search.** Tokenize and combine meta field values for search from the front-end site.

4. Click **OK** to save your changes. The newly added meta fields appear in the meta fields list.

If newly created meta fields are not immediately visible, go to the next page or set the **Page Size** to display more entries.

**Applying meta fields to a meta class**

1. Go to **Administration > Catalog System > Meta Classes.** The Meta Classes page appears.
2. Select **Element > Catalog Entry.**
3. Select the desired meta class from the **Type** drop-down. The **Name**, **Friendly Name**, and **Description** fields are populated with default values.
4. Apply a meta field to a meta class by selecting the check box next to the meta field. If you want to sort the order of the meta fields in the catalog entry, enter a number into the **Sort** field.
5. Click **OK** to save your changes.

### Order system administration

This topic is intended for administrators and developers with administration access rights in Episerver.

Go to **Administration > Order System** to set up payment methods, shipping methods, providers, configure specific taxes, and order-specific meta-fields and meta-classes.
This topic is intended for administrators and developers with administration access rights in Episerver.

You need to create three components for payment in Episerver Commerce. You also can give customers several payment options and customize methods for specific markets.

Payment type. A meta class that contains the properties for a particular payment type. For example, a credit card payment type contains credit card number, card expiration date, and card type. Episerver provides the following payment types:

- Payment by phone
- Exchange payment
- Credit card payment
- Other Payment

Additional payment providers are available as modules for Episerver Commerce.
Payment gateway. Provides an interface to the system that provides payment processing. A payment type is passed to the payment gateway and the gateway executes the payment transaction with the payment system (such as PayPal). One payment type is associated with each payment gateway.

Payment method. Contains information about the way the customer views a payment option and has a payment gateway associated with it.

Setting up a payment

1. Go to Administration > Order System > Payments and select a language in the list. The Payment Methods window appears, displaying available payment methods for the selected language.

2. On the Payment Methods window, click New to create a new payment method. The Payment Method Edit screen appears.
ID. The system-assigned unique identifier for the payment gateway.

Name. Enter the name displayed to the user.

Description. Enter a description that is displayed to the user.

System Keyword. Enter a unique name for each instance of the gateway; new non-unique keywords do not save to the database. This keyword is not editable after a gateway is created.

Language. Select a language for the payment gateway.

Class Name. Name of the gateway class to be associated with the payment.

Payment Class. Name of the gateway payment to be associated with the payment.
Sort Order. Enter a number to order the payment method on the list of payment methods page.

IsActive. Select Yes to activate the payment method; otherwise No.

IsDefault. Select Yes to make this payment method the default; otherwise No.

Supports Recurring. Select Yes to support recurring payments, such as a subscription; otherwise No.

Restricted Shipping Methods.

3. On the Markets tab, select the markets where the payment method are available. You must define a market before it can be selected.
4. Click **OK** to save the **Payment Method**. The payment method appears in the list of Payment Methods.

For a payment method to appear it has to be **all** of: (1) assigned to the market, (2) assigned to a language that is valid for the market, **and** (3) assigned to a language that is valid for the site.

**Editing payment methods**

To edit an existing payment method, click **Edit**.
The ID is automatically generated. You can change the other fields (except System Keyword). Click OK to save your changes.

Deleting payment methods
To delete Payment Methods, click X and click OK to confirm.

To delete multiple payment methods at once, select each payment method you want to delete, then select More Actions > Delete. Click OK to confirm.

Using nSoftware-provided payment gateways
Episerver Commerce supports multiple payment gateways using nSoftware where an end user can set up a new payment method. The following procedure shows how to enable an nSoftware-supported gateway.
1. Create a new payment method.
2. Enter a **Name**, such as nSoftware.
3. Enter a **Description**.
4. Enter the **System Keyword** as `ICharge`.
5. Select a **Language**.
6. Select the **Class**
   ```
   Name: Mediachase.Commerce.Plugins.Payment.ICharge.IChargeGateway
   ```
7. Select **Yes** for **IsActive**.
8. Change the **Sort Order**, **IsDefault**, and **Supports Recurring** as needed.
9. Click **OK** to save changes.
10. Click the payment gateway again to go back to the **Payment Method Edit** page.
11. Click the **Parameters** tab. The **Configure IBiz E-Payment Integrator Component** appears.

![Configure IBiz E-Payment Integrator Component](image)

12. You can select from the most popular payment gateways in the **Gateway** drop-down menu. The **Configuration Parameters** change depending on the gateway you select, such as Authorize.Net.

13. Enter your credentials and other relevant information to activate the gateway and click **OK**.

---

**Commerce** **Shipping**

This topic is intended for administrators and developers with administration access rights in Episerver.

Shipping is the physical delivery of products to e-commerce customers. Just as for payments, you can set up shipping methods and providers. Episerver provides the following shipping gateways:

- **Generic Gateway** (fixed shipping rate)
- **Weight/Jurisdiction** Gateway (base price + additional fee that is calculated based on the weight and shipping location)

To create a customized shipping gateway, see the [Developer Guide for Episerver Commerce](https://www.episerver.com).

To create a shipping method, go to **Administration > Order System > Shipping**.
A shipping method manages information and rules that determine the shipping cost, and displays it on the front-end site while a customer checks out an item from a shopping cart. The shipping fee is added to the total price of the purchase.

A shipping method is mapped to a shipping provider that is visible to a back-end administrator in Commerce Manager. This allows the public site to display friendly names such as Ground Shipping to the customer and this is mapped to a provider such as UPS.

**Customizing shipping methods**

Episerver provides the following shipping methods.

- Ground Shipping
- Fixed Shipping.
1. Go to Administration > Order System > Shipping > Shipping Methods > English (United States) or any other languages. The Shipping Methods List screen appears.

2. Click Edit for either of the available methods. The Overview tab for Shipping Method Edit appears.

- **ID.** Automatically generated after saving the new shipping method.
- **Name.** Enter a name without spaces or special characters; this name is not displayed in the public site, but is for end users to manage and organize the shipping methods.
- **Friendly Name.** Enter a friendly name that can have spaces and special characters; the friendly name is the name seen by customers who are purchasing items.
- **Description.** Enter a description (optional).
- **Provider.** Select a provider, which is created in the Shipping providers screen.
  - Select **Generic Gateway** for a fixed shipping fee specified in Base Price.
  - Select **Weight/Jurisdiction Gateway** for a shipping fee that is calculated from the weight and shipping location.
- **Language.** Select a language.
- **Base Price.** Enter the base price that becomes the fixed shipping fee for the Generic Gateway option, or part of the Weight/Jurisdiction Gateway option.
3. Click the **Settings** tab to exclude countries, regions, and payments from a shipping method. To exclude a selection, highlight the items in the **Available** boxes on the left and click **Add** to move them to the **Chosen** boxes.
4. Click the **Parameters** tab to set conditions for the shipping fee. This screen appears only when you select the **Weight/Jurisdiction Gateway** in the **Provider** field in the **Overview** tab.

<table>
<thead>
<tr>
<th><strong>Jurisdiction Group</strong></th>
<th><strong>Weight</strong></th>
<th><strong>Price</strong></th>
<th><strong>Start Date</strong></th>
<th><strong>End Date</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>0 or more</td>
<td>10</td>
<td>10/8/2008 12:00 AM</td>
<td>19/8/2020 12:00 AM</td>
</tr>
</tbody>
</table>

- **Jurisdiction Group**: Select a jurisdiction group to apply the current shipping method (for example, *United States*). You can set up the options on the **Shipping Jurisdictions** and **Shipping Jurisdiction Groups** screen.
- **Weight**: Enter a numerical value for the weight. You select the units for the weight in the **Common Settings** screen.
- **Price**: Enter a price that is added to the base price (**Overview** tab) when the weight and jurisdiction group conditions are met.
- **Start Date**: Enter a start date and time for the shipping method to take effect.
- **End Date**: Enter an end date and time for the shipping method to expire.

5. Click **Add** to save the condition.
6. Click **OK** to save changes.

### Deleting shipping methods

1. Check off the box that corresponds to the shipping methods you want to delete.
2. Select **More Actions > Delete**. You also can click **X** next to the shipping method name to delete an individual method.
3. Click OK to confirm.

Commerce  Shipping providers

This topic is intended for administrators and developers with administration access rights in Episerver.

A shipping provider class interacts with a shipping service, such as USPS, UPS, or FedEx by retrieving shipping price information. A provider can present specific scenarios with one or more services, such as price by weight or ground shipping.

The Shipping Providers page manages the list of providers and types.

Customizing a shipping provider

1. Go to Administration > Order System > Shipping > Shipping Providers. Edit one of the two providers listed.
2. Edit Name and Description.
3. System Keyword (no spaces) and Classes are something that your developers need to code and provide.
4. Click OK to save changes. The revised shipping provider appears in the Shipping Providers page.

The Parameters and Packages tabs are partially implemented to let developers fully customize those features.

Deleting shipping providers

1. Go to the Shipping Providers page.
2. Select the check box that corresponds to the shipping providers you want to delete. (You can also click X to delete an individual shipping provider.)
3. Select More Actions > Delete.
4. Click OK to confirm.

---

**Commerce Configuring taxes**

This topic is intended for administrators and developers with administration access rights in Episerver.

Configure taxes so that rates are calculated and added to the total price during the checkout process. You can combine and apply multiple taxes (such as federal, state and local tax) to a purchase. Set up and maintain taxes with the following methods:

- Creating or editing each tax control manually
- Importing data with a CSV file

**Configuring taxes manually**

To set up your taxes manually, you need to work in the following areas in the Administration tab of the Admin Site—Tax Categories, Tax Jurisdiction Groups, Tax Jurisdictions, and Taxes—and the configuration pages for each of the catalog items.

1. **Create and configure Countries and Regions** (Go to Administration > System Settings > Dictionaries > Countries): In Countries section create the countries you plan to sell your products in and set the appropriate country codes. For the country codes, it is important that you use the ISO Short code provided at MSDN site Table of Language Culture Name, Codes, and ISO Values Method [C++]. Using the ISO Long code or anything else does not correctly calculate taxes during checkout.

2. **Create new Tax Categories** (Go to Administration > Catalog System): Create tax categories that are used later to associate your catalog items with the tax rates you define. For example you may create categories such as General Sales, Food, and Luxury Items depending on the tax regulations for your item types. The categories you create are selectable on the Page Details of your items (Variations/SKU Edit page) and on the Tax Edit page.
3. **Create and configure Tax Jurisdictions** (Go to Administration > Order system > Tax Configuration): Specify particular tax jurisdictions for a particular region by specifying zip codes, country codes, and so on. Tax rates are applied to whatever level of information you specify for each jurisdiction. For example, if you specify only the country code as US, customers with a US address (regardless of state, county and so on) are included in this jurisdiction.

   - **Country Code and Region Code** that you enter in the Jurisdictions Edit page must match the codes you used in step 1.

4. **Create and configure new Tax Jurisdiction Groups** (Go to Administration > Order system > Tax Configuration): You can include multiple tax jurisdictions in the new Tax Jurisdiction Groups.

5. **Create and configure Taxes** (Go to Administration > Order System > Tax Configuration): Specify tax rates and also associate the Tax Categories and Jurisdiction groups created in Steps 2 and 4.

6. **Associate Catalogs to the Tax Categories** created in Step 2 (Go to Order Management > Catalogs): Go to the Catalog Management subsystem and link specific catalog items to the appropriate tax categories from the Pricing/Inventory page within each Variation/SKU Edit page.

**Configuring taxes using CSV import**

CSV Tax Import can update tax data in bulk. Creating a CSV tax file with a specified format (see Example Scenarios) lets you complete steps 2 through 5 in one shot (above in Method 1). Step 6 of Method 1 can be done manually, but you can also use the CSV import functionality in the Catalog Management subsystem to associate catalogs to tax categories.

Import your CSV tax file into your Commerce Manager by following the steps:

1. Click the **Administration** tab in the Commerce Manager.
2. In the navigation tree, go to **Order System > Taxes Configuration > Taxes**.
3. Click **Import Taxes**.
4. Click **Add New File** and then **Browse** to select and upload your CSV tax file. The path of your chosen file appears in the field.
5. Click **Upload File** and then **Save The File**. The CSV tax file appears in the Files Available for Import section.
6. Select and highlight the CSV file and click **Start Import**. The import process begins and completes in a dialog box. You can now view your tax setup in the Commerce Manager.
7. If you want to edit the existing setup, simply repeat the steps with a modified CSV file.

**Caution:** Re-importing a CSV file only edits existing information or adds new data, but nothing is deleted. If you delete an entire row of data in the CSV file, you must manually
delete those entries in the Commerce Manager. You can delete all the tax data and perform the CSV tax import from scratch.

Sample CSV files and scenarios

Example 1: Single tax per catalog item based on a single jurisdiction

If your variable is State, then you can specify the tax rate on a state-level. For example, CA is 9% and MA is 6%. If you placed an order from California, then 9% sales tax is applied during checkout.

<table>
<thead>
<tr>
<th>Jurisdiction</th>
<th>Jurisdiction Group</th>
<th>Tax Rate</th>
<th>Tax Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>California</td>
<td>CA Tax Group</td>
<td>9%</td>
<td>General Sales</td>
</tr>
<tr>
<td>Massachusetts</td>
<td>MA Tax Group</td>
<td>6%</td>
<td>General Sales</td>
</tr>
</tbody>
</table>

See TaxCSVSample1.csv in this sample .zip file.

Example 2: Two or more taxes per catalog item based on more than one jurisdiction

If you have a luxury item that requires State and Federal tax, then you can specify tax rates on a state and federal level. For example, a luxury item purchased in CA has a 9% state tax rate and a federal tax rate of 3%. Both taxes are applied during checkout.

<table>
<thead>
<tr>
<th>Jurisdiction</th>
<th>Jurisdiction Group</th>
<th>Tax Rate</th>
<th>Tax Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>California General</td>
<td>CA GS Tax Group</td>
<td>9%</td>
<td>General Sales</td>
</tr>
<tr>
<td>Massachusetts General</td>
<td>MA GS Tax Group</td>
<td>6%</td>
<td>General Sales</td>
</tr>
<tr>
<td>California Luxury</td>
<td>CA LX Tax Group</td>
<td>9%</td>
<td>Luxury Sales</td>
</tr>
<tr>
<td>Massachusetts Luxury</td>
<td>MA LX Tax Group</td>
<td>6%</td>
<td>Luxury Sales</td>
</tr>
<tr>
<td>US Federal Luxury</td>
<td>US LX Tax Group</td>
<td>3%</td>
<td>Luxury Sales</td>
</tr>
</tbody>
</table>

See TaxCSVSample2.csv in this sample .zip file.

Example 3: Tax CSV file with tax type specified

You can specify the tax type. Episerver provides Sales Tax and Shipping Tax.

<table>
<thead>
<tr>
<th>Jurisdiction</th>
<th>Jurisdiction Group</th>
<th>Tax Rate</th>
<th>Tax Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>California</td>
<td>CA Tax Group</td>
<td>9%</td>
<td>Sales tax</td>
</tr>
<tr>
<td>Massachusetts</td>
<td>MA Tax Group</td>
<td>6%</td>
<td>Shipping Tax</td>
</tr>
</tbody>
</table>

See TaxCSVSample3.csv in this sample .zip file.
Order meta-classes and meta-fields

This topic is intended for administrators and developers with administration access rights in Episerver.

You can extend the metadata of catalog items and order forms. For example, if you create a meta-class called *Wine*, add meta-fields that are characteristic for wine, such as *color*, *taste*, *vintage*, and *maturity*.

Default order meta-fields that are used by the ordering process are built into the system and are not available from the administration interface. However, you can add your own meta-fields to extend the attributes of your orders.

### Creating an order meta-class

1. Navigate to *Administration > Order System > Meta Classes*. The *Meta Classes* page appears.
2. Select *Create New > New Meta Class* and fill in the fields.

   - **Name**: Enter the name of the meta-class used in your code, this cannot have any spaces.
   - **Friendly Name**: Enter the name of the meta-class displayed for practical use in Order Management.
   - **Description**: Enter a description of the meta-class.
Object Type. Select Order Group, Order Form, Shipment, LineItem, Order Group Address, or Order Form Payment.

3. Select OK to save changes. The newly created meta-class appears in the Type drop-down menu.

If you select the meta-class, you see available meta-fields listed but with none selected.

Creating an order meta field

1. Go to Administration > Order System > Meta Fields. The Meta Fields page appears.
2. Select New Meta Field. The Meta Field edit page appears.

You also can select Create New > New Meta Field on the Meta Classes page.

3. Enter Meta Fields details.
Name. Enter a system name without spaces or special characters (such as NumberMegapixels).

Friendly Name. Enter a user-friendly name seen by end-users on the back and front-end (such as Number of Megapixels).

Description. Enter information about the meta-field.

Type. The drop-down menu shows the following field types.

- datetime
- decimal
- float
» money
» Integer
» Boolean
» Date
» Email
» URL
» Short String
» Long String
» Long Html String
» String Dictionary
» File
» Image File
» Dictionary (single and multiple line dictionary type option selector)

» **Supports Multiple Languages.** Select if the meta-field can appear in two or more languages.

  **Use in comparing.** Select to be able to compare items (only works if you have compare functionality on the front-end site).

» **Allow Null Values.** Allows a null value for this field.

» **Search Properties.** Depending on the data field type selected, you may have the option to set the search properties of the data field. The options are:

  » **Allow search.** Select the box to permit searching on this meta-field.
  
  » **Enable Sorting Search Results.** Select the box to enable sorting of search results on this meta-field.
  
  » **Include Values in Search Results.** Select the box to include the original value of this meta-field in the search results.
  
  » **Tokenize.** Select the box to prepare individual words (word breaking) in a long product description property.
  
  » **Include in the Default Search.** Select the box to tokenize and combine meta-field values for search from the front-end site.

4. Select **OK** to save your changes. The newly added meta fields are listed in the meta-fields list.

If newly created meta-fields are not immediately visible, go to the next page or set the **Page Size** to display more entries.

### Applying meta fields to a meta-class

1. Go to **Administration > Order System > Meta Classes**. The Meta Classes page appears.

2. Select **Element > Catalog Entry**.

© Episerver 2016
3. Select the desired meta class from the **Type** drop-down. The **Name**, **Friendly Name**, and **Description** fields are populated with default values.

4. Apply a meta-field to a meta-class by selecting the check box next to the meta-field. If you want to sort the order of the meta-fields in the catalog entry, enter a number into the **Sort** field.

5. Select **OK** to save your changes.

### Commerce Scheduled jobs

This topic is intended for administrators and developers with administration access rights in Episerver.

A scheduled job performs a specific task automatically when set to a date and time. An administrator can manually execute a scheduled job at any time. See Scheduled jobs in the CMS Administrator User Guide for information about scheduled jobs in the Episerver platform.
The following Commerce-specific scheduled jobs are provided with the administration interface.

**Subscription payment plans**
Ensures that recurring payments are regularly generated as a background process. Used for payment plans, such as magazine or grocery subscriptions, generating recurring payments.

**Remove expired carts**
Abandoned carts are not converted into an order, but are stored in the system until they expire. This job removes expired carts when executed.

**Full search index**
Performs a full indexing of content in product catalogs.

**Draft store migration**
Used for migration of previously published content versions, when upgrading to the version management introduced with Commerce 9, see Episerver World for technical details.

**Shipment releasing**
Searches for releasable shipments in active orders. If the difference between current time and shipment creation time is greater than the configured time span, the shipment status for the order is changed to *Released*.

**Rotate encryption keys**
Sensitive customer data is secured with encryption keys that are set in meta fields. This job rotates the encryption keys used by the system. See Episerver World for technical details.

**Incremental search index**
Performs an incremental search indexing.
Managing content

Content on an e-commerce website is usually products from the product catalog, which are exposed through types of categorization, faceted navigation or filtering.

In Episerver Commerce, content is information entered into CMS pages and blocks, and information related to e-commerce catalog entries such as categories, products and variants. Catalog content often is based on data retrieved from external systems.

Different user groups update content. For example, merchandisers organize the product catalog, manage pricing and enrich the product information, whereas marketers and editors create campaign pages and promote products. The shopping community creates content through social features.

Catalog content

Catalog content consists of various types of catalog entries, such as categories, products, variants, packages and bundles. The Catalog view lets you:

- Create new categories and add products and variants to these in the product catalog structure. See Working with Commerce Categories.
- Browse the catalog tree to see the structure of catalog entries, and the content types on which they are based.
- Create relationships between catalog entries using drag-and-drop functionality.
- Edit catalog entries such as categories, products and variants from the On-Page Editing or the All Properties editing views.
- Add text, media such as images and videos, and links to properties in different content types such as adding a product description. See Managing content in the CMS Editor User Guide.
- Manage pricing across products, markets and customer groups, compare prices filtered by markets and customer groups, and make adjustments as needed. See Managing pricing.
- Create links to entries in the product catalog using the Link tool. You can create links to catalog content from the rich-text editor or from a link property in the content. In either case, you can select a catalog entry in the link tool dialog.
Publish changes directly on the website, or schedule it for later publishing.
Catalogs gadget

You can access the Catalogs gadget in the CMS and Commerce assets pane. Use the gadget to drag catalog entries into the rich-text editor or a content area of a CMS page or block, to display and promote product information, such as a campaign page.
You also can use the Catalogs gadget to create relation links between catalog entries by dragging catalog items into the Relations tab of other catalog entries. See Editing and publishing catalog entries.

To properly display product information when used in other types of content, the rendering templates must be adapted to display catalog content.

**Commerce-specific gadgets**

Episerver Commerce has the following e-commerce-specific gadgets which you can add to the dashboard in Episerver:

- Commerce orders gadget
- Commerce overview gadget
- Gadgets
- Gadgets
- Commerce settings for CMO gadget
Multiple language content

E-commerce businesses often exist in multiple markets that require your website to be available in several languages. You can manage catalog content in multiple languages, and also activate multiple languages for the Episerver Commerce user interface. See Multi-language management for information about working with multiple content languages.

Personalized content

The personalization feature in Episerver CMS targets content to specific visitor groups. For example, you can design campaigns based on recent orders or the total spent amount for a customer. The personalization option is available in the rich-text editor, and also is applied to available blocks on your website. See Commerce personalization criteria.

Find and best bets for catalog content

If you have Episerver Find installed on your website, you can promote content in your product catalog by adding best bets to the search results. See the Episerver Find User Guide.

Managing languages in Commerce

Usually a website has a default or master content language set up during installation. You can set up languages for catalog entry content, such as product (SKU) descriptions, for your website at the catalog level. This means that when you configure a language for a catalog, you define catalog entry descriptions in that language.

To work with multiple languages for Episerver Commerce content, first enable the languages in the CMS admin and edit views. Next, language-specific fields appear, ready for translation in edit view; product descriptions that are not yet translated appear empty if they are displayed on the front-end site.

Translating catalog content is similar to translating CMS content, such as pages and blocks. Episerver uses specific language settings for catalogs, markets, and payment and shipping methods in Commerce.

Enabling a language for catalog content

1. Activate the language in the CMS admin and edit view, as described in Multi-language management.
Enable the language in edit view to make it available for editors to translate content, and to make the website's start page available in that language, for proper display of translated content.

2. Enable the language for the catalog to which you want to apply the new language:
   a. In the Catalog edit view, open the catalog for which you want to add a language in the All properties editing view.
   b. In Available languages, select the newly-added language.
   c. Publish the catalog changes.

Translating content for catalog entries

1. In the Catalog view, select the desired catalog entry to translate in the catalog tree.
2. Click Edit in the context menu for the selected entry, or select the entry to open the All Properties editing view.
3. In the header next to Languages, select the desired language for translation. (Enabled languages are listed.)
4. Edit the available properties, and follow the content publishing flow to save and publish the translated catalog entry information.

💡 When you translate content, have the original content open in another browser window for comparison. You also can copy and paste the original content into the text area where you are working, as reference.

### Switching language and viewing language versions

When editing translated content in the All Properties editing view, you can switch languages by selecting the desired language in the **Header**. The user interface reloads, displaying the content in the selected language. See Translating content for information about switching between languages and viewing language versions for content.

### Editing global properties

Depending on your implementation, some properties may be globally shared and can only be edited in the master language. See Translating content for information about editing global properties.

### Setting the user interface language

To set the user interface language for **Catalogs** and **CMS**:

1. Select your user profile name in the upper right corner.
2. Click **My Settings** then the **Display Options** tab.
3. Select the language of your choice and click **Save**.
To set the user interface language for Commerce Manager:
1. In the upper menu of Commerce Manager, click Change Language.
2. Select the language.
3. Click OK.

**Personalization**

Episerver Commerce provides custom visitor group criteria so you can personalize content based on product and order information.

You need administration access rights to create and edit a visitor group. Existing visitor groups are available for editors in edit view.

To see available visitor groups, in the global menu, click CMS then Visitor Groups. Click Create to define a visitor group, then add the personalization criteria as desired.

**Commerce-specific criteria**

These criteria are available by default in an Episerver Commerce installation, in addition to the CMS-specific criteria. See also: Visitor groups in the CMS Administrator User Guide.

- **Customer properties.** Personalize content based on age or geographic location:
  - **Date of Birth.** Format mm/dd/yyyy.
  - **Customer group.** Select Customer, Partner, or Distributor.
  - **Registration source.** Enter the source of registration.
  - **Country.** Select a country from the list.
  - **Region code.** Select a region code based on the address region in addresses.
  - **Address postal code.** Select a postal code from the list (based on state selected).
  - **State.** Select a state from the list.

You can select only one property type with a related value for a criterion, but you can define several customer properties criteria for a visitor group.

- **Market.** Personalize content based on the market to which a visitor website belongs.
  - **Market.** Select a market. Available markets are defined under Market Management.

- **Recent Orders.** Personalize content based how often a customer orders:
  - **Order times.** Select the number of times an order is placed.
  - **Number of days.** Select the number of days over which the number of orders must occur. For example, 4 times in the last 2 days.

- **Product in cart or wish list.** Identify customers that have placed a product of a certain type or brand in their cart or wish list.

© Episerver 2016
Specified product code. Enter the desired product code.
Product from a specified category. Select the desired product category.
Product has a specified property and value. Enter the desired product property and value, such as brand and Sony.

You can select only one property type with a related value for a criterion, but you can define several add several criteria of the type Products in Cart or Wish List to a visitor group.

Recent orders. Personalize content for visitors who placed an order on the site in the last number of days.
Number of days. Select the number of days.
Total spent. Personalize content for visitors who spent a specified amount of money (in a specified currency) on the site in the last number of days.
Spent at least. Select amount and currency.
Number of days. Select the number of days.

How visitor groups are used

When creating a campaign, you can limit it to members of selected visitor groups.

Commerce Gadgets

A gadget is a small application that you can add to the assets and navigation panes, and to the Episerver dashboard. See Gadgets in the CMS Editor User Guide for information about built-in gadgets in the Episerver platform.

The Episerver Commerce sample site provides the following gadgets.

- Commerce orders gadget
- Commerce overview gadget
- Commerce settings for CMO gadget

Commerce orders gadget

Use the Commerce Orders gadget monitors sales activities for your Episerver Commerce website. The gadget displays order statistics in a sales graph and a list of purchase orders created within a selected time interval.

To add and configure the Commerce Orders gadget:

1. Log into Episerver Commerce.
2. From the right-click menu, click Dashboard.
3. Click the Dashboard tab under which you want the gadget to appear.
4. In top right corner of the dashboard, click Add Gadgets
5. Click OrderGadget. The gadget appears on the dashboard. By default, it displays new data every 30 seconds.
6. To update the refresh interval, from the gadget’s drop-down menu, click Edit and enter a new time interval.
7. Click OK.

Commerce overview gadget

Use the Commerce Overview gadget to monitor sales data from your Episerver Commerce website. Data is grouped by products, categories, orders, customers and promotions.

To add and configure the Commerce Overview gadget:

1. Log into Episerver Commerce.
2. From the right-click menu, click Dashboard.
3. Click the Dashboard tab under which you want the gadget to appear.
4. In top right corner of the dashboard, click Add Gadgets.
5. Click Overview. The gadget appears on the dashboard. By default, it displays new data every 30 seconds.
6. To update the refresh interval, from the gadget’s drop-down menu, click Edit and enter a new time interval.
7. Click OK.

Commerce settings for CMO gadget

To use this gadget, both Episerver CMO and Episerver Commerce must be installed on your website.

Measure and monitor campaigns and optimize landing pages with the Episerver Campaign Monitor and Optimization (CMO) gadget. Episerver CMO analyzes campaigns and landing pages, rather than whole sites. See also: Episerver CMO.

You also can use Episerver CMO gadget to monitor activities on an Episerver Commerce site, such as the number of views, and orders for a product or product category. The Generic KPI function in CMO supports the logging of Commerce KPI data so that external applications, such as Commerce, can send notifications using a specific application key. The number of orders is an example of a generic KPI. Application names and keys are defined in Episerver CMO, which monitors incoming notifications with specific key values, and collects and stores the data.

To set up the integration between CMO and Commerce:
1. Set up web services to be used by Episerver CMO and the corresponding URL.
2. In Episerver CMO, define external applications, application names and keys.
3. Using the Episerver Commerce Settings for CMO gadget, define product views and product orders that you want to monitor. (You need the application keys and the URL for the CMO Web Services.)
4. In Episerver CMO, create a campaign and add the generic KPI for Episerver Commerce.
5. Episerver Commerce updates the KPI value using web services. The monitoring result appears on the campaign report page in CMO, or by using the CMO KPI Summary gadget for Episerver Commerce on the site that has the Episerver CMO service installed.

Adding or editing Commerce settings for the CMO gadget

1. Log in to Episerver Commerce and click Dashboard in the right-click menu.
2. Click Add Gadgets.
3. Click the Commerce Settings for CMO gadget to add it to your dashboard.
4. Click Add to define the monitoring parameters. (Click Edit to modify the parameters.)
   - **Type.** Select one of the following:
     - **Product View.** Defines views of a product or all products under a specific category (CMS) (node).
     - **Product Order.** Defines orders for one product or all orders of products under a specific category (node).
   - **Product/Category.** Select a product or a category using the tree structure.
   - **Application Key.** Enter the application ID (defined in Episerver CMO).
   - **URL for CMO Web Service.** Enter the URL to be used by CMO for the web service (defined in Episerver CMO).
5. Click OK.
Deleting Commerce settings for the CMO gadget

1. Open the dashboard, and navigate to the Commerce settings for CMO gadget.
2. In the check box to the left, select settings that you want to delete.
3. Click Delete then OK.

Access rights

This section describes how to manage access rights for users such as editors, administrators, and marketers working both in Episerver Commerce and Episerver CMS. When a user is created, you can set desired access rights depending on whether the user will work with CMS, catalog content, Commerce Manager, or all parts.

You need administrative access rights in CMS to manage users and access rights. This description refers to a default implementation of Episerver Commerce. Your website may be configured differently, and have customized user and user group management.

Managing users and groups

You manage users and access rights to various parts of the system from the CMS admin view. For easier and safer maintenance, it is recommended to base access rights on groups rather than individual users. Provide access rights by adding a user to appropriate groups, see Managing users and user groups in the CMS Administrator User Guide.

Be aware that both (visitors registering on your public site or manually created in Commerce Manager) and system users created from the CMS admin view, are visible in the same listing in CMS admin view and Commerce Manager. By default, registered visitors belong to the "Everyone" and "Registered" groups.

Groups and access rights

In addition to the default groups described in Access rights in the CMS Administrator User Guide, Commerce adds a set of groups, which can be used to assign access rights to Commerce functions. Use the groups described below to control access rights to various parts of the system.

The CommerceAdmins, CommerceSettingsAdmins and CatalogManagers groups must be manually created in the CMS administration view before you can add users to them. Go to CMS > Admin > Set Access Rights and add the groups under Administer Groups.
Groups for controlling access to basic parts of the system

<table>
<thead>
<tr>
<th>Group</th>
<th>Provides access to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrators</td>
<td>All parts of the system, including Administration in Commerce Manager. Usually restricted to developers for implementation and maintenance.</td>
</tr>
<tr>
<td>WebAdmins</td>
<td>All parts of the editing and administration views in CMS and Commerce. All parts of Commerce Manager except Administration. Usually restricted to very few users.</td>
</tr>
<tr>
<td>WebEditors</td>
<td>All parts of the CMS edit view except Visitor Groups. Required for all users if not members of WebAdmins. Additional editing access rights in the CMS page tree is required for CMS content editors (see below).</td>
</tr>
<tr>
<td>CatalogManagers</td>
<td>The Catalogs user interface.</td>
</tr>
<tr>
<td>CommerceSettingsAdmins</td>
<td>The Settings option for adding dictionary property values for Commerce content.</td>
</tr>
<tr>
<td>CommerceAdmins</td>
<td>All parts of Commerce Manager except Administration, but not the admin view in CMS.</td>
</tr>
</tbody>
</table>

Groups for providing specific access in Commerce Manager

You can use these groups for providing specific access to functionality in Commerce Manager.

<table>
<thead>
<tr>
<th>Group</th>
<th>Provides access to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Management Users</td>
<td>All parts of Commerce Manager except Administration.</td>
</tr>
<tr>
<td>Order Supervisor</td>
<td>Full administration of the order management procedure.</td>
</tr>
<tr>
<td>Order Managers</td>
<td>Creating returns and exchanges, viewing and editing orders, sending notifications, processing payments and split shipments.</td>
</tr>
<tr>
<td>Receiving Manager</td>
<td>Viewing shipments and receiving returns.</td>
</tr>
<tr>
<td>Shipping Manager</td>
<td>Viewing, packing, and completing shipments.</td>
</tr>
</tbody>
</table>

In addition to these pre-defined groups, you can also use permissions for functions to set up customized access rights to functions in Commerce Manager. See below for more information.
**Controlling user access for Commerce functions**

You can manage access to Commerce functions on a very detailed level. A standard installation of Episerver Commerce has a set of predefined commerce-specific roles. By assigning these roles to users or user groups, you provide them with access rights to perform tasks such as *editing orders or deleting catalogs*.

In the CMS admin view, go to **Config > Security > Permissions for Functions**, select a function and assign users or groups as desired.

See Permission for functions the CMS Administrator User Guide for information.

**Controlling access to the content structure**

The **WebEditors** group provides access to the editing view only, so you also must grant editing access in the content structure to users who edit content in CMS. You can do this by creating "structure groups". For example, you can create a **Site_Editors** group with editing permission in the entire tree structure, and **Product_Editors** or **News_Editors** groups with limited editing access to selected parts
of the tree. Define access rights for the groups in the page tree, and then add users to the groups as appropriate.

See access rights the CMS Administrator User Guide for information about working with access rights in Episerver.

EXAMPLE: Creating a user with access rights in CMS and Commerce

In this example, we create a user who works with enrichment of product information and landing pages in CMS, catalog content in Commerce, and all parts of Commerce Manager.

1. In the CMS admin view, go to Access Rights > Create User.
2. Enter the user information, select Active, and add the user to the desired groups. In this example, WebEditors is needed to access the editing views, and CommerceAdmins is needed for access to Commerce Manager. Site_Editors is a structure group which provides editing access to all parts of the page tree structure on this website.
3. Click **Save**.
4. Log in as the user to verify that proper access rights are applied.
# Index

## A
- access rights
  - commerce ............. 294
- administrators
  - role ................. 30, 140
- all properties, editing ... 25
- assets
  - as catalog entries ... 70

## B
- built-in discounts ........ 159
- bundles
  - commerce ............ 74
  - defined 58
  - deleting 77
- business categories
  - creating ............. 126
  - deleting ............. 126
  - editing ............. 126
- business foundation ... 223
- business objects
  - adding fields ........ 226
  - creating ............ 224
  - customizing ........ 225
  - deleting ............ 245

## C
- forms
  - customizing 229
  - editing 230
  - recreating 236
  - publishing ........... 243
  - relationship
    - many to many 242
    - many to one 240
    - one to many 238
- catalogs
  - batch update ........ 64
  - browsing ............ 48
  - categories
    - editing 54
  - content
    - enabling
      - languages 287
    - languages, enabling
      - user
      - interface 289
    - translating 288
- campaigns
  - creating ............. 148
  - deleting ............. 151
  - editing ............. 190
  - introduction ........ 146
- campaigns(legacy)
  - overview ............ 186
- carts
  - expired, remove, job 281
- catalog entries
  - assets ............... 70
  - detaching ........... 56
  - linking ............. 55
  - moving ............. 60
  - related entries ...... 71
  - viewing ............. 54

## D
- deleting ............. 52
- entry properties .... 66
- exporting existing
  - data ............... 35
- importing
  - CSV files 37
- importing existing
  - data ............... 35
- meta class
  - creating 255
meta classes ........ 34
meta field
  creating 256
overview .......... 34
properties ........ 66
searching .......... 50
structure .......... 34
updating search
  index ........ 245
variants .......... 59
categories
  editing .......... 54
categorizing
  products .......... 52
CMO gadget
  commerce settings . 292
commerce
  access rights .... 294
  best sellers report ... 213
  bundles ............ 74
    defined 58
    deleting 77
contacts .......... 126
  browsing 126
content
  overview 283
  types 283
exchanges ........ 107
gadgets
  overview 291
languages
  enabling 287
  translating 288
  user interface, enabling 289
low stock report .... 213
markets ............ 142
orders
  gadget 291
overview
  gadget 292
packages .......... 74
  deleting 77
payment plans .... 93, 96
payments
  methods
    deleting 265
    editing 264
overview 260
personalization .... 290
customer properties
  criteria 290
market criteria 290
order frequency criteria 290
product in cart
criteria 290
recent orders
  criteria 291
total spent
  criteria 291
picklists .......... 99
pricing .......... 77
  adding 79
  by customer group 80
reporting .......... 213
returns .... 101, 107
sales report .......... 213
scheduled jobs .... 280
shipments
  completing 101
  splitting 91
shipping .......... 98
report 213
shipping methods
customizing 268
  deleting 271
overview 268
shipping providers
customizing 272
deleting 272
overview 272
shopping carts ...... 104
taxes
  configuring 273
configuring manually 273
configuring via CSV import 274
community member role 29, 139
contacts
browsing 126
creating 133
customizing views 128
dictionary values 137
editing 137
overview 126
printing list 132
searching 128
content
commerce
overview 283
editor role 29, 140
countries
adding 216
CRM
overview 114
currencies 218
adding 218
customer groups
pricing by 80
customer segments
browsing 209
creating 210
creating with conditions 211
overview 209
dictionary values
organizations 124
discounts
built-in 159
creating 152
exclusions 184
introduction 151
prevent combination with other discounts 184
prioritizing 183
promotion codes 157
redemption limits 158
gadgets
CMO commerce settings 292
customer commerce orders 291
overview 291
customer commerce overview 292
global menu 20
inventory
variants 73
left menu
customizing 246
length
units, determining 222
login 20
marketer role 29, 140
marketing
overview 146
markets
browsing 142
creating 143
defining 142
overview 142
menu, global 20

© Episerver 2016
<table>
<thead>
<tr>
<th>Index Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>merchandiser role</td>
<td>29, 140</td>
</tr>
<tr>
<td>meta classes</td>
<td></td>
</tr>
<tr>
<td>catalogs</td>
<td>34, 81</td>
</tr>
<tr>
<td>creating</td>
<td>276</td>
</tr>
<tr>
<td>creating for catalog</td>
<td></td>
</tr>
<tr>
<td>items</td>
<td>255</td>
</tr>
<tr>
<td>ordering</td>
<td>276</td>
</tr>
<tr>
<td>meta fields</td>
<td></td>
</tr>
<tr>
<td>applying to meta class</td>
<td>279</td>
</tr>
<tr>
<td>creating</td>
<td>277</td>
</tr>
<tr>
<td>creating for catalog</td>
<td></td>
</tr>
<tr>
<td>items</td>
<td>256</td>
</tr>
<tr>
<td>on-page editing</td>
<td>25</td>
</tr>
<tr>
<td>order system</td>
<td>259</td>
</tr>
<tr>
<td>orders</td>
<td></td>
</tr>
<tr>
<td>browsing</td>
<td>81</td>
</tr>
<tr>
<td>canceling</td>
<td>97</td>
</tr>
<tr>
<td>commerce, overview</td>
<td>81</td>
</tr>
<tr>
<td>creating</td>
<td>83</td>
</tr>
<tr>
<td>from order list</td>
<td>84</td>
</tr>
<tr>
<td>deleting</td>
<td>98</td>
</tr>
<tr>
<td>editing</td>
<td>97</td>
</tr>
<tr>
<td>searching</td>
<td>83</td>
</tr>
<tr>
<td>organizations</td>
<td></td>
</tr>
<tr>
<td>browsing</td>
<td>115</td>
</tr>
<tr>
<td>creating</td>
<td>120</td>
</tr>
<tr>
<td>customizing views</td>
<td>116</td>
</tr>
<tr>
<td>dictionary values</td>
<td>124</td>
</tr>
<tr>
<td>editing</td>
<td>123</td>
</tr>
<tr>
<td>overview</td>
<td>115</td>
</tr>
<tr>
<td>printing list</td>
<td>120</td>
</tr>
<tr>
<td>searching</td>
<td>116</td>
</tr>
<tr>
<td>P</td>
<td></td>
</tr>
<tr>
<td>packages</td>
<td></td>
</tr>
<tr>
<td>commerce</td>
<td>74</td>
</tr>
<tr>
<td>deleting</td>
<td>77</td>
</tr>
<tr>
<td>packing slips</td>
<td></td>
</tr>
<tr>
<td>printing</td>
<td>103</td>
</tr>
<tr>
<td>panes</td>
<td>24</td>
</tr>
<tr>
<td>settings</td>
<td>24</td>
</tr>
<tr>
<td>payment plans</td>
<td></td>
</tr>
<tr>
<td>canceling</td>
<td>96</td>
</tr>
<tr>
<td>creating</td>
<td>93</td>
</tr>
<tr>
<td>editing</td>
<td>96</td>
</tr>
<tr>
<td>recurring</td>
<td>96</td>
</tr>
<tr>
<td>payments</td>
<td></td>
</tr>
<tr>
<td>methods</td>
<td></td>
</tr>
<tr>
<td>deleting</td>
<td>265</td>
</tr>
<tr>
<td>editing</td>
<td>264</td>
</tr>
<tr>
<td>overview</td>
<td>260</td>
</tr>
<tr>
<td>personalization</td>
<td></td>
</tr>
<tr>
<td>commerce</td>
<td>290</td>
</tr>
<tr>
<td>customer properties</td>
<td></td>
</tr>
<tr>
<td>criteria</td>
<td>290</td>
</tr>
<tr>
<td>market criteria</td>
<td>290</td>
</tr>
<tr>
<td>order frequency criteria</td>
<td>290</td>
</tr>
<tr>
<td>product in cart</td>
<td></td>
</tr>
<tr>
<td>criteria</td>
<td>290</td>
</tr>
<tr>
<td>recent orders</td>
<td></td>
</tr>
<tr>
<td>criteria</td>
<td>291</td>
</tr>
<tr>
<td>total spent</td>
<td></td>
</tr>
<tr>
<td>criteria</td>
<td>291</td>
</tr>
<tr>
<td>picklists</td>
<td>99</td>
</tr>
<tr>
<td>deleting</td>
<td>104</td>
</tr>
<tr>
<td>printing</td>
<td>103</td>
</tr>
<tr>
<td>removing items</td>
<td>104</td>
</tr>
<tr>
<td>pricing</td>
<td></td>
</tr>
<tr>
<td>commerce</td>
<td>77, 79</td>
</tr>
<tr>
<td>by customer group</td>
<td>80</td>
</tr>
<tr>
<td>viewing</td>
<td>73</td>
</tr>
<tr>
<td>prioritizing discounts</td>
<td>183</td>
</tr>
<tr>
<td>product order</td>
<td>83</td>
</tr>
<tr>
<td>products</td>
<td></td>
</tr>
<tr>
<td>categorization</td>
<td>52</td>
</tr>
<tr>
<td>deleting</td>
<td>65</td>
</tr>
<tr>
<td>promotion codes</td>
<td>157</td>
</tr>
<tr>
<td>promotions</td>
<td></td>
</tr>
<tr>
<td>activating</td>
<td>204</td>
</tr>
<tr>
<td>deactivating</td>
<td>204</td>
</tr>
<tr>
<td>deleting</td>
<td>205</td>
</tr>
<tr>
<td>promotions(legacy)</td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>190</td>
</tr>
<tr>
<td>R</td>
<td></td>
</tr>
<tr>
<td>receiving</td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>98</td>
</tr>
</tbody>
</table>
redemption limits, for discounts ........ 158
related entries
catalog entries ........ 71
remove expired carts job ............ 281
returns
commerce ........... 107
reasons ........... 220
roles .................. 28, 139
administrator ........ 30, 140
community member ........ 29, 139
content editor ........ 29, 140
developer ........ 30, 141
marketer ........ 29, 140
merchandiser ........ 29, 140
visitor ........ 29, 139
website owner ........ 30, 140
rotate encryption keys job ............ 281
shipping methods
customizing ........ 268
deleting ............. 271
overview ............ 268
shipping providers
customizing ........ 272
deleting ............. 272
overview ............ 272
shopping carts
converting to purchase order .... 105
creating ............ 105
overview ............ 104
T
tax categories
deleting ............. 254
overview ............ 254
taxes
configuring ........ 273
CSV import 274
manually 273
touch screen, prioritizing mouse input from .......... 28
U
user interface
language, changing for commerce 289
users
commerce, con- 296
V
variants
adding ............ 69
catalog, creating ... 59
deleting ........... 65
editing ........... 69
inventory ........... 73
pricing ........... 73
video
Creating a campaign and discount, 148, 153
visitor role ........ 29, 139
W
warehouses
deleting ........... 253
overview ........... 251
websites
owner role ........ 30, 140
width
units, determining ... 222