
Ektron CMS User Guide



Ektron CMS User Guide
Ektron, Inc.

542 Amherst St.

Nashua, NH 03063

Tel: +1 603-594-0249

Fax: +1 603-594-0258

Email: sales@ektron.com

http://www.ektron.com

© 2014 Ektron, Inc. All rights reserved. 

Trademarks—Ektron, the Ektron logo and eIntranet, are trademarks of Ektron Inc.

Other company and product namesmay be trademarks of their respective owners.

http://www.ektron.com/


Table of Contents

Ektron CMS User Guide 5
Workarea Quick Reference 5
Content Quick Reference 6
Content Types 6
Content Properties 7
Content Statuses 7
Other Content Information 8

Creating New Content 9
Editing in Ektron 10
Applying Styles 11
Removing Styling from Text 12

Working with Links 12
Viewing a Link 12
Inserting a Link to Text 13
Inserting a Link to an Image 13
Editing a Link 14
Removing a Link 14
Adding a Bookmark 14

Working with Tables 15
Inserting a Table 15
Applying Table Properties 16
Adding a Table Caption 16
Modifying Rows and Columns 17
Modifying a Table Style 18
Moving a Table 19
Deleting a Table 19

Working with Images 20
Inserting an Image using Drag and Drop 20
Inserting an Image Using the Library 20
Editing Images 21
Adjusting Image Size 23

Deleting an Image 24
Viewing and Editing HTML Source Content 24
Embedding External Content 25
Embedding a Google Map 28
Embedding a Vimeo Video 29
Removing External Content 29

Ektron CMS User Guide 3



(This page intentionally blank.)



Ektron CMS User Guide
This document describes essential operations for editing content through the
Workarea. For complete information about the Ektron product, see the Ektron
Reference.

Workarea Quick Reference

l 1—Workarea Tabs
o Desktop—Smart personalization desktop.
o Content—Folders, contents, DMS, taxonomies, collections, and menus.
o Library—Content folder structure that organizes images, files , hyperlinks and
quicklinks.

o Settings—Manage CMS settings based upon permissions.
o Reports—Content reports and site analytics.
o Help—Access to this document.

l Content Tab Types
o 2—Folder Tab—View folder architect structure of CMS.
o 3—Taxonomy Tab—View Taxonomy Structure and options.
o 4—Collections Tab—View Collections and options.
o 5—Menu Tab—View Menus and options.

l Folder Types
o 6—Content Folder—View contents in the selected folder.
o 7—Blog Folder—View the posts and comments on this blog.
o 8—Forum Folder—View the discussion forums, categories, topics, and replies.
o 9—eCommerce Folder—View the eCommerce items.
o 10—Calendar Folder—View and plan events on the calendar.
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o 11—Community Folder—Folders for membership uses to edit content, select to
view contents.

l Drop-down Menus
o 12—New menu—Create new content, forms documents, Folders menus and 
collections.

o 13—View menu—View Language, Properties and archived content and more.
o 14—Delete menu—Delete multiple items. Administrators can delete folders.
o 15—Action menu—Export for translation, search, move/copy content, eSync.
o 16—DMS/ Add asset—Pop up the window for drag and drop documents from local
machine.

o 17—In Context Help—Context help.
o 18—Content Organization Bar—Sort content by the title.

l Content Types
o 19—Content Items—HTML Content, Forms, DMS, or Multimedia Content.
o 20—Quick Edit Menu—For content editing, properties and content eSync.
o 21—Language Flag—Indicate the content language version.
o 22—Content ID—Automatically generated by system.
o 23—Content Status—Current status of a piece of content. 

n (A) Approved, Published and on the website.
n (O) Checked Out Only, available for editing by the content editor who checked
it out.

n (I) Checked In, Available for editing. 
n (S) Submitted,  Currently in the approval chain. Waiting for acceptance.
n (M) Deletion,  Marked for deletion.
n (T) Awaiting Tasks,  Currently awaiting completion of tasks.
n (P) Pending,  Awaiting scheduled start date.
n (D) Pending Deletion,  Pending deletion but created with a future start date.

o 24—Date Modified—Last modified date of the content.
o 25—Last Editor—Person who made the last modification.

Content Quick Reference
Types of content are described in this section. A website has pages with 1 or more
blocks of content.

Content Types
l HTML content—Content to be published on the World Wide Web.
l XML Smart Forms—Online forms, polls, or surveys to collect information from site
visitors and save it in XML format.

l HTML form/survey—Online forms, polls, or surveys to collect information from site
visitors and save it in HTML format.

l DMS Documents—Office documents, managed files, and multimedia files.
l Office documents—Microsoft Office files.

Content Quick Reference
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l Managed files—Files created outside of Ektron, such as PDF files. You cannot create
or edit these files within Ektron—you can only store them.

l Multimedia—Files that run in a media player, such as audio and movie files.
l Blogs—A form of online information sharing for a group of people to share their
thoughts.

l Web Calendars—Keeps visitors informed about upcoming events, displayed to all
visitors to your website, and any authorized user can add events to a calendar.

l Discussion Boards—Allows topic discussions on your website. A site or membership
user with Add Topic permission creates a topic and posts a starter question. Site visitors
can then reply.

l Content Imported from SharePoint®—After an Ektron administrator sets up DxH to
map SharePoint to Ektron, an end user only needs to place content in a SharePoint
folder to update their Ektron-powered website; the content is automatically transferred
to the Ektron Workarea. You also can manually import SharePoint content from the
Ektron Workarea.

Content Properties
l Content Title—The title assigned to the content.
l Content ID—The ID number assigned to the content to retrieve content from a
database.

l Content Language—The language in which the content is written.
l Status—The current status of the content.
l Last User to Edit—The last user to edit the content.
l Last Edit Date—When the content was last edited.
l Start Date—When the content appears on the website.
l End Date—When the content is removed from the website.
l Action on End Date—What happens to the content when its end date and time occurs.
l Date Created—The date on which the content was created.
l Approval Method—Which approvers must sign off on content before it is published.
l Approvals—Users in the approval chain for this content.
l Smart Form Configuration—The Smart Form applied to the content (managed by the
administrator).

l Template—The template currently assigned to the content (managed by the
administrator).

l Path—The folder path to the content’s folder. A slash (\) represents the Content folder.
l Ranking—If this feature is enabled for the content, the average numerical rating
appears (1-10).

l Content Searchable—True appears if the content can be found when someone
searches your website. However, even if content is not searchable, the Workarea
Advanced search still finds it.

Content Statuses

Content Properties
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l A (Approved)—Through the approval chain and published on the website.
l O (Checked Out)—Currently being edited; has not been checked in.
l I (Checked In)—Checked in for other users to edit.
l S (Submitted for Approval)—Saved and submitted into the approval chain.
l M (Marked for Deletion)—Requested for deletion.
l P (Pending Go Live Date)—Approved but the publish date has not occurred yet.
l T (Awaiting Completion of Associated Tasks)—Tasks assigned to content are not
complete.

l D (Pending Deletion)—Content was created with a future start date then checked in and
deleted. This status only remains until the start date is reached when the content is
deleted.

Other Content Information
l Properties tab—View the content’s properties.
l Content tab—Display and edit content.
l Summary tab—Edit content’s summary.
l Metadata tab—Edit content’s metadata.
l Alias tab—View and edit the content item’s primary alias, or view all secondary
aliases.

l Comment tab—View comments on changes made when editing content. This comment
also appears on the View Content and Content History screens. Use it to help distinguish
one version from another.

l Tasks tab—Add or edit tasks for this content.
l Web Alerts tab—Add or edit Web Alerts for this content.
l Templates tab—The template currently assigned to the content.
l Category tab—Any taxonomy categories currently assigned to the content. Only
appears if at least 1 taxonomy is applied to the folder in which the content resides.

l Edit—Open content for editing.
l —View older versions of content; restore older version.

l —Toggle display between published and staged versions

l —Compare current and earlier versions of content.
l —Delete content.

l —View and edit permissions for content.

l —View and possibly edit the content's approval chain.
l —Find all content with Quicklinks to this content.

l —Attach a task to content.

l —View Analytics for this content.
l —Displays the content item's rating and reviews, messages, and flags.
l —View and edit content's Content Searchable check box and flagging definitions.

l —Go back to previous menu

l —Determines if content will be included when an .xlf file is created.

Other Content Information
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l —Copy content to XLIFF files that can be submitted to a translation agency.
l View (language)—If you can view content in more than one language, select a
language from the drop-down list.

l Add-select language—Lets you copy current content into a new item and translate it to
selected language.

Creating New Content
1. In the Workarea, go to the folder in which you want to create a new content item.
2. Choose a type of content from the New menu. (For example, choose New
> HTML Content. The Edit Content screen appears.

3. Specify a title and begin creating your new content item.

l Title—Enter a title for the content. It cannot include these characters: \ / * > < |
l Content Searchable—(Administrators) Check this box if this content should be
found when someone searches your website.

l Publish or Submit—Publish the content to the website. This action updates the
content in the database and exits the editor.
Only the last approver in the approval chain sees the Publish button.
Other users see Submit. If no approval chain is assigned to the content’s
folder, every authorized user sees Publish.

l —Check In—Save and check-in the content. This action updates the content in
the database and exits the editor. It does not submit the content into the approval
chain. Rather, it allows you and other users to continue changing it.

l —Undo Checkout—Close without saving changes. Return content to its state
prior to checkout.

Creating New Content
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l —Save—Save content without leaving the editor. It is a good idea to save your
work frequently. But, if you later click Cancel and exit the editor, you lose
changes saved by clicking this button.

l —Cancel—Close editor without saving changes. Leave content in checked out
state.

l —Preview—Preview current content within its template in a new browser.

Editing in Ektron
In some Workarea locations, the editor toolbar "floats," and you can drag it to any
screen location. In other locations, the toolbar is fixed at the top of the editor. When
your hover the cursor over editable content, a yellow border appears. When you
click the content, the border turns blue, and a floating editor toolbar appears.

You can edit content only for which you have permission and in one of the following
statuses:

l checked out by you
l checked in
l published
l submitted for your approval

You can edit HTML content, HTML forms, XML Smart Forms, add information about
content (summary, metadata, and so on), check in, submit, and publish content.

1. From the Workarea, click Content and navigate to the folder that contains content you
want to edit. If you do not know the folder location, you can find content using Action
> Search from the root folder.

2. Click the content you want to edit.
3. Click Edit. The editor appears.

Editor Notes

l Cut, copy, and paste are accessible through your browser. Right-click to choose them or
use keyboard shortcuts. The editor may modify pasted content, depending on tags that

Editing in Ektron
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an administrator sets in StyleConfig.js. For example, headings, bullets, and bolded
fonts may be maintained during a paste operation but the actual font may not.

IMPORTANT: When you paste content from another application, the editor formats
that content into valid, minimal HTML and retains as much formatting and styling as
possible. However, results are browser-dependent.

l Paste HTML content into the Source Viewer.
l Your browser checks spelling. If your browser does not support it, find and install a
plug-in to do it.

l Use the Inspector to perform advanced actions on content items (images, hyperlink,
paragraphs, and so on). If enabled, the Inspector appears at the bottom of the editor.
Click to open, set values, then click the minimize button.

Applying Styles
To apply inline styles and classes to text, use the styling toolbar.

Applying Styles
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You can select paragraphs or individual words, then use styling toolbar buttons to
style the selected text. Click the down arrow in the toolbar's lower right to view
additional buttons. Styling buttons are context-sensitive, so they vary according to
cursor location, which format toolbar button is selected, and whether any text is
selected. For example, within the editor, select the text critical issue and click
Span ( ). Next, open the styling toolbar, and click one or more buttons to apply

styling.

Removing Styling from Text
1. Select the text to which the styling is applied.
2. Click the down arrow in the toolbar's lower right.
3. Click Remove styling.

Working with Links
This section shows you how to view, insert, or delete a link in content.

Viewing a Link
1. Click the cursor on the linked text or image.
2. Open the Inspector ( ) on the Review tab to view the link's properties.

Removing Styling from Text
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3. Use the dialog to modify the link's properties.

Inserting a Link to Text
1. Highlight text that you want to become a hyperlink.
2. Click Link ( ) on the Format tab. (If you click Link on an empty space, a link appears

in the content as New Link.)

3. In the link field, enter the desired URL and press Enter. The selected text becomes a
hyperlink.

4. To enter additional link properties, select linked text and open the Inspector ( ) on
the Review tab.

Inserting a Link to an Image
1. Click an image that you want to become a hyperlink.

Inserting a Link to Text
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NOTE: You know that you selected an image if you see an <IMG> tag in the
Inspector.

2. Open the Inspector ( ) on the Review tab.

3. Click Add hyperlink to Image.
4. Click the <A> tag.

5. Enter hyperlink information.

Editing a Link
1. Click the linked item. The link destination appears in the toolbar.
2. Edit the link text as needed.

Removing a Link
1. Click the linked item. The link destination appears in the toolbar.

2. Click Break Link ( ). The link is removed.

Adding a Bookmark
Use a bookmark to let a site visitor go from any word or phrase to another place in
the same content block. On your Web page, text appears in a different color to
indicate the bookmark.

Bookmarks are particularly helpful on a long page. For example, your Web page
contains minutes from several meetings, and the top of the page lists meeting
dates. You could assign a hyperlink to each date, and a bookmark to each set of
minutes. A site visitor can click any date to go to those minutes (using the
bookmark).

Editing a Link
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To use a bookmark, you create 2 things:

l a source—text a user clicks to jump to the bookmark
l a destination—the location to which the cursor jumps when the source is clicked

For example, place the text [ Top ] [ Bottom ] at the top and bottom of a content
block. The following procedure shows how to create bookmarks so that clicking [ 
Top ] at the bottom of the page jumps to the top of the page, and clicking on [ 
Bottom ] at the top of the page jumps to the bottom of the page.

1. Create the bookmark's (destination).
a. At the bottom of the page, insert then highlight the destination text, in this case [ 
Top ].

b. On the editor toolbar, choose Insert > Bookmark ( ). A bookmark icon displays
next to the source text but does not show up on the Web page.

c. Click the bookmark icon then the Inspector ( ) on the Review tab. A dialog
displays the bookmark options.

d. Specify the title, PageTop.
e. Repeat steps a through d for [ Bottom ] at the bottom of the content, and give it

the Title of PageBottom.
2. Create links to the bookmarks.

a. Highlight the source text. In this example, [ Top ] at the bottom of the content.
b. Choose Format > Insert Link ( ). The text is selected.
c. Double click the selected text.
d. Open the Inspector ( ) on the Review tab.

e. Choose Existing Bookmark. A drop-down list appears from which you can select
a bookmark.

f. Choose PageTop from the drop down list.
g. Repeat steps a through d for [ Bottom ] at the top of the content, and choose
PageBottom from the drop-down list.

Working with Tables
This section describes how to insert and edit tables.

You can use Tab to move from one cell to the next. If you are on the last cell, Tab
creates a new row. Use Shift/Tab to move backwards.

Inserting a Table
1. From the toolbar's Insert tab, click Table ( ). A table dialog box appears.
2. Drag the cursor over rows and columns to indicate the table size. The following example

shows 5 columns and 5 rows.

Working with Tables
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3. Click the mouse. The table is inserted.

Applying Table Properties
Use the Inspector ( ) on the Review tab to apply properties to a table, a table row
(TR), or a single cell (TD).

Adding a Table Caption

Applying Table Properties
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1. Hover the cursor over the top left corner and click the table handle.

2. In the toolbar, the Table tab is selected.
3. Enter the caption in the text box and click the Table caption button ( ).

Alternatively, you can enter a table caption in the Inspector.

Modifying Rows and Columns
Click the gray area beside a table row or above a table column. Your selection is
highlighted.

You can use the following table functions on selected rows/columns:

l —Add column to the left
l —Add column to the right

l —Add row below

l —Add row above
l —Delete column
l —Delete row
l —Format column as header (create a 508-compliant table without modifying the
source)

l —Format row as header (create a 508-compliant table without modifying the source)

Modifying Rows and Columns
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l —Merge cells
l —Split cells
l —Table caption; when you click on this, Table caption appears above the table.
Modify text as desired.

l Text Box—Add a summary that visually impaired users can access with a screen reader.
The summary does not appear in the editor or on a Web page.

IMPORTANT: When you save and publish your content, your site styling is applied.
Therefore, a table in the Workarea may appear differently from a table you edit in
context.

Table with merged cells:

NOTE: To split a merged cell, select the column or row of the merged cell before clicking
Split.

Modifying a Table Style
With the Inspector open, click anywhere in a table to view styles and advanced
properties you can apply.

In the following example, a 3x3 table was created. Clicking in a cell, the nested tag
structure shows the following:

Modifying a Table Style
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Click any tag to see styles you can apply to it. For example, click to see
table properties. The following image shows the table size reduced to 25%.

Moving a Table
When you make a table the content focus (a colored bar appears around the table),
a tab appears above the table's left top corner. Use the tab to drag the table to
another place in your content. You can also move a table in Source Viewer.

Deleting a Table

Moving a Table
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1. Select the table.
2. Click the handle.

3. Press Delete.
You can also delete a table from Source View, and easily collapse the entire table to
delete it in one line of HTML.

Working with Images
The easiest way to insert an image into content is by dragging and dropping it from a
Windows Explorer window. You can also

l insert an image that has been saved to the Library or as an asset, or
l add a new image to the Library while inserting it into content

Inserting an Image using Drag and Drop
You can drag-and-drop an image from your computer into Ektron content using a file
browser. Dropped images are added to the Library for future reuse. Dropped images
must have one of these extensions: .jpg, .gif, or .png, and cannot exceed 5 MB.

When dragging and dropping, the file name becomes the item's title, and no other
library information is collected (for example, its summary and metadata). Once the
content is saved, use the Edit Library screen to add information for the new library
item.

Inserting an Image Using the Library
1. Place the cursor where you want the image to appear.

2. Click Library ( ) in the Insert menu. The Library screen appears.
3. From the left panel, navigate to the folder containing the image you want to insert. If

you do not know its folder, use Search ( ) to find an image by title, description, or

internal file name.

NOTE: If the file is not in the library, you can insert it by clicking the Add Library
button > Browse and navigating to the file. Then, enter a title and optionally a
description and metadata information. The file is inserted into the content and added
to the library.

Working with Images
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4. Select Images from the content type drop-down.

5. Select an image and click Insert ( ). The image is inserted into the content. (You can
also double-click the image.)

Alternatively, you can insert a miniature version of the image, called a
thumbnail, by clicking the thumbnail button ( ). When the thumbnail appears
on a Web page, a site visitor clicks it to view a full-sized image.

Editing Images
After inserting an image, you can adjust its properties by opening the Inspector (
) on the Review tab.

The Inspector’s Advanced tab lets you modify the image size, position, wrapping,
and so on, and lets you select images that change based on breakpoints for viewing
modes of your users. For example, click Responsive Image Selection > Change
and select an image to display when screen resolution is 275 pixels or fewer.

Editing Images
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If you reduce the size of the editing window to under 276 pixels, the editor
automatically switches to the smaller picture.

Editing Images
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Adjusting Image Size
In the Inspector, the Basic and Advanced tabs have a field for adjusting image size.

Adjusting Image Size
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l Basic tab—Use the Size slider to specify a percentage of the original image. The Size
is calculated as pixels and stored in the <img> tag as a style attribute.

l Advanced tab—the Size > Width field represents a percentage of the parent
container. This number is stored in the <img> tag as is.

Deleting an Image
1. Select the image.
2. Open the Inspector ( ) on the Review tab.

NOTE: You know that you selected an image if an <IMG> tag appears in the
Inspector.

3. Click Delete image.

Viewing and Editing HTML Source Content
To view and edit the HTML source, click View Source ( ) on the Review tab. The
Source Viewer appears. As you edit the HTML, the content window dynamically
updates with your changes.

When you finish editing in the Source Viewer, click the X in the top right corner.

The Source Viewer supports tag completion. For example, if you type <p>, the
Source Viewer automatically adds a closing </p> tag.

The Source Viewer supports collapsing and expanding tags. For example, if a table is
in the content, a small arrow appears next to the line numbers. Click the arrow to
expand or collapse the nested tags.

Deleting an Image
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Embedding External Content
You can embed the following types of external content into the editor.

l YouTube
l Vimeo
l DailyMotion
l Google Maps

You can also insert content using its <embed> or <object> code.

Embedded elements are treated responsively. This means that a video or map is
sized according to the device on which it is viewed.

PREREQUISITE

You need the URL of the media item that you want to embed. Content
providers typically supply an easy way to find the content's URL. For
example, to find a YouTube video, click Share, then copy the URL.

Embedding External Content
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1. On the editor toolbar, click the Insert tab then Insert Embedded Media ( ). The
Insert Embedded Media screen appears.

Embedding External Content
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2. Use the Select the Media Source pulldown to select a media source.

3. Insert the URL for the content that you want to embed.
To embed content from another source, choose Other in the Select the Media
Source pulldown, then insert the code.

Embedding External Content
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4. Click Embed. The media is embedded in the content.

Embedding a Google Map
Click the Share link. Then copy the text in the Paste HTML to embed in website
field and paste it into the Embed Source field.

Embedding aGoogleMap
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To modify the map before inserting it, click the Customize and preview
embedded map link. You can change the size, view, and zoom. When finished,
copy the HTML from the bottom of the screen and paste it to the Embed Source
field.

Embedding a Vimeo Video
When embedding a Vimeo video, use the URL in the browser address bar.

Removing External Content
1. On the Review tab, click the View Source button ( ). Source Viewer appears.
2. Find and delete content between the opening and closing <div class="embed-

container> tags that surround the video. An example is below.
<div class="embed-container">
<iframe marginheight="0" marginwidth="0"

Embedding a Vimeo Video
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src="https://maps.google.com/maps?f=q&amp;source=s_q&amp;

hl=en&amp;geocode=&amp;q=542+Amherst+Street,+Nashua,+NH&amp;aq=0&amp;oq=542&amp;sl
l=42.752811,
-
71.49671&amp;sspn=0.203443,0.308647&amp;ie=UTF8&amp;hq=&amp;hnear=542+Amherst+St,+
Nashua,+New+Hampshire+03063
&amp;t=h&amp;ll=42.796156,-
71.573181&amp;spn=0.120922,0.219727&amp;z=12&amp;iwloc=A&amp;output=embed"
frameborder="0" height="480" scrolling="no"
width="640"></iframe>
<br/><small><a href="https://maps.google.com/maps?f=q&amp;
source=embed&amp;hl=en&amp;geocode=&amp;q=542+Amherst+Street,
+Nashua,+NH&amp;aq=0&amp;oq=542&amp;sll=42.752811,-
71.49671&amp;sspn=0.203443,0.308647&amp;
ie=UTF8&amp;hq=&amp;hnear=542+Amherst+St,+Nashua,+New+Hampshire+03063&amp;t=h&amp;
ll=42.796156,-71.573181&amp;spn=0.120922,0.219727&amp;z=12&amp;iwloc=A"
style="color:#0000FF;text-align:left">View Larger Map</a></small>
</div>

Removing External Content
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